<!DOCTYPE html>
<html lang="en-US">
	<head>
				<meta charset="UTF-8" />
		<meta name="viewport" content="width=device-width, initial-scale=1, maximum-scale=1.0, minimal-ui">
				<title>Magisk developer says Android Q root access could be hard - 9to5Google</title>
<!-- Jetpack Site Verification Tags -->
<meta name="google-site-verification" content="Htm3pGW8rcBX6wK35FZMBNMbpuieOZ5c8F489axa8nw" />
<meta name="msvalidate.01" content="808CE29E29F1230249D24A893DE871FB" />
		<script src="https://9to5google.com/wp-content/themes/9to5-2015/assets/js/adsbygoogle.js"></script>

               <!-- Google Tag Manager -->
		<script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
				new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
				j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
				'https://www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
			})(window,document,'script','dataLayer','GTM-THGGVXB');</script>
		<!-- End Google Tag Manager -->
			
<!-- This site is optimized with the Yoast SEO Premium plugin v9.5 - https://yoast.com/wordpress/plugins/seo/ -->
<link rel="canonical" href="https://9to5google.com/2019/03/13/android-q-root-magisk-trouble/" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:description" content="Root has been a part of the Android community for years and years now, and it was looking like Android Q wouldn&#8217;t be the end of it. However, just a few hours after the first beta for Android Q launched, it&#8217;s been discovered that getting root access on the latest version might be a bit [&hellip;]" />
<meta name="twitter:title" content="Magisk developer says Android Q root access could be hard - 9to5Google" />
<meta name="twitter:site" content="@9to5Google" />
<meta name="twitter:image" content="https://9to5google.com/wp-content/uploads/sites/4/2019/03/android_q_beta_logo_1.jpg?quality=82&#038;strip=all" />
<meta name="twitter:creator" content="@9to5Google" />
<script type='application/ld+json'>{"@context":"https://schema.org","@type":"Organization","url":"https://9to5google.com/","sameAs":["https://www.facebook.com/pages/9to5Google/218132111544562","https://www.instagram.com/9to5google","https://www.youtube.com/c/9to5google","https://twitter.com/9to5Google"],"@id":"https://9to5google.com/#organization","name":"9to5Google","logo":"https://9to5google.com/wp-content/uploads/sites/4/2018/09/9to5-google-logo.png"}</script>
<!-- / Yoast SEO Premium plugin. -->

<link rel='dns-prefetch' href='//s0.wp.com' />
<link rel='dns-prefetch' href='//pagead2.googlesyndication.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="9to5Google &raquo; Feed" href="https://9to5google.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="9to5Google &raquo; Comments Feed" href="https://9to5google.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="9to5Google &raquo; Android Q changes could spell trouble for root access, says Magisk developer Comments Feed" href="https://9to5google.com/2019/03/13/android-q-root-magisk-trouble/feed/" />
		<link href="https://9to5google.com/wp-content/themes/9to5-2015/images/favicons/9to5google/9to5google-touch-icon-iphone.png" rel="apple-touch-icon" />
		<link href="https://9to5google.com/wp-content/themes/9to5-2015/images/favicons/9to5google/9to5google-touch-icon-ipad.png" rel="apple-touch-icon" sizes="152x152" />
		<link href="https://9to5google.com/wp-content/themes/9to5-2015/images/favicons/9to5google/9to5google-touch-icon-ipad-retina.png" rel="apple-touch-icon" sizes="167x167" />
		<link href="https://9to5google.com/wp-content/themes/9to5-2015/images/favicons/9to5google/9to5google-touch-icon-iphone-retina.png" rel="apple-touch-icon" sizes="180x180" />
		<link href="https://9to5google.com/wp-content/themes/9to5-2015/images/favicons/9to5google/9to5google-icon-hires.png" rel="icon" sizes="192x192" />
		<link href="https://9to5google.com/wp-content/themes/9to5-2015/images/favicons/9to5google/9to5google-icon-normal.png" rel="icon" sizes="128x128" />
	
<!-- Jetpack Open Graph Tags -->
<meta property="og:type" content="article" />
<meta property="og:title" content="Android Q changes could spell trouble for root access, says Magisk developer" />
<meta property="og:url" content="https://9to5google.com/2019/03/13/android-q-root-magisk-trouble/" />
<meta property="og:description" content="Root has been a part of the Android community for years and years now, and it was looking like Android Q wouldn&#8217;t be the end of it. However, just a few hours after the first beta for Android …" />
<meta property="article:published_time" content="2019-03-14T03:05:11+00:00" />
<meta property="article:modified_time" content="2019-03-14T03:05:11+00:00" />
<meta property="og:site_name" content="9to5Google" />
<meta property="og:image" content="https://9to5google.com/wp-content/uploads/sites/4/2019/03/android_q_beta_logo_1.jpg?quality=82&#038;strip=all&#038;w=1600" />
<meta property="og:image:width" content="1600" />
<meta property="og:image:height" content="800" />
<meta property="og:image:alt" content="Android Q Beta" />
<meta property="og:locale" content="en_US" />
<meta name="twitter:creator" content="@NexusBen" />
<meta name="twitter:text:title" content="Android Q changes could spell trouble for root access, says Magisk developer" />
<meta name="twitter:image" content="https://9to5google.com/wp-content/uploads/sites/4/2019/03/android_q_beta_logo_1.jpg?quality=82&#038;strip=all&#038;w=1600" />
<meta name="twitter:image:alt" content="Android Q Beta" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:site" content="@9to5google" />

<!-- End Jetpack Open Graph Tags -->
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/11.2.0\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/11.2.0\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/9to5google.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.1.1"}};
			!function(a,b,c){function d(a,b){var c=String.fromCharCode;l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,a),0,0);var d=k.toDataURL();l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,b),0,0);var e=k.toDataURL();return d===e}function e(a){var b;if(!l||!l.fillText)return!1;switch(l.textBaseline="top",l.font="600 32px Arial",a){case"flag":return!(b=d([55356,56826,55356,56819],[55356,56826,8203,55356,56819]))&&(b=d([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]),!b);case"emoji":return b=d([55358,56760,9792,65039],[55358,56760,8203,9792,65039]),!b}return!1}function f(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var g,h,i,j,k=b.createElement("canvas"),l=k.getContext&&k.getContext("2d");for(j=Array("flag","emoji"),c.supports={everything:!0,everythingExceptFlag:!0},i=0;i<j.length;i++)c.supports[j[i]]=e(j[i]),c.supports.everything=c.supports.everything&&c.supports[j[i]],"flag"!==j[i]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[j[i]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(h=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",h,!1),a.addEventListener("load",h,!1)):(a.attachEvent("onload",h),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),g=c.source||{},g.concatemoji?f(g.concatemoji):g.wpemoji&&g.twemoji&&(f(g.twemoji),f(g.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='all-css-0' href='https://9to5google.com/wp-includes/css/dist/block-library/style.min.css?m=1552442177g' type='text/css' media='all' />
<link crossorigin="anonymous" rel='stylesheet' id='googleFonts-css'  href='https://fonts.googleapis.com/css?family=Roboto%3A300%2C300italic%2C400%2C400italic%2C500%2C500italic%7CQuestrial&#038;ver=5.1.1' type='text/css' media='all' />
<link rel='stylesheet' id='all-css-2' href='https://9to5google.com/_static/??-eJyVjcEKwjAQRH/IdJvQgB7Eb1mSpY1u0uKuSP7eoFR6Eexthpk3A8/FhLkoFQWdKJPASWdvXG89oAipQBAB4RRuXVMH2EOYd2Mfp5VJupzKF0sl8CPSJ48oU2pDPypXgUwxIXG7aFdbszBWuhumEUP9D2/Z1q/QJZ+t924YnD32L+PvdMs=' type='text/css' media='all' />
<script type='text/javascript'>
/* <![CDATA[ */
var _wpmejsSettings = {"pluginPath":"\/wp-includes\/js\/mediaelement\/","classPrefix":"mejs-","stretching":"responsive"};
/* ]]> */
</script>
<script type='text/javascript' src='https://9to5google.com/_static/??-eJzTLy/QzcxLzilNSS3WzwKiwtLUokoopZdVrKOPT4FubmZ6UWJJql5uZh5QsX2uraGpqZGJiZGhhUEWACVeIKY='></script>
<script type='text/javascript'>
var mejsL10n = {"language":"en","strings":{"mejs.install-flash":"You are using a browser that does not have Flash player enabled or installed. Please turn on your Flash player plugin or download the latest version from https:\/\/get.adobe.com\/flashplayer\/","mejs.fullscreen-off":"Turn off Fullscreen","mejs.fullscreen-on":"Go Fullscreen","mejs.download-video":"Download Video","mejs.fullscreen":"Fullscreen","mejs.time-jump-forward":["Jump forward 1 second","Jump forward %1 seconds"],"mejs.loop":"Toggle Loop","mejs.play":"Play","mejs.pause":"Pause","mejs.close":"Close","mejs.time-slider":"Time Slider","mejs.time-help-text":"Use Left\/Right Arrow keys to advance one second, Up\/Down arrows to advance ten seconds.","mejs.time-skip-back":["Skip back 1 second","Skip back %1 seconds"],"mejs.captions-subtitles":"Captions\/Subtitles","mejs.captions-chapters":"Chapters","mejs.none":"None","mejs.mute-toggle":"Mute Toggle","mejs.volume-help-text":"Use Up\/Down Arrow keys to increase or decrease volume.","mejs.unmute":"Unmute","mejs.mute":"Mute","mejs.volume-slider":"Volume Slider","mejs.video-player":"Video Player","mejs.audio-player":"Audio Player","mejs.ad-skip":"Skip ad","mejs.ad-skip-info":["Skip in 1 second","Skip in %1 seconds"],"mejs.source-chooser":"Source Chooser","mejs.stop":"Stop","mejs.speed-rate":"Speed Rate","mejs.live-broadcast":"Live Broadcast","mejs.afrikaans":"Afrikaans","mejs.albanian":"Albanian","mejs.arabic":"Arabic","mejs.belarusian":"Belarusian","mejs.bulgarian":"Bulgarian","mejs.catalan":"Catalan","mejs.chinese":"Chinese","mejs.chinese-simplified":"Chinese (Simplified)","mejs.chinese-traditional":"Chinese (Traditional)","mejs.croatian":"Croatian","mejs.czech":"Czech","mejs.danish":"Danish","mejs.dutch":"Dutch","mejs.english":"English","mejs.estonian":"Estonian","mejs.filipino":"Filipino","mejs.finnish":"Finnish","mejs.french":"French","mejs.galician":"Galician","mejs.german":"German","mejs.greek":"Greek","mejs.haitian-creole":"Haitian Creole","mejs.hebrew":"Hebrew","mejs.hindi":"Hindi","mejs.hungarian":"Hungarian","mejs.icelandic":"Icelandic","mejs.indonesian":"Indonesian","mejs.irish":"Irish","mejs.italian":"Italian","mejs.japanese":"Japanese","mejs.korean":"Korean","mejs.latvian":"Latvian","mejs.lithuanian":"Lithuanian","mejs.macedonian":"Macedonian","mejs.malay":"Malay","mejs.maltese":"Maltese","mejs.norwegian":"Norwegian","mejs.persian":"Persian","mejs.polish":"Polish","mejs.portuguese":"Portuguese","mejs.romanian":"Romanian","mejs.russian":"Russian","mejs.serbian":"Serbian","mejs.slovak":"Slovak","mejs.slovenian":"Slovenian","mejs.spanish":"Spanish","mejs.swahili":"Swahili","mejs.swedish":"Swedish","mejs.tagalog":"Tagalog","mejs.thai":"Thai","mejs.turkish":"Turkish","mejs.ukrainian":"Ukrainian","mejs.vietnamese":"Vietnamese","mejs.welsh":"Welsh","mejs.yiddish":"Yiddish"}};
</script>
<script type='text/javascript' src='https://9to5google.com/wp-includes/js/mediaelement/mediaelement-and-player.min.js?ver=4.2.6-78496d1'></script>
<script type='text/javascript' src='https://9to5google.com/wp-includes/js/mediaelement/mediaelement-migrate.min.js?m=1552442180g'></script>
<link rel='https://api.w.org/' href='https://9to5google.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://9to5google.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://9to5google.com/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress 5.1.1" />
<link rel='shortlink' href='https://wp.me/p9SZ9T-1a1s' />
<link rel="alternate" type="application/json+oembed" href="https://9to5google.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2F9to5google.com%2F2019%2F03%2F13%2Fandroid-q-root-magisk-trouble%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://9to5google.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2F9to5google.com%2F2019%2F03%2F13%2Fandroid-q-root-magisk-trouble%2F&#038;format=xml" />
<!-- Stream WordPress user activity plugin v3.2.3 -->

<link rel='dns-prefetch' href='//v0.wordpress.com'/>
<style type='text/css'>img#wpstats{display:none}</style>	<script type='text/javascript' src='https://www.googletagservices.com/tag/js/gpt.js' async></script>
	<script type='text/javascript' src='https://9to5google.com/wp-content/themes/9to5-2015/assets/js/vendor/prebid1.20.0.js' async></script>
	<script>
	!function(a9,a,p,s,t,A,g){if(a[a9])return;function q(c,r){a[a9]._Q.push([c,r])}a[a9]={init:function(){q("i",arguments)},fetchBids:function(){q("f",arguments)},setDisplayBids:function(){},targetingKeys:function(){return[]},_Q:[]};A=p.createElement(s);A.async=!0;A.src=t;g=p.getElementsByTagName(s)[0];g.parentNode.insertBefore(A,g)}("apstag",window,document,"script","//c.amazon-adsystem.com/aax2/apstag.js");
	</script>
	<script>
		window.googletag = window.googletag || {};
		var googletag = googletag || {};
		googletag.cmd = googletag.cmd || [];
	</script>

		<script type="text/javascript">
	var ninetofiveHeaderBidderData = {
		districtmTag: 13893414,
		districtmDmxTag: 242604,
		sovrn: [{"sizes":[[300,250]],"below_the_fold_id":586242},{"sizes":[[728,90]],"above_the_fold_id":586239,"below_the_fold_id":586243},{"sizes":[[970,250]],"above_the_fold_id":586240,"below_the_fold_id":586244},{"sizes":[[970,90]],"above_the_fold_id":586241,"below_the_fold_id":586245}],
		appnexus: [{"below_the_fold_sizes":[[728,90],[970,90],[970,250],[300,250]],"above_the_fold_sizes":[[728,90],[970,90],[970,250]],"below_the_fold_id":13866598,"above_the_fold_id":13866595}]	};

	var aboveTheFold = true;
	/**
	 *  Build ad units from bidding partners.
	 *
	 * @param {string}  slotID       The slot ID.
	 * @param {array}   sizes        The default sizes.
	 * @param {boolean} aboveTheFold Is the ad above the fold?
	 */
	var ninetofiveGetHeaderBidderAdUnits = function( slotID, sizes, aboveTheFold ) {
		adUnits = [];

		// District M
		adUnits.push( {
			code: slotID,
			mediaTypes: { banner: { sizes: sizes } },
			bids: [	{
				bidder: 'districtm',
				params: {
					placementId: ninetofiveHeaderBidderData.districtmTag
				}
			} ]
		} );

		// District M DMX
		adUnits.push( {
			code: slotID,
			mediaTypes: { banner: { sizes: sizes } },
			bids: [	{
				bidder: 'districtmDMX',
				params: {
					dmxid: ninetofiveHeaderBidderData.districtmDmxTag,
					memberid: 101574
				}
			} ]
		} );

		// Sovrn
		ninetofiveHeaderBidderData.sovrn.forEach( function( asovrn ) {
			adUnits.push( {
				code: slotID,
				mediaTypes: { banner: { sizes: asovrn.sizes } },
				bids: [	{
					bidder: 'sovrn',
					params: {
						tagid: ( aboveTheFold && asovrn.above_the_fold_id ) ?
							asovrn.above_the_fold_id :
							asovrn.below_the_fold_id
					}
				} ]
			} );

		} );

		// Sovrn
		ninetofiveHeaderBidderData.appnexus.forEach( function( anapnexus ) {
			adUnits.push( {
				code: slotID,
				mediaTypes: { banner: {
					sizes: aboveTheFold ? anapnexus.above_the_fold_sizes : anapnexus.below_the_fold_sizes
				} },
				bids: [	{
					bidder: 'appnexus',
					params: {
						placementId: ( aboveTheFold && anapnexus.above_the_fold_id ) ?
							anapnexus.above_the_fold_id :
							anapnexus.below_the_fold_id
					}
				} ]
			} );
		} );

		return adUnits;
	};
	</script>
	<link rel="mask-icon" color="#296700" href="https://9to5google.com/wp-content/themes/9to5-2015/images/9to5-clock.svg"><link rel="amphtml" href="https://9to5google.com/2019/03/13/android-q-root-magisk-trouble/amp/"><link rel="icon" href="https://9to5google.com/wp-content/uploads/sites/4/2017/03/favicon-bg-none-face-white.png?w=32" sizes="32x32" />
<link rel="icon" href="https://9to5google.com/wp-content/themes/9to5-2015/images/favicons/9to5google/9to5google-icon-hires.png" sizes="192x192" />
<link rel="apple-touch-icon-precomposed" href="https://9to5google.com/wp-content/themes/9to5-2015/images/favicons/9to5google/9to5google-touch-icon-iphone-retina.png" />
<meta name="msapplication-TileImage" content="https://9to5google.com/wp-content/uploads/sites/4/2017/03/favicon-bg-none-face-white.png?w=256" />

	<style>
		.th26688a03 { padding: 10px 0; text-align: center; background: url('https://9to5google.com/wp-content/themes/9to5-2015/images/top-leaderboard-bg.png') repeat center; min-height: 110px;}
		.th26688a03 .inlinead { background-color: transparent; min-height: 1px; }
		.th26688a03 .inlinead > div { background-color: transparent; padding: 0; }

		.color-scheme-electrek .th26688a03 { background-color: #939598; }

		.ad { margin: 0 auto; }

		@media (min-width: 0px) and (max-width: 767px) { .two-up-ads { display: none; } }

		.two-up-ads, .post-leaderboard { box-sizing: border-box; width: 100%; float: left; padding-left: 0.83333%; padding-right: 0.83333%; background-color: #ECECED; padding: 25px 0; }
		.two-up-ads .ad-1, .two-up-ads .ad-2, .post-leaderboard .ad-1, .post-leaderboard .ad-2 { display: inline-block; width: 300px; height: 250px; overflow: hidden; }
		.two-up-ads .ad-1, .post-leaderboard .ad-1 { box-sizing: border-box; width: 50%; float: left; padding-left: 0.83333%; padding-right: 0.83333%; text-align: right; }
		.two-up-ads .ad-2, .post-leaderboard .ad-2 { box-sizing: border-box; width: 50%; float: right; padding-left: 0.83333%; padding-right: 0.83333%; text-align: left; padding-left: 40px; }

		@media (min-width: 0px) and (max-width: 767px) { .post-leaderboard img { width: 100%; } }

		.post-leaderboard > * { margin: 0 auto; text-align: center; display: block; }

		/** inline ads **/
		.th004a243e { background-color: #DCDDDE; max-width: 100%; overflow: hidden; text-align: center; }\
		.th004a243e > div, .th004a243e > ins { padding: 20px 0; margin: 0 auto; }
		.enable-fallbacks .th004a243e > div, .enable-fallbacks .th004a243e > ins { padding: 0 0 0 0; }
		@media only screen and (min-width: 768px) { .th004a243e > div, .th004a243e > ins { display: block; padding: 25px 10px 25px 0; }
		.enable-fallbacks .th004a243e > div, .enable-fallbacks .th004a243e > ins { padding: 0 0 0 0; } }

		.post-body .th004a243e { background-color: transparent; }

		.thac813bb2 { width: 300px; height: 250px; }
		@media (min-device-width: 320px) and (max-device-width: 479px) { .thac813bb2 { width: 300px; height: 250px; } }
		@media (min-width: 500px) { .thac813bb2 { width: 320px; height: 400px; } }
		@media (min-device-width: 480px) and (max-device-width: 767px) { .thac813bb2 { width: 300px; height: 250px; } }
		@media (min-width: 768px) { .thac813bb2 { float: right; margin-left: 20px; width: 336px; height: 280px; } }
		@media (min-width: 1000px) {
               .thac813bb2 { margin: 0 -105px 20px 20px; }
               .aside-post .thac813bb2 { margin-top: 20px; }
          }
		.enable-fallbacks .thac813bb2 { display: none !important; }

		.th62e8808b { display: none; }
		.enable-fallbacks .th62e8808b { display: block; }
		.th62e8808b img { max-width: 100%; }

		.th62e8808b.th337395b7 { background: url('https://9to5google.com/wp-content/themes/9to5-2015/images/top-leaderboard-bg.png') repeat center; max-width: 100%; overflow: hidden; text-align: center; }
		.th62e8808b.th337395b7 > div { margin: 20px auto; padding: 0 0; }

		.th787debf9 { line-height: 0; max-width: 300px; position: relative; }
		.th787debf9 h3 { background: rgba(0, 0, 0, 0.7); bottom: 0; box-sizing: border-box; color: #fff; font-size: 1.17em; font-weight: 400; line-height: 1.3; margin: 0 0; padding: 0.25em 0.5em; position: absolute; text-align: left; width: 100%; }
		.post-body .th787debf9 h3 { font-size: 1em; }
		@media (min-width: 768px) { .post-body .th787debf9 { float: right; margin-left: 20px; width: 300px; height: 250px; } }
		@media (min-width: 1000px) { .post-body .th787debf9 { margin: 0 -105px 20px 20px; } }

		.th337395b7 .th787debf9 { margin: 0 auto; }
		.th6857532d { cursor: pointer }
          .th1880b217 { display: none; }
	</style>
	</head>
		<body class="post-template-default single single-post postid-276858 single-format-aside color-scheme-google infinite-scroll">
					<!-- Google Tag Manager (noscript) -->
		<noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-THGGVXB"
		                  height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
		<!-- End Google Tag Manager (noscript) -->
			
			<div></div>
			<header class="site-header js-header-normal" id="js-site-header">
				<div class="site-header-inner">

					<div class="header-logo">
						<a href="https://9to5google.com/" rel="home">
							<img src="https://9to5google.com/wp-content/uploads/sites/4/2018/10/cropped-new-9to5-google-logo.png" alt="" />
						</a>
						<button aria-expanded="false" aria-controls="js-site-switcher" id="js-button-switcher" class="js-button button-site-switcher">
									<svg class="ninetofive-icon chevron-down js-regular-icon" aria-hidden="true">
									<use
				xlink:href="https://9to5google.com/wp-content/themes/9to5-2015/images/svg-sprite-1.svg#ninetofive-icon-chevron-down"/>
		</svg>
											<svg class="ninetofive-icon chevron-up js-expanded-icon" aria-hidden="true">
									<use
				xlink:href="https://9to5google.com/wp-content/themes/9to5-2015/images/svg-sprite-1.svg#ninetofive-icon-chevron-up"/>
		</svg>
									<span class="screen-reader-text">Switch site</span>
						</button>
					</div>
					<!-- .header-logo -->

					<nav id="primary-menu" class="primary-menu">
						<button class="js-mobile-menu-prev js-button" id="js-mobile-menu-prev" data-direction="1">
									<svg class="ninetofive-icon chevron-left " aria-hidden="true">
									<use
				xlink:href="https://9to5google.com/wp-content/themes/9to5-2015/images/svg-sprite-1.svg#ninetofive-icon-chevron-left"/>
		</svg>
								</button>
						<button class="js-mobile-menu-next js-button" id="js-mobile-menu-next" data-direction="-1">
									<svg class="ninetofive-icon chevron-right " aria-hidden="true">
									<use
				xlink:href="https://9to5google.com/wp-content/themes/9to5-2015/images/svg-sprite-1.svg#ninetofive-icon-chevron-right"/>
		</svg>
								</button>
						<ul id="menu-guides" class="primary-menu-ul"><li id="menu-item-270499" class="menu-item menu-item-type-taxonomy menu-item-object-ninetofive_guides menu-item-270499"><a href="https://9to5google.com/guides/exclusives/">Exclusives</a></li>
<li id="menu-item-145933" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-145933"><a href="http://9to5google.com/guides">Guides</a>
<ul class="sub-menu">
	<li id="menu-item-190195" class="menu-item menu-item-type-taxonomy menu-item-object-ninetofive_guides menu-item-190195"><a href="https://9to5google.com/guides/google-corporate/">GOOG</a></li>
	<li id="menu-item-190186" class="menu-item menu-item-type-taxonomy menu-item-object-ninetofive_guides menu-item-190186"><a href="https://9to5google.com/guides/android/">Android</a></li>
	<li id="menu-item-190162" class="menu-item menu-item-type-taxonomy menu-item-object-ninetofive_guides menu-item-190162"><a href="https://9to5google.com/guides/android-basics/">Android Basics</a></li>
	<li id="menu-item-190191" class="menu-item menu-item-type-taxonomy menu-item-object-ninetofive_guides menu-item-190191"><a href="https://9to5google.com/guides/best-phones/">Best Phones</a></li>
	<li id="menu-item-244977" class="menu-item menu-item-type-taxonomy menu-item-object-ninetofive_guides menu-item-244977"><a href="https://9to5google.com/guides/google-pixel-3-xl/">Google Pixel 3 XL</a></li>
	<li id="menu-item-244979" class="menu-item menu-item-type-taxonomy menu-item-object-ninetofive_guides menu-item-244979"><a href="https://9to5google.com/guides/htc-u12/">HTC U12</a></li>
	<li id="menu-item-244978" class="menu-item menu-item-type-taxonomy menu-item-object-ninetofive_guides menu-item-244978"><a href="https://9to5google.com/guides/samsung-galaxy-s9/">Samsung Galaxy S9</a></li>
	<li id="menu-item-244980" class="menu-item menu-item-type-taxonomy menu-item-object-ninetofive_guides menu-item-244980"><a href="https://9to5google.com/guides/oneplus-6/">OnePlus 6</a></li>
	<li id="menu-item-244981" class="menu-item menu-item-type-taxonomy menu-item-object-ninetofive_guides menu-item-244981"><a href="https://9to5google.com/guides/oneplus-6t/">OnePlus 6T</a></li>
</ul>
</li>
<li id="menu-item-190111" class="menu-item menu-item-type-taxonomy menu-item-object-ninetofive_guides menu-item-has-children menu-item-190111"><a href="https://9to5google.com/guides/google/">Google</a>
<ul class="sub-menu">
	<li id="menu-item-244984" class="menu-item menu-item-type-taxonomy menu-item-object-ninetofive_guides menu-item-244984"><a href="https://9to5google.com/guides/google-pixel-2/">Google Pixel 2</a></li>
	<li id="menu-item-244985" class="menu-item menu-item-type-taxonomy menu-item-object-ninetofive_guides menu-item-244985"><a href="https://9to5google.com/guides/google-pixel-2-xl/">Google Pixel 2 XL</a></li>
	<li id="menu-item-244976" class="menu-item menu-item-type-taxonomy menu-item-object-ninetofive_guides menu-item-244976"><a href="https://9to5google.com/guides/google-pixel-3/">Google Pixel 3</a></li>
	<li id="menu-item-244983" class="menu-item menu-item-type-taxonomy menu-item-object-ninetofive_guides menu-item-244983"><a href="https://9to5google.com/guides/google-pixel-3-xl/">Google Pixel 3 XL</a></li>
	<li id="menu-item-190113" class="menu-item menu-item-type-taxonomy menu-item-object-ninetofive_guides menu-item-190113"><a href="https://9to5google.com/guides/google-home/">Google Home</a></li>
	<li id="menu-item-190114" class="menu-item menu-item-type-taxonomy menu-item-object-ninetofive_guides menu-item-190114"><a href="https://9to5google.com/guides/google-wifi/">Google Wifi</a></li>
	<li id="menu-item-190181" class="menu-item menu-item-type-taxonomy menu-item-object-ninetofive_guides menu-item-190181"><a href="https://9to5google.com/guides/google-daydream/">Google Daydream</a></li>
	<li id="menu-item-190115" class="menu-item menu-item-type-taxonomy menu-item-object-ninetofive_guides menu-item-190115"><a href="https://9to5google.com/guides/chromecast/">Chromecast</a></li>
	<li id="menu-item-190161" class="menu-item menu-item-type-taxonomy menu-item-object-ninetofive_guides menu-item-190161"><a href="https://9to5google.com/guides/nexus/">Nexus</a></li>
	<li id="menu-item-190622" class="menu-item menu-item-type-taxonomy menu-item-object-ninetofive_guides menu-item-190622"><a href="https://9to5google.com/guides/google-cardboard/">Google Cardboard</a></li>
	<li id="menu-item-190125" class="menu-item menu-item-type-taxonomy menu-item-object-ninetofive_guides menu-item-190125"><a href="https://9to5google.com/guides/nest/">Nest</a></li>
</ul>
</li>
<li id="menu-item-145656" class="menu-item menu-item-type-taxonomy menu-item-object-ninetofive_guides menu-item-has-children menu-item-145656"><a href="https://9to5google.com/guides/android/">Android</a>
<ul class="sub-menu">
	<li id="menu-item-190109" class="menu-item menu-item-type-taxonomy menu-item-object-ninetofive_guides menu-item-190109"><a href="https://9to5google.com/guides/samsung/">Samsung</a></li>
	<li id="menu-item-190107" class="menu-item menu-item-type-taxonomy menu-item-object-ninetofive_guides menu-item-190107"><a href="https://9to5google.com/guides/motorola/">Motorola</a></li>
	<li id="menu-item-190108" class="menu-item menu-item-type-taxonomy menu-item-object-ninetofive_guides menu-item-190108"><a href="https://9to5google.com/guides/lg/">LG</a></li>
	<li id="menu-item-190110" class="menu-item menu-item-type-taxonomy menu-item-object-ninetofive_guides menu-item-190110"><a href="https://9to5google.com/guides/htc/">HTC</a></li>
	<li id="menu-item-190116" class="menu-item menu-item-type-taxonomy menu-item-object-ninetofive_guides menu-item-190116"><a href="https://9to5google.com/guides/oneplus/">OnePlus</a></li>
	<li id="menu-item-190117" class="menu-item menu-item-type-taxonomy menu-item-object-ninetofive_guides menu-item-190117"><a href="https://9to5google.com/guides/lenovo/">Lenovo</a></li>
	<li id="menu-item-190118" class="menu-item menu-item-type-taxonomy menu-item-object-ninetofive_guides menu-item-190118"><a href="https://9to5google.com/guides/huawei/">Huawei</a></li>
	<li id="menu-item-190193" class="menu-item menu-item-type-taxonomy menu-item-object-ninetofive_guides menu-item-190193"><a href="https://9to5google.com/guides/asus/">Asus</a></li>
</ul>
</li>
<li id="menu-item-145938" class="menu-item menu-item-type-taxonomy menu-item-object-ninetofive_guides menu-item-145938"><a href="https://9to5google.com/guides/android-auto/">Auto</a></li>
<li id="menu-item-145657" class="menu-item menu-item-type-taxonomy menu-item-object-ninetofive_guides menu-item-145657"><a href="https://9to5google.com/guides/android-tv/">TV</a></li>
<li id="menu-item-145935" class="menu-item menu-item-type-taxonomy menu-item-object-ninetofive_guides menu-item-145935"><a href="https://9to5google.com/guides/wear-os/">Wear OS</a></li>
<li id="menu-item-145658" class="menu-item menu-item-type-taxonomy menu-item-object-ninetofive_guides menu-item-has-children menu-item-145658"><a href="https://9to5google.com/guides/google-chrome/">Chrome</a>
<ul class="sub-menu">
	<li id="menu-item-146068" class="menu-item menu-item-type-taxonomy menu-item-object-ninetofive_guides menu-item-146068"><a href="https://9to5google.com/guides/chromebook/">Chromebooks</a></li>
	<li id="menu-item-190119" class="menu-item menu-item-type-taxonomy menu-item-object-ninetofive_guides menu-item-190119"><a href="https://9to5google.com/guides/chromecast/">Chromecast</a></li>
	<li id="menu-item-190183" class="menu-item menu-item-type-taxonomy menu-item-object-ninetofive_guides menu-item-190183"><a href="https://9to5google.com/guides/chromecast-ultra/">Chromecast Ultra</a></li>
	<li id="menu-item-190184" class="menu-item menu-item-type-taxonomy menu-item-object-ninetofive_guides menu-item-190184"><a href="https://9to5google.com/guides/chromecast-audio/">Chromecast Audio</a></li>
</ul>
</li>
<li id="menu-item-145661" class="menu-item menu-item-type-taxonomy menu-item-object-ninetofive_guides menu-item-has-children menu-item-145661"><a href="https://9to5google.com/guides/youtube/">YouTube</a>
<ul class="sub-menu">
	<li id="menu-item-190174" class="menu-item menu-item-type-taxonomy menu-item-object-ninetofive_guides menu-item-190174"><a href="https://9to5google.com/guides/youtube-tv/">YouTube TV</a></li>
	<li id="menu-item-190175" class="menu-item menu-item-type-taxonomy menu-item-object-ninetofive_guides menu-item-190175"><a href="https://9to5google.com/guides/youtube-kids/">YouTube Kids</a></li>
	<li id="menu-item-190176" class="menu-item menu-item-type-taxonomy menu-item-object-ninetofive_guides menu-item-190176"><a href="https://9to5google.com/guides/youtube-red/">YouTube Red</a></li>
</ul>
</li>
<li id="menu-item-190122" class="menu-item menu-item-type-taxonomy menu-item-object-ninetofive_guides menu-item-has-children menu-item-190122"><a href="https://9to5google.com/guides/alphabet/">Alphabet</a>
<ul class="sub-menu">
	<li id="menu-item-190126" class="menu-item menu-item-type-taxonomy menu-item-object-ninetofive_guides menu-item-190126"><a href="https://9to5google.com/guides/waymo/">Waymo</a></li>
	<li id="menu-item-190127" class="menu-item menu-item-type-taxonomy menu-item-object-ninetofive_guides menu-item-190127"><a href="https://9to5google.com/guides/verily-life-sciences/">Verily Life Sciences</a></li>
	<li id="menu-item-190137" class="menu-item menu-item-type-taxonomy menu-item-object-ninetofive_guides menu-item-190137"><a href="https://9to5google.com/guides/calico/">Calico</a></li>
	<li id="menu-item-190138" class="menu-item menu-item-type-taxonomy menu-item-object-ninetofive_guides menu-item-190138"><a href="https://9to5google.com/guides/deepmind/">DeepMind</a></li>
	<li id="menu-item-190139" class="menu-item menu-item-type-taxonomy menu-item-object-ninetofive_guides menu-item-190139"><a href="https://9to5google.com/guides/jigsaw/">Jigsaw</a></li>
	<li id="menu-item-190142" class="menu-item menu-item-type-taxonomy menu-item-object-ninetofive_guides menu-item-190142"><a href="https://9to5google.com/guides/google-ventures/">Google Ventures</a></li>
	<li id="menu-item-190145" class="menu-item menu-item-type-taxonomy menu-item-object-ninetofive_guides menu-item-190145"><a href="https://9to5google.com/guides/google-fiber/">Google Fiber</a></li>
	<li id="menu-item-190147" class="menu-item menu-item-type-taxonomy menu-item-object-ninetofive_guides menu-item-190147"><a href="https://9to5google.com/guides/access-and-energy/">Access &amp; Energy</a></li>
</ul>
</li>
<li id="menu-item-190149" class="menu-item menu-item-type-taxonomy menu-item-object-ninetofive_guides menu-item-has-children menu-item-190149"><a href="https://9to5google.com/guides/g-suite/">G Suite</a>
<ul class="sub-menu">
	<li id="menu-item-190151" class="menu-item menu-item-type-taxonomy menu-item-object-ninetofive_guides menu-item-190151"><a href="https://9to5google.com/guides/gmail/">Gmail</a></li>
	<li id="menu-item-190152" class="menu-item menu-item-type-taxonomy menu-item-object-ninetofive_guides menu-item-190152"><a href="https://9to5google.com/guides/google-calendar/">Google Calendar</a></li>
	<li id="menu-item-190153" class="menu-item menu-item-type-taxonomy menu-item-object-ninetofive_guides menu-item-190153"><a href="https://9to5google.com/guides/google-docs/">Google Docs</a></li>
	<li id="menu-item-190154" class="menu-item menu-item-type-taxonomy menu-item-object-ninetofive_guides menu-item-190154"><a href="https://9to5google.com/guides/google-plus/">Google Plus</a></li>
	<li id="menu-item-190155" class="menu-item menu-item-type-taxonomy menu-item-object-ninetofive_guides menu-item-190155"><a href="https://9to5google.com/guides/hangouts/">Google Hangouts</a></li>
	<li id="menu-item-190156" class="menu-item menu-item-type-taxonomy menu-item-object-ninetofive_guides menu-item-190156"><a href="https://9to5google.com/guides/google-drive/">Google Drive</a></li>
	<li id="menu-item-190157" class="menu-item menu-item-type-taxonomy menu-item-object-ninetofive_guides menu-item-190157"><a href="https://9to5google.com/guides/google-keep/">Google Keep</a></li>
	<li id="menu-item-190158" class="menu-item menu-item-type-taxonomy menu-item-object-ninetofive_guides menu-item-190158"><a href="https://9to5google.com/guides/google-vault/">Google Vault</a></li>
	<li id="menu-item-190159" class="menu-item menu-item-type-taxonomy menu-item-object-ninetofive_guides menu-item-190159"><a href="https://9to5google.com/guides/jamboard/">Jamboard</a></li>
</ul>
</li>
<li id="menu-item-190188" class="menu-item menu-item-type-taxonomy menu-item-object-ninetofive_featured menu-item-190188"><a href="https://9to5google.com/feature/videos/">Videos</a></li>
</ul>					</nav>
					<!-- .primary-menu -->

					<div class="header-right-area">

						<button class="main-menu-toggle js-button" id="js-main-menu-toggle" aria-expanded="false" aria-controls="primary-menu">
									<svg class="ninetofive-icon hamburger js-regular-icon" aria-hidden="true">
									<use
				xlink:href="https://9to5google.com/wp-content/themes/9to5-2015/images/svg-sprite-1.svg#ninetofive-icon-hamburger"/>
		</svg>
											<svg class="ninetofive-icon cross js-expanded-icon" aria-hidden="true">
									<use
				xlink:href="https://9to5google.com/wp-content/themes/9to5-2015/images/svg-sprite-1.svg#ninetofive-icon-cross"/>
		</svg>
									<span class="screen-reader-text">Toggle main menu</span>
						</button>

						<div class="header-social" id="js-header-social">
							<a href="https://www.youtube.com/c/9to5google" title="View 9to5 on YouTube">
		<svg class="ninetofive-icon youtube " aria-hidden="true">
									<use
				xlink:href="https://9to5google.com/wp-content/themes/9to5-2015/images/svg-sprite-1.svg#ninetofive-icon-youtube"/>
		</svg>
		</a>
<a href="https://www.facebook.com/pages/9to5Google/218132111544562" title="Like us on Facebook">
		<svg class="ninetofive-icon facebook " aria-hidden="true">
									<use
				xlink:href="https://9to5google.com/wp-content/themes/9to5-2015/images/svg-sprite-1.svg#ninetofive-icon-facebook"/>
		</svg>
		</a>
<a href="http://twitter.com/9to5google" title="Follow us on Twitter">
		<svg class="ninetofive-icon twitter " aria-hidden="true">
									<use
				xlink:href="https://9to5google.com/wp-content/themes/9to5-2015/images/svg-sprite-1.svg#ninetofive-icon-twitter"/>
		</svg>
		</a>
<a href="http://instagram.com/9to5google" title="Follow us on Instagram">
		<svg class="ninetofive-icon instagram " aria-hidden="true">
									<use
				xlink:href="https://9to5google.com/wp-content/themes/9to5-2015/images/svg-sprite-1.svg#ninetofive-icon-instagram"/>
		</svg>
		</a>
<a href="https://itunes.apple.com/us/podcast/alphabet-scoop/id1359922601?mt=2" title="Subscribe to our weekly podcast">
		<svg class="ninetofive-icon podcast " aria-hidden="true">
									<use
				xlink:href="https://9to5google.com/wp-content/themes/9to5-2015/images/svg-sprite-1.svg#ninetofive-icon-podcast"/>
		</svg>
		</a>
<div class="header-social-more" id="js-header-social-more" aria-hidden="true"><a href="https://apple.news/TMzMaigopSFChmI1nDK60mg" title="View 9to5 on Apple News">
		<svg class="ninetofive-icon applenews " aria-hidden="true">
									<use
				xlink:href="https://9to5google.com/wp-content/themes/9to5-2015/images/svg-sprite-1.svg#ninetofive-icon-applenews"/>
		</svg>
		</a>
<a href="https://b.smartnews.be/r/8GkJ3uZKPl1eorSk" title="View 9to5 on SmartNews">
		<svg class="ninetofive-icon smartnews " aria-hidden="true">
									<use
				xlink:href="https://9to5google.com/wp-content/themes/9to5-2015/images/svg-sprite-1.svg#ninetofive-icon-smartnews"/>
		</svg>
		</a>
<a href="https://flipboard.com/@9to5google" title="View 9to5 on FlipBoard">
		<svg class="ninetofive-icon flipboard " aria-hidden="true">
									<use
				xlink:href="https://9to5google.com/wp-content/themes/9to5-2015/images/svg-sprite-1.svg#ninetofive-icon-flipboard"/>
		</svg>
		</a>
<a href="https://9to5google.com/push/" title="Signup for Safari Notifications">
		<svg class="ninetofive-icon pushup " aria-hidden="true">
									<use
				xlink:href="https://9to5google.com/wp-content/themes/9to5-2015/images/svg-sprite-1.svg#ninetofive-icon-pushup"/>
		</svg>
		</a>
<a href="https://eepurl.com/bdw6AH" title="Signup for our email list">
		<svg class="ninetofive-icon email " aria-hidden="true">
									<use
				xlink:href="https://9to5google.com/wp-content/themes/9to5-2015/images/svg-sprite-1.svg#ninetofive-icon-email"/>
		</svg>
		</a>
</div>							<button aria-expanded="false" aria-controls="js-header-social-more" id="js-button-social" class="js-button button-social-toggle">
										<svg class="ninetofive-icon dots-expand " aria-hidden="true">
									<use
				xlink:href="https://9to5google.com/wp-content/themes/9to5-2015/images/svg-sprite-1.svg#ninetofive-icon-dots-expand"/>
		</svg>
										<span class="screen-reader-text">More social networks</span>
							</button>
						</div>
						<!-- .header-social -->

						<div class="header-icon-links">
							
<a href='https://9to5google.com/contact/' class='has-tooltip'>		<svg class="ninetofive-icon feedback " aria-hidden="true">
									<use
				xlink:href="https://9to5google.com/wp-content/themes/9to5-2015/images/svg-sprite-1.svg#ninetofive-icon-feedback"/>
		</svg>
		<span class='header-tooltip'>Submit a Tip / Contact Us</span></a>
</li>
						</div>
						<!-- .header-icon-links -->

						<div class="header-search">
							
	<div class="search-form" id="js-search-form">
		<script>
			(function() {
				var cx = '008464549922976904202:uxmexxzm3k4';
				var gcse = document.createElement('script');
				gcse.type = 'text/javascript';
				gcse.async = true;
				gcse.src = 'https://cse.google.com/cse.js?cx=' + cx;
				var s = document.getElementsByTagName('script')[0];
				s.parentNode.insertBefore(gcse, s);
			})();
		</script>
		<gcse:searchbox-only></gcse:searchbox-only>
	</div>
							<button aria-expanded="false" aria-controls="js-search-form" id="js-button-search" class="js-button button-search-toggle">
										<svg class="ninetofive-icon search js-regular-icon" aria-hidden="true">
									<use
				xlink:href="https://9to5google.com/wp-content/themes/9to5-2015/images/svg-sprite-1.svg#ninetofive-icon-search"/>
		</svg>
												<svg class="ninetofive-icon cross js-expanded-icon" aria-hidden="true">
									<use
				xlink:href="https://9to5google.com/wp-content/themes/9to5-2015/images/svg-sprite-1.svg#ninetofive-icon-cross"/>
		</svg>
										<span class="screen-reader-text">Toggle search</span>
							</button>
						</div>
						<!-- .header-search -->

					</div>
					<!-- .header-right-area -->

				</div>
				<!-- .site-header-inner -->

				<div class="site-switcher" id="js-site-switcher" aria-hidden="true">
					<ul class="site-switcher-list">
<li><a href='https://9to5mac.com'>		<svg class="ninetofive-icon ninetofive-mac " aria-hidden="true">
									<use
				xlink:href="https://9to5google.com/wp-content/themes/9to5-2015/images/svg-sprite-1.svg#ninetofive-icon-ninetofive-mac"/>
		</svg>
		<span class='screen-reader-text'>9to5Mac</span></a></li>
</li>

<li><a href='https://9to5toys.com'>		<svg class="ninetofive-icon ninetofive-toys " aria-hidden="true">
									<use
				xlink:href="https://9to5google.com/wp-content/themes/9to5-2015/images/svg-sprite-1.svg#ninetofive-icon-ninetofive-toys"/>
		</svg>
		<span class='screen-reader-text'>9to5Toys</span></a></li>
</li>

<li><a href='https://electrek.co'><div class="ninetofive-icon ninetofive-electrek"></div><span class='screen-reader-text'>Electrek</span></a></li>
</li>

<li class='menu-item-dronedj'><a href='https://www.dronedj.com'><div class="ninetofive-icon ninetofive-dronedj"></div><span class='screen-reader-text'>DroneDJ</span></a></li>
</li>

<li class='site-switcher-text-only'><a href='https://9to5mac.com/about/'>About</a></li>
</li>

<li class='site-switcher-text-only'><a href='https://9to5mac.com/community/'>Community</a></li>
</li>
</ul>				</div>
				<!-- .site-switcher -->

			</header>
			<!-- .site-header -->

			<div class="site-header-placeholder"></div>
			
			<div class="order-control">
				
				
				<div class="th26688a03 ad-container ad-container--leaderboard order-control__mobile-top">
					<div id="div-gpt-ad-1436850350386-0" class="inlinead"></div>
<script type='text/javascript'>
	// Make sure that nineto5ads exists, it will load ad once google tag exists
	window.nineto5ads = window.nineto5ads|| [];

	var apstagSlots = [];
	var adUnits = [];
	if ( 'undefined' !== typeof ninetofiveGetHeaderBidderAdUnits ) {
		adUnits = ninetofiveGetHeaderBidderAdUnits( "\/1049447\/9to5google-728x90-TopMain-R", [[728,90]], true );
	}
	apstagSlots.push( {
		slotID: "div-gpt-ad-1436850350386-0",
		slotName: "\/1049447\/9to5google-728x90-TopMain-R",
		sizes: [[728,90]]
	} );

	var slotID = "\/1049447\/9to5google-728x90-TopMain-R";</script><div class="th8881425d th464c213f"><div class="th6857532d"><img src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" class="th1880b217"/></div></div><div class="thb4e1d01e thebe92596"><div class="th6857532d"><img src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" class="th1880b217"/></div></div><div class="th88588a1b tha3140898"><div class="th6857532d"><img src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" class="th1880b217"/></div></div><div class="thd09d0440 th64bf86c2"><div class="th6857532d"><img src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" class="th1880b217"/></div></div><div class="thf3fb2949 th34ded898"><div class="th6857532d"><div class="th62e8808b thf7b89ea2"><div class="th6857532d" data-th76734c27="http://amzn.to/2ptg1ma"><img src="https://9to5google.com/wp-content/uploads/sites/4/2017/05/best-usb-c_amz.jpg?quality=82&strip=all"/></div></div></div></div><div class="th8307b0d4 thd7d15a8b"><div class="th6857532d"><img src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" class="th1880b217"/></div></div><div class="th1e400f6f th2eaf3acd"><div class="th6857532d"><img src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" class="th1880b217"/></div></div><div class="th6bfa855a th919804f3"><div class="th6857532d"><img src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" class="th1880b217"/></div></div>				</div>

			</div><!-- .order-control -->
			
		<div id="content">
					<div class="news-feed-header">
				<div class="elastic-container">
					<div class="currently-reading">
						<p>Today</p>
					</div><!-- .currently-reading -->


				</div><!-- .elastic-container -->
			</div><!-- .news-feed-header -->
			<div id="news-placeholder"></div>

		<article class="post-content" itemscope itemtype="http://schema.org/NewsArticle">
				<div class="elastic-container">
					<h1 class="post-title" itemprop="headline"><a href="https://9to5google.com/2019/03/13/android-q-root-magisk-trouble/" itemprop="mainEntityOfPage">Android Q changes could spell trouble for root access, says Magisk developer</a></h1>
					<div class="post-meta">
						<p class="byline" itemprop="author" itemscope itemtype="https://schema.org/Person">
							<a href="https://9to5google.com/author/nexusben1/">
								<span itemprop="name">Ben Schoon</span>
							</a>
						</p>
						<p class="time-twitter">
							- Mar. 13th 2019 8:05 pm PT
								<div class="icon-twitter"></div>
								<p><a href="https://twitter.com/NexusBen" target="_blank" class="twitter-handle">@NexusBen</a></p>
						</p>


							<div class="tags">
								<div class="post-cats">
								</div><!-- .post-cats -->
							</div><!-- .tags -->

						<meta itemprop="keywords" content=""/>
						<meta itemprop="datePublished" content="2019-03-13 20:05:11"/>
						<meta itemprop="dateModified" content="2019-03-13 20:05:11"/>
					</div><!-- .post-meta -->
				</div><!-- .elastic-container -->
				<div class="feat-image-wrapper">
						<div itemprop="image" itemscope itemtype="https://schema.org/ImageObject">
							<meta itemprop="url" content="https://9to5google.com/wp-content/uploads/sites/4/2019/03/android_q_beta_logo_1.jpg?quality=82&#038;strip=all&#038;w=1600">
							<meta itemprop="height" content="800">
							<meta itemprop="width" content="1600">
						</div>
						<div class="feat-image wide">
							<img src="https://9to5google.com/wp-content/uploads/sites/4/2019/03/android_q_beta_logo_1.jpg?quality=82&#038;strip=all&#038;w=1600" srcset="https://i0.wp.com/9to5google.com/wp-content/uploads/sites/4/2019/03/android_q_beta_logo_1.jpg?resize=320%2C0&amp;quality=82&amp;strip=all&amp;ssl=1 320w, https://i0.wp.com/9to5google.com/wp-content/uploads/sites/4/2019/03/android_q_beta_logo_1.jpg?resize=640%2C0&amp;quality=82&amp;strip=all&amp;ssl=1 640w, https://i0.wp.com/9to5google.com/wp-content/uploads/sites/4/2019/03/android_q_beta_logo_1.jpg?resize=1024%2C0&amp;quality=82&amp;strip=all&amp;ssl=1 1024w, https://i0.wp.com/9to5google.com/wp-content/uploads/sites/4/2019/03/android_q_beta_logo_1.jpg?resize=1500%2C0&amp;quality=82&amp;strip=all&amp;ssl=1 1500w, https://i0.wp.com/9to5google.com/wp-content/uploads/sites/4/2019/03/android_q_beta_logo_1.jpg?resize=2000%2C0&amp;quality=82&amp;strip=all&amp;ssl=1 2000w, https://i0.wp.com/9to5google.com/wp-content/uploads/sites/4/2019/03/android_q_beta_logo_1.jpg?resize=2500%2C0&amp;quality=82&amp;strip=all&amp;ssl=1 2500w">
						</div><!-- .feat-image -->
					<div class="post-social-mobile">
						<a href="https://9to5google.com/2019/03/13/android-q-root-magisk-trouble/#comments" class="comments" itemprop="discussionUrl"><span class="dsq-postid" data-dsqidentifier="276858 https://9to5google.com/?p=276858">0</span></a>
						<div class="sharedaddy sd-sharing-enabled"><div class="robots-nocontent sd-block sd-social sd-social-text sd-sharing"><div class="sd-content"><ul><li class="share-facebook"><a rel="nofollow noopener noreferrer" data-shared="sharing-facebook-276858" class="share-facebook sd-button no-icon" href="https://9to5google.com/2019/03/13/android-q-root-magisk-trouble/?share=facebook" target="_blank" title="Click to share on Facebook"><span>Facebook</span></a></li><li class="share-twitter"><a rel="nofollow noopener noreferrer" data-shared="sharing-twitter-276858" class="share-twitter sd-button no-icon" href="https://9to5google.com/2019/03/13/android-q-root-magisk-trouble/?share=twitter" target="_blank" title="Click to share on Twitter"><span>Twitter</span></a></li><li class="share-pinterest"><a rel="nofollow noopener noreferrer" data-shared="sharing-pinterest-276858" class="share-pinterest sd-button no-icon" href="https://9to5google.com/2019/03/13/android-q-root-magisk-trouble/?share=pinterest" target="_blank" title="Click to share on Pinterest"><span>Pinterest</span></a></li><li class="share-linkedin"><a rel="nofollow noopener noreferrer" data-shared="sharing-linkedin-276858" class="share-linkedin sd-button no-icon" href="https://9to5google.com/2019/03/13/android-q-root-magisk-trouble/?share=linkedin" target="_blank" title="Click to share on LinkedIn"><span>LinkedIn</span></a></li><li class="share-reddit"><a rel="nofollow noopener noreferrer" data-shared="" class="share-reddit sd-button no-icon" href="https://9to5google.com/2019/03/13/android-q-root-magisk-trouble/?share=reddit" target="_blank" title="Click to share on Reddit"><span>Reddit</span></a></li><li class="share-end"></li></ul></div></div></div>
					</div><!-- .post-social-mobile -->
				</div><!-- .feat-image-wrapper -->
				<div class="elastic-container">
					<div class="post-body" itemprop="articleBody">
						<p>Root has been a part of the Android community for years and years now, and it was looking like Android Q wouldn&#8217;t be the end of it. However, just a few hours after the <a href="https://9to5google.com/2019/03/13/android-q-beta-1-new-features/">first beta for Android Q launched</a>, it&#8217;s been discovered that getting root access on the latest version might be a bit more difficult than anticipated.</p>
<p><span id="more-276858"></span>
	<!-- author ad --><ins class="adsbygoogle author_ad" style="display:block;" data-ad-client="ca-pub-8513483021683571" data-ad-slot="8874812040"></ins>
<script type="text/javascript">(adsbygoogle = window.adsbygoogle || []).push({});</script>
		
<div class="th8881425d th464c213f"><div class="th6857532d"><img src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" class="th1880b217"/></div></div><div class="thb4e1d01e thebe92596"><div class="th6857532d"><img src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" class="th1880b217"/></div></div><div class="th88588a1b tha3140898"><div class="th6857532d"><img src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" class="th1880b217"/></div></div><div class="thd09d0440 th64bf86c2"><div class="th6857532d"><img src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" class="th1880b217"/></div></div><div class="thf3fb2949 th34ded898"><div class="th6857532d"><div class="th62e8808b th787debf9"><div class="th6857532d" data-th76734c27="http://bit.ly/2Q7nzGb"><img src="https://i2.wp.com/9to5google.com/wp-content/uploads/sites/4/2018/06/google_pixel_2_xl_1.jpg?resize=300%2C250&#038;quality=82&#038;strip=all&#038;ssl=1"/><h3>The best gifts for Android users</h3></div></div></div></div><div class="th8307b0d4 thd7d15a8b"><div class="th6857532d"><img src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" class="th1880b217"/></div></div><div class="th1e400f6f th2eaf3acd"><div class="th6857532d"><img src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" class="th1880b217"/></div></div><div class="th6bfa855a th919804f3"><div class="th6857532d"><img src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" class="th1880b217"/></div></div></p>
<p>John Wu, the developer behind Magisk, tweeted some bad news tonight for root fans. Apparently, it could be a while before Android Q is successfully rooted. While he was able to root an <a href="https://9to5google.com/2019/03/04/android-q-rooted-before-developer-preview/">early build of the OS just this month</a>, things aren&#8217;t going so well for the beta version.</p>
<p>Apparently, Google switched Android Q to logical partitions for the system block, leaving no simple way to mount the block. At first, Wu thought he might have to rebuild Magisk from scratch to get things working, a process which he expected could take &#8220;months&#8221; just to get it to boot on Q.</p>
<p>Luckily, after taking another look at things shortly after, Wu found his first clue to implementing Magisk on Android Q. In another tweet, he explains some of the things Google changed in Q from the ground up, including &#8220;completely changing&#8221; how the system works with root access.</p>
<blockquote class="twitter-tweet"  data-dnt="true">
<p lang="en" dir="ltr">Bad news: Android Q root won&#39;t come anytime soon. Android Q has switched to logical partitions for the system block, which means there is no easy way to mount the block by any means. I&#39;m currently thinking of what tricks can I do other than implement everything from scratch&#8230;.</p>
<p>&mdash; John Wu (@topjohnwu) <a href="https://twitter.com/topjohnwu/status/1105947979679191041?ref_src=twsrc%5Etfw">March 13, 2019</a></p></blockquote>
<p><script async src="https://platform.twitter.com/widgets.js" charset="utf-8"></script></p>
<blockquote class="twitter-tweet"  data-dnt="true">
<p lang="en" dir="ltr">It will take me an extreme amount of time to figure out how to workaround all this mess. I won&#39;t expect Magisk to be even able to boot on Q in months.</p>
<p>&mdash; John Wu (@topjohnwu) <a href="https://twitter.com/topjohnwu/status/1105962401424392192?ref_src=twsrc%5Etfw">March 13, 2019</a></p></blockquote>
<p><script async src="https://platform.twitter.com/widgets.js" charset="utf-8"></script></p>
<blockquote class="twitter-tweet"  data-dnt="true">
<p lang="en" dir="ltr">Sigh&#8230; Google really like to rewrite things over and over again. So far I found out:<br>1. Completely changed how system as root works<br>2. Stop using DTBO for normal boot<br>3. Stop appending DTB after kernel<br>4. Stop placing fstab into DTB<br>And the journey continues&#8230;..</p>
<p>&mdash; John Wu (@topjohnwu) <a href="https://twitter.com/topjohnwu/status/1105937804725571586?ref_src=twsrc%5Etfw">March 13, 2019</a></p></blockquote>
<p><script async src="https://platform.twitter.com/widgets.js" charset="utf-8"></script></p>
<h3>More on Android Q:</h3>
<ul>
<li><a href="https://9to5google.com/2019/03/04/android-q-rooted-before-developer-preview/">Android Q gets successfully rooted before a developer preview is even available</a></li>
<li><a href="https://9to5google.com/2019/03/13/android-q-beta-launch/">Google launches Android Q Beta 1 for all Pixel phones</a></li>
<li><a href="https://9to5google.com/2019/03/13/android-q-beta-1-new-features/">Here’s everything new in Android Q Beta 1 [Gallery]</a></li>
</ul>
<p><!-- youtube embed --></p>
<hr />
<p style="text-align: center"><a href="https://www.youtube.com/c/9to5google?sub_confirmation=1"><i>Check out 9to5Google on YouTube for more news:</i></a></p>
<p><span class="embed-youtube" style="text-align:center; display: block;"><iframe class='youtube-player' type='text/html' width='1000' height='563' src='https://www.youtube.com/embed/46VmaKPRbu8?version=3&#038;rel=0&#038;fs=1&#038;autohide=2&#038;showsearch=0&#038;showinfo=1&#038;iv_load_policy=1&#038;wmode=transparent' allowfullscreen='true' style='border:0;'></iframe></span></p>

					</div><!-- .post-body -->

				</div><!-- .elastic-container -->

				<div itemprop="publisher" itemscope itemtype="https://schema.org/Organization">
					<div itemprop="logo" itemscope itemtype="https://schema.org/ImageObject">
						<meta itemprop="url" content="https://9to5google.com/wp-content/uploads/sites/4/2018/10/cropped-new-9to5-google-logo.png">
						<meta itemprop="width" content="366">
						<meta itemprop="height" content="60">
					</div>
					<meta itemprop="name" content="9to5Google">
				</div>

				<div class="elastic-container">
					<div class="related-guides-container">
						<h1>Guides</h1>
						<div class="related-guides-list">
							<div class="related-guides-item">
								<a href="https://9to5google.com/guides/android-q/">
								<div class="related-guides-item-image">
									<img src="https://9to5google.com/wp-content/themes/9to5-2015/images/default-9to5google-guide.jpg" title="Android Q" alt="Android Q" />
								</div>
								<h3>Android Q</h3>
								<p></p>
								</a>
							</div>
						</div>
							<div class="post-cats"></div>
							<!-- .post-cats -->
					</div>
				</div>

			<div class="elastic-container">
				<div class="author-bio-container">
					<h2 class="bio-title">About the Author</h2>
					<div class="author-bio" itemprop="author" itemscope itemtype="https://schema.org/Person">
							<div class="author-bio-details">
								<a href="https://9to5google.com/author/nexusben1/">
									<img src="https://secure.gravatar.com/avatar/53c3eccb0df53253da7fb21049b682a7?s=512&#038;d=mm&#038;r=r" class="author-gravatar">
								</a>
								<h3>
									<a href="https://9to5google.com/author/nexusben1/">
										<span itemprop="name">Ben Schoon</span>
									</a>
								</h3>

									<p class="twitter">
										<a href="https://twitter.com/NexusBen" target="_blank" class="twitter-handle"><span class="icon-twitter"></span>@NexusBen</a>
									</p>

								<div class="author-excerpt">
									<p>Ben is a writer and video producer for 9to5Google. Find him on Twitter @NexusBen. Email schoon@9to5mac.com</p>

								</div>
						</div>
					</div>
						<div class="author-gear">
							<h3><span>Ben Schoon's favorite gear</span></h3>
							<div class="author-gear-list">
								<div class="author-gear-item">
									<a class="author-gear-item-link" href="https://9to5google.com/2019/01/23/nomad-pixel-3-rugged-case/" target="_blank">
										<div class="author-gear-item-image">
											<img src="https://i1.wp.com/9to5google.com/wp-content/uploads/sites/4/2019/01/nomad_pixel_3_xl_3.jpg?resize=300%2C175&#038;quality=82&#038;strip=all&#038;ssl=1" title="Nomad case for Pixel 3" alt="Nomad case for Pixel 3" width="290" height="145"/>
										</div>
										<h4 class="author-gear-item-title">Nomad case for Pixel 3</h4>
									</a>
								</div>
								<div class="author-gear-item">
									<a class="author-gear-item-link" href="https://9to5google.com/2019/02/04/best-android-smartwatches/" target="_blank">
										<div class="author-gear-item-image">
											<img src="https://i1.wp.com/9to5google.com/wp-content/uploads/sites/4/2019/01/fossil_sport_7.jpg?resize=300%2C175&#038;quality=82&#038;strip=all&#038;ssl=1" title="Best Android Smartwatches" alt="Best Android Smartwatches" width="290" height="145"/>
										</div>
										<h4 class="author-gear-item-title">Best Android Smartwatches</h4>
									</a>
								</div>
							</div>
						</div>
				</div>
			</div>





		</article><!-- .post-content -->

	<aside class="trending-wrapper"><div class="trending-items trending-items--single">
				<a href="https://9to5google.com/2019/03/13/android-q-beta-launch/" rel="bookmark">
					<div class="trending-grid-item">
						<div class="img-wrap" style="background-image: url(https://9to5google.com/wp-content/uploads/sites/4/2019/03/android_q_1.jpg?quality=82&#038;strip=all&#038;w=1600);"></div>
						<p class="trending-excerpt">Google launches Android Q Developer Preview 1</p>
					</div>
				</a>
			
				<a href="https://9to5google.com/2019/03/12/armani-exchange-connected-review/" rel="bookmark">
					<div class="trending-grid-item">
						<div class="img-wrap" style="background-image: url(https://9to5google.com/wp-content/uploads/sites/4/2019/03/Armani-Exchange-Connected-review.jpg?quality=82&#038;strip=all&#038;w=1600);"></div>
						<p class="trending-excerpt">Armani Exchange Connected review [Video]</p>
					</div>
				</a>
			
				<a href="https://9to5google.com/2019/03/11/google-spring-cleaning-death-inbox-allo/" rel="bookmark">
					<div class="trending-grid-item">
						<div class="img-wrap" style="background-image: url(https://9to5google.com/wp-content/uploads/sites/4/2019/03/google_spring_cleaning_calendar_1.jpg?quality=82&#038;strip=all&#038;w=1600);"></div>
						<p class="trending-excerpt">Google &#039;Spring Cleaning&#039; calendar: What&#039;s being killed</p>
					</div>
				</a>
			
				<a href="https://9to5google.com/2019/03/11/huawei-mediapad-m5-lite-review/" rel="bookmark">
					<div class="trending-grid-item">
						<div class="img-wrap" style="background-image: url(https://9to5google.com/wp-content/uploads/sites/4/2019/03/Huawei-MediaPad-M5-Lite-review.jpg?quality=82&#038;strip=all&#038;w=1600);"></div>
						<p class="trending-excerpt">Huawei MediaPad M5 Lite review [Video]</p>
					</div>
				</a>
			</div></aside>
					<div id="comments" class="comments-area post-body">
				<div class="elastic-container">
					
<div id="disqus_thread"></div>
				</div><!-- .elastic-container -->
			</div><!-- #comments.comments-area -->
			</div><!-- #content -->


	<div style="text-align:center">
		<a href="https://vip.wordpress.com/?utm_source=vip_powered_wpcom&#038;utm_medium=web&#038;utm_campaign=VIP%20Footer%20Credit&#038;utm_term=9to5google.com" rel="generator nofollow" class="powered-by-wpcom"><img src="https://9to5google.com/wp-content/mu-plugins/vip-helpers/images/vip-powered-light-small.png" width="187" height="26" alt="Powered by WordPress.com VIP" /></a>	</div>

		<script type="text/javascript">
		//<![CDATA[
		var ninetofiveInfiniteScroll = {"settings":{"id":"content","ajaxurl":"https:\/\/9to5google.com\/?infinity=scrolling","currentday":"13.03.19","order":"DESC","offset":0,"history":{"host":"9to5google.com","path":"\/2019\/03\/13\/android-q-root-magisk-trouble\/page\/%d\/","use_trailing_slashes":true,"parameters":""},"query_args":{"page":0,"year":2019,"monthnum":3,"day":13,"name":"android-q-root-magisk-trouble","error":"","m":"","p":0,"post_parent":"","subpost":"","subpost_id":"","attachment":"","attachment_id":0,"static":"","pagename":"","page_id":0,"second":"","minute":"","hour":"","w":0,"category_name":"","tag":"","cat":"","tag_id":"","author":"","author_name":"","feed":"","tb":"","paged":0,"meta_key":"","meta_value":"","preview":"","s":"","sentence":"","title":"","fields":"","menu_order":"","embed":"","category__in":[],"category__not_in":[],"category__and":[],"post__in":[],"post__not_in":[],"post_name__in":[],"tag__in":[],"tag__not_in":[],"tag__and":[],"tag_slug__in":[],"tag_slug__and":[],"post_parent__in":[],"post_parent__not_in":[],"author__in":[],"author__not_in":[],"ignore_sticky_posts":false,"suppress_filters":false,"cache_results":false,"update_post_term_cache":true,"lazy_load_term_meta":true,"update_post_meta_cache":true,"post_type":"","posts_per_page":6,"nopaging":false,"comments_per_page":"75","no_found_rows":false,"order":"DESC"},"last_post_date":"2019-03-13 20:05:11","dfp_id":"1049447","post_id":276858,"stats":"blog=146091833&host=9to5google.com&v=ext&j=1:7.1.1&x_pagetype=infinite-jetpack","google_analytics":false}};
		//]]>
	</script>
	<div style="display:none">
	</div>
<script id='loop-template' type='x-tmpl-mustache'>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</script><script id='content-template' type='x-tmpl-mustache'><div class="extended">
	{{{ post_content }}}

	{{# product_link }}
		{{# product_price }}
			<div class="product_cta_lower">
				<a href="{{ product_link }}" class="product-button{{# savings_amount }} has-savings{{/ savings_amount }}" target="_blank">
					{{# savings_amount }}
						<span class="product-savings-amount">Get this deal<br/>{{ savings_amount }}</span>
					{{/ savings_amount }}
					<span class="product-price">{{ product_price }}</span>
				</a>
			</div>
		{{/ product_price }}
	{{/ product_link }}
	
	<div class="extended-comment-cta">
	  <a href="{{ permalink }}#comments" class="comments">{{{ comment_count }}}</a>
	</div>

</div><!-- .extended -->
</script><script id='aside-template' type='x-tmpl-mustache'><div class="post-body">

	{{# featured_image }}
		{{# product_link }}
			{{# product_price }}
				<div class="product_cta_image">
					<a href="{{ product_link }}" class="product-button{{# savings_amount }} has-savings{{/ savings_amount }}" target="_blank">
						{{# savings_amount }}
							<span class="product-savings-amount">Get this deal<br/>{{ savings_amount }}</span>
						{{/ savings_amount }}
						<span class="product-price">{{ product_price }}</span>
					</a>
				</div>
			{{/ product_price }}
		{{/ product_link }}

		<div class="feat-image-wrapper">
			{{# featured_image }}
				<div class="feat-image{{ image_class }}"><img src="{{featured_image}}" srcset="{{ srcset }}"></div>
			{{/ featured_image }}
		</div><!-- .feat-image-wrapper -->
		<div class="post-social-mobile">
			<a href="{{permalink}}#comments" class="comments">{{{comment_count}}}</a>
			{{{share_buttons}}}
		</div><!-- .post-social-mobile -->

	{{/ featured_image }}
	{{{post_content}}}
	{{# meta.display_author_ad }}
		{{{ meta.author_ad }}}
	{{/ meta.display_author_ad }}

	{{# product_link }}
		{{# product_price }}
			<div class="product_cta_lower">
				<a href="{{ product_link }}" class="product-button{{# savings_amount }} has-savings{{/ savings_amount }}" target="_blank">
					{{# savings_amount }}
						<span class="product-savings-amount">Get this deal<br/>{{ savings_amount }}</span>
					{{/ savings_amount }}
					<span class="product-price">{{ product_price }}</span>
				</a>
			</div>
		{{/ product_price }}
	{{/ product_link }}

	<div class="post-cats">
		{{# featured_tags }}
    	<a href="{{tag_link}}" title="View all posts in {{tag_name}}" class="featured_tag">{{tag_name}}</a>
    {{/ featured_tags }}
		{{# categories }}
			<a href="{{cat_link}}" title="View all posts in {{cat_name}}">{{cat_name}}</a>
		{{/ categories }}
	</div><!-- .post-cats -->

	<div class="extended-comment-cta">
	  <a href="{{ permalink }}#comments" class="comments">{{{ comment_count }}}</a>
	</div>

</div><!-- .post-body -->
</script>		<link rel='stylesheet' id='all-css-0' href='https://9to5google.com/wp-content/mu-plugins/jetpack/modules/tiled-gallery/tiled-gallery/tiled-gallery.css?m=1521944087g' type='text/css' media='all' />
<script type='text/javascript'>
/* <![CDATA[ */
var globalJSVars = {"ajaxurl":"https:\/\/9to5google.com\/wp-admin\/admin-ajax.php"};
/* ]]> */
</script>
<script type='text/javascript' src='https://9to5google.com/_static/??-eJyVzNENgkAMANCFLAWlCX4YZ1EooReuvVyLJEzvjwPIAO/hXmA0DdbAWDiz4z2M4Np2hC93DsfkmG3iqnJUsC3KFk3yC/5HVZTDZvlwk0VPQNFZVILBx2rrCqXyW6Zf8syPjvrbMBD1bfoCiTBFjw=='></script>
<script type='text/javascript' src='https://s0.wp.com/wp-content/js/devicepx-jetpack.js?ver=201911'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var countVars = {"disqusShortname":"9to5googleprod"};
/* ]]> */
</script>
<script type='text/javascript'>
/* <![CDATA[ */
var embedVars = {"disqusConfig":{"integration":"wordpress 3.0.16"},"disqusIdentifier":"276858 https:\/\/9to5google.com\/?p=276858","disqusShortname":"9to5googleprod","disqusTitle":"Android Q changes could spell trouble for root access, says Magisk developer","disqusUrl":"https:\/\/9to5google.com\/2019\/03\/13\/android-q-root-magisk-trouble\/","postId":"276858"};
/* ]]> */
</script>
<script type='text/javascript'>
/* <![CDATA[ */
var PushUpNotificationSettings = {"domain":"https:\/\/9to5google.com","userID":"1","websitePushID":"web.com.9to5google","webServiceURL":"https:\/\/push.10up.com","prompt":"1"};
/* ]]> */
</script>
<script type='text/javascript'>
/* <![CDATA[ */
var stylesheetDirectory = "https:\/\/9to5google.com\/wp-content\/themes\/9to5-2015";
/* ]]> */
</script>
<script type='text/javascript' src='https://9to5google.com/_static/??-eJyVjssKwjAURH/I9DalAV2InyJtcrEpednJpfj3vkEEF+5mcc7M0FqUzalyqlSCnHwCOY+zgIqMwVuaQTbHeAOONkuqzYwN/WNxHNn9sopgknLHn6mJPn2zdeLIoF3NRnWtNjQAXPHYGJYs4KAGh7fmkw3iGB8f1MIlXF7dh7jXxnR93+ltO18BHcZelQ=='></script>
<script type='text/javascript' src='//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js?ver=1.0.45'></script>
<script type='text/javascript' src='https://9to5google.com/_static/??-eJx9jEEKwzAMBD9URzgkkEvpU4pjiSBXUk1tU/L7utBD6CHHYXYW3tmxRWlIBVIBJeRAQkpWobsjD8o2pHKBv6Yj6Up49PFp9XuhzWVpG1tfUs0hPuDeW1gbC0JlIXRbEKHXfka/65te/TyP0zT6xacP7JlEpg=='></script>

	<script>
		(function($){
			$(document.body).on('post-load', function(){
				var nodes = document.querySelectorAll('span.dsq-postid');
				for (var i = 0, url; i < nodes.length; i++) {
					var shorturl = nodes[i].getAttribute('rel');
					var new_rel = shorturl ? shorturl.replace( 'https:', 'http:' ) : '';
					nodes[i].parentNode.setAttribute('data-disqus-identifier', new_rel );
					url = nodes[i].parentNode.href.split('#', 1);
					if (url.length == 1) url = url[0];
					else url = url[1];
					nodes[i].parentNode.href = url + '#disqus_thread';
				}

				var DISQUSWIDGETS = window.DISQUSWIDGETS || {};

				if ( Object.keys(DISQUSWIDGETS).length !== 0 && DISQUSWIDGETS.constructor === Object ) {
					DISQUSWIDGETS.getCount({reset: true});
				}
			});
		})(jQuery);
	</script>

	<script type='text/javascript'>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</script>
	<script>

		// Check if our canRunAds variable is set
		if ( typeof canRunAds === 'undefined' || canRunAds === null ){
			document.body.classList.add( 'enable-fallbacks' );
		}

		(function($){
			$( '.th6857532d' ).click( function () {
				window.open( $( this ).data( 'th76734c27' ) );
				return false;
			});

			$(document.body).on('post-load', function(){
				$( '.th6857532d' ).click( function () {
					window.open( $( this ).data( 'th76734c27' ) );
					return false;
				});
			});
		})(jQuery);
	</script>
<script type='text/javascript' src='https://stats.wp.com/e-201911.js' async='async' defer='defer'></script>
<script type='text/javascript'>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:7.1.1',blog:'146091833',post:'276858',tz:'-7',srv:'9to5google.com'} ]);
	_stq.push([ 'clickTrackerInit', '146091833', '276858' ]);
</script>
<!-- Tracking Codes -->          <script type="text/javascript" src="//s.skimresources.com/js/3947X1518523.skimlinks.js"></script>
		<!-- End Tracking Codes -->
	</body>
</html>