<!DOCTYPE html>
<html lang="en">
	<head>
		<title>
			Google Assistant can now run on other devices, developer preview SDK launching today | 9to5Google		</title>

				<meta charset="UTF-8" />
		<meta name="viewport" content="width=device-width, initial-scale=1, maximum-scale=1.0, minimal-ui">
				<meta name="google-site-verification" content="Htm3pGW8rcBX6wK35FZMBNMbpuieOZ5c8F489axa8nw" />
<meta name="msvalidate.01" content="808CE29E29F1230249D24A893DE871FB" />
		<script src="https://s0.wp.com/wp-content/themes/vip/9to5-2015/assets/js/adsbygoogle.js"></script>

               <!-- Google Tag Manager -->
		<script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
				new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
				j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
				'https://www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
			})(window,document,'script','dataLayer','GTM-THGGVXB');</script>
		<!-- End Google Tag Manager -->
					<script src='https://r-login.wordpress.com/remote-login.php?action=js&amp;host=9to5google.com&amp;id=22427743&amp;t=1493318022&amp;back=https%3A%2F%2F9to5google.com%2F2017%2F04%2F27%2Fgoogle-assistant-sdk%2F' type="text/javascript"></script>
		<script type="text/javascript">
		/* <![CDATA[ */
			if ( 'function' === typeof WPRemoteLogin ) {
				document.cookie = "wordpress_test_cookie=test; path=/";
				if ( document.cookie.match( /(;|^)\s*wordpress_test_cookie\=/ ) ) {
					WPRemoteLogin();
				}
			}
		/* ]]> */
		</script>
		<link rel='dns-prefetch' href='//s2.wp.com' />
<link rel='dns-prefetch' href='//s0.wp.com' />
<link rel='dns-prefetch' href='//s1.wp.com' />
<link rel='dns-prefetch' href='//pagead2.googlesyndication.com' />
<link rel='dns-prefetch' href='//9to5google.wordpress.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel="alternate" type="application/rss+xml" title="9to5Google &raquo; Feed" href="https://9to5google.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="9to5Google &raquo; Comments Feed" href="https://9to5google.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="9to5Google &raquo; Google Assistant can now run on other devices, developer preview SDK launching&nbsp;today Comments Feed" href="https://9to5google.com/2017/04/27/google-assistant-sdk/feed/" />

<!-- Jetpack Open Graph Tags -->
<meta property="og:type" content="article" />
<meta property="og:title" content="Google Assistant can now run on other devices, developer preview SDK launching today" />
<meta property="og:url" content="https://9to5google.com/2017/04/27/google-assistant-sdk/" />
<meta property="og:description" content="With a wider rollout of Assistant currently underway for Android phones and Wear, Google today announced a developer preview SDK that will allow Assistant to be built into third-party devices." />
<meta property="article:published_time" content="2017-04-27T17:39:42+00:00" />
<meta property="article:modified_time" content="2017-04-27T17:39:42+00:00" />
<meta property="og:site_name" content="9to5Google" />
<meta property="og:image" content="https://9to5google.files.wordpress.com/2017/04/google-assistant-sdk-e1493313856274.jpg?quality=82&amp;strip=all&amp;w=1000&amp;strip=all&amp;w=1600&amp;h=1000" />
<meta property="og:locale" content="en_US" />
<meta name="twitter:site" content="@9to5google" />
<meta name="twitter:image" content="https://9to5google.files.wordpress.com/2017/04/google-assistant-sdk-e1493313856274.jpg?quality=82&amp;strip=all&amp;w=1000&amp;strip=all&amp;w=1600&amp;h=1000" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:creator" content="@technacity" />
<meta property="article:publisher" content="https://www.facebook.com/WordPresscom" />
<meta property="og:image:width" content="1376" />
<meta property="og:image:height" content="688" />
	<script type="text/javascript">
		/* <![CDATA[ */
		function addLoadEvent(func) {
			var oldonload = window.onload;
			if (typeof window.onload != 'function') {
				window.onload = func;
			} else {
				window.onload = function () {
					oldonload();
					func();
				}
			}
		}
		/* ]]> */
	</script>
			<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s0.wp.com\/wp-content\/mu-plugins\/wpcom-smileys\/twemoji\/2\/72x72\/","ext":".png","svgUrl":"https:\/\/s0.wp.com\/wp-content\/mu-plugins\/wpcom-smileys\/twemoji\/2\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/s1.wp.com\/wp-includes\/js\/wp-emoji-release.min.js?m=1488818651h&ver=4.7.4"}};
			!function(a,b,c){function d(a){var b,c,d,e,f=String.fromCharCode;if(!k||!k.fillText)return!1;switch(k.clearRect(0,0,j.width,j.height),k.textBaseline="top",k.font="600 32px Arial",a){case"flag":return k.fillText(f(55356,56826,55356,56819),0,0),!(j.toDataURL().length<3e3)&&(k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57331,65039,8205,55356,57096),0,0),b=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57331,55356,57096),0,0),c=j.toDataURL(),b!==c);case"emoji4":return k.fillText(f(55357,56425,55356,57341,8205,55357,56507),0,0),d=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55357,56425,55356,57341,55357,56507),0,0),e=j.toDataURL(),d!==e}return!1}function e(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var f,g,h,i,j=b.createElement("canvas"),k=j.getContext&&j.getContext("2d");for(i=Array("flag","emoji4"),c.supports={everything:!0,everythingExceptFlag:!0},h=0;h<i.length;h++)c.supports[i[h]]=d(i[h]),c.supports.everything=c.supports.everything&&c.supports[i[h]],"flag"!==i[h]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[i[h]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(g=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",g,!1),a.addEventListener("load",g,!1)):(a.attachEvent("onload",g),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),f=c.source||{},f.concatemoji?e(f.concatemoji):f.wpemoji&&f.twemoji&&(e(f.twemoji),e(f.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='all-css-0-1' href='https://s0.wp.com/_static/??-eJx9jUEOgkAMAD9kLSIxejC+ZVkbWdguDe2G71tIvBkuTdvMZHAViHMxKoZcQXL9pKKY00SKI5mEOMF+naPqCf/jcV7I/yzBNoLpnQJlYseONJbbz9rWwVuHmVWchr6XhVTBJ6fKYIOHdu/Fz0t3bR9t092b8QtnYFC+' type='text/css' media='all' />
<link rel='stylesheet' id='googleFonts-css'  href='https://fonts.googleapis.com/css?family=Roboto%3A300%2C300italic%2C400%2C400italic%2C500%2C500italic%7CQuestrial&#038;ver=4.7.4' type='text/css' media='all' />
<link rel='stylesheet' id='all-css-2-1' href='https://s1.wp.com/_static/??-eJyVkEEOwjAMBD9EMK0aRA+It4RggsFJqtoF8XsChxaEQHDblXcsr+HSGZ+TYlLQA0YUOFMHrWZr6kVlwYmgCngRECZ/mhc1g38p80j9z+qVUeaR0ohS8jzsCnQUiLgjh1x2lF3PpmN3xf43rsye/QQRpKxUTpVRvBWIg+l4CFQyAbPh7J1STi/G7NlR/w3tccs5FBkerSf76WGHBgLnreN7YBPXVdPWjV22K3u8ATluqfc=' type='text/css' media='all' />
<link rel='stylesheet' id='screen-css-3-1' href='https://s1.wp.com/wp-content/themes/vip/plugins/wp-paginate/wp-paginate.css?m=1292836527h' type='text/css' media='screen' />
<script type='text/javascript' src='https://s1.wp.com/_static/??-eJyFztEKwjAMBdAfsquTiXsRv6XWOFKXtDbphn69HeiDMBQCgdzDJXZOBtmP5QJiQ517gfx4rybIxv4ChnDITqEh5A/2kRVYF0vxjCOYIpDdUG+16BpXXIqiBCIVraTfLyFPCPNfFkCT8zeTQfC5tJ7o2Hb9Yde3+24bXjRNW9I='></script>
<link rel='stylesheet' id='all-css-0-2' href='https://s1.wp.com/wp-content/mu-plugins/highlander-comments/style.css?m=1377793621h' type='text/css' media='all' />
<!--[if lt IE 8]>
<link rel='stylesheet' id='highlander-comments-ie7-css'  href='https://s1.wp.com/wp-content/mu-plugins/highlander-comments/style-ie7.css?m=1351637563h&#038;ver=20110606' type='text/css' media='all' />
<![endif]-->
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://9to5google.wordpress.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://s1.wp.com/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress.com" />
<link rel="canonical" href="http://9to5google.com/2017/04/27/google-assistant-sdk/" />
<link rel='shortlink' href='http://wp.me/p1w6tN-JLi' />
<link rel="alternate" type="application/json+oembed" href="https://public-api.wordpress.com/oembed/1.0/?format=json&amp;url=https%3A%2F%2F9to5google.com%2F2017%2F04%2F27%2Fgoogle-assistant-sdk%2F&amp;for=wpcom-auto-discovery" /><link rel="alternate" type="application/xml+oembed" href="https://public-api.wordpress.com/oembed/1.0/?format=xml&amp;url=https%3A%2F%2F9to5google.com%2F2017%2F04%2F27%2Fgoogle-assistant-sdk%2F&amp;for=wpcom-auto-discovery" /><link rel='openid.server' href='https://9to5google.wordpress.com/?openidserver=1' />
<link rel='openid.delegate' href='https://9to5google.wordpress.com/' />
<link rel="search" type="application/opensearchdescription+xml" href="https://9to5google.com/osd.xml" title="9to5Google" />
<link rel="search" type="application/opensearchdescription+xml" href="https://s1.wp.com/opensearch.xml" title="WordPress.com" />
<script type="text/javascript">
			// <![CDATA[
			(function () {
				var aE = function( o, t, f ) {
					if (o.addEventListener)
						o.addEventListener(t, f, false);
					else if (o.attachEvent) 
						o.attachEvent('on' + t, f);
				}		

				var confirmSubmit = function() {
					if ( confirm('Are you sure that you want to flag this comment?') ) {
						return true;
					}
					else 
						return false;
				}

				var init = function() {
					var links = document.getElementsByTagName('a');
					var nonce = '30e31083ed';
					var nonce_key = '1d3ebb482e';
					var re = new RegExp(nonce_key, 'gi');
					for ( var i = 0; i < links.length; i++ ) {
						var href = links[i].getAttribute('href');
						// if it's a flagging link
						if ( re.exec(href) ) {
							// replace with correct nonce
							links[i].setAttribute('href', href.replace(re, nonce));
							links[i].onclick = confirmSubmit;
						}
					}
				}



				aE(window, 'load', init);
			}).call(this);
			//]]>
			</script><link rel="mask-icon" color="#296700" href="https://s0.wp.com/wp-content/themes/vip/9to5-2015/images/9to5-clock.svg">		<style type="text/css">
			.recentcomments a {
				display: inline !important;
				padding: 0 !important;
				margin: 0 !important;
			}

			table.recentcommentsavatartop img.avatar, table.recentcommentsavatarend img.avatar {
				border: 0px;
				margin: 0;
			}

			table.recentcommentsavatartop a, table.recentcommentsavatarend a {
				border: 0px !important;
				background-color: transparent !important;
			}

			td.recentcommentsavatarend, td.recentcommentsavatartop {
				padding: 0px 0px 1px 0px;
				margin: 0px;
			}

			td.recentcommentstextend {
				border: none !important;
				padding: 0px 0px 2px 10px;
			}

			.rtl td.recentcommentstextend {
				padding: 0px 10px 2px 0px;
			}

			td.recentcommentstexttop {
				border: none;
				padding: 0px 0px 0px 10px;
			}

			.rtl td.recentcommentstexttop {
				padding: 0px 10px 0px 0px;
			}
		</style>
		<meta name="application-name" content="9to5Google" /><meta name="msapplication-window" content="width=device-width;height=device-height" /><meta name="msapplication-tooltip" content="Beyond Good and Evil" /><meta name="msapplication-task" content="name=Subscribe;action-uri=https://9to5google.com/feed/;icon-uri=https://9to5google.files.wordpress.com/2017/03/favicon-bg-none-face-white.png?w=16" /><link rel="amphtml" href="https://9to5google.com/2017/04/27/google-assistant-sdk/amp/" /><style type="text/css" id="syntaxhighlighteranchor"></style>
<link rel="icon" href="https://9to5google.files.wordpress.com/2017/03/favicon-bg-none-face-white.png?w=32" sizes="32x32" />
<link rel="icon" href="https://9to5google.files.wordpress.com/2017/03/favicon-bg-none-face-white.png?w=192" sizes="192x192" />
<link rel="apple-touch-icon-precomposed" href="https://9to5google.files.wordpress.com/2017/03/favicon-bg-none-face-white.png?w=180" />
<meta name="msapplication-TileImage" content="https://9to5google.files.wordpress.com/2017/03/favicon-bg-none-face-white.png?w=256" />

	<style>
		.th69280b21 { padding: 10px 0; text-align: center; }
          .color-scheme-mac .th69280b21 { background-color: #0d4d7c; }
		.color-scheme-google .th69280b21 { background-color: #16341B; }
		.color-scheme-toys .th69280b21 { background-color: #6B393B; }
		.color-scheme-electrek .th69280b21 { background-color: #00cacd; }
		.th69280b21 .inlinead { background-color: transparent; min-height: 1px; }
		.th69280b21 .inlinead > div { background-color: transparent; padding: 0; }

		.color-scheme-electrek .th69280b21 { background-color: #939598; }

		.ad { margin: 0 auto; }

		@media (min-width: 0px) and (max-width: 767px) { .two-up-ads { display: none; } }

		.two-up-ads, .post-leaderboard { box-sizing: border-box; width: 100%; float: left; padding-left: 0.83333%; padding-right: 0.83333%; background-color: #ECECED; padding: 25px 0; }
		.two-up-ads .ad-1, .two-up-ads .ad-2, .post-leaderboard .ad-1, .post-leaderboard .ad-2 { display: inline-block; width: 300px; height: 250px; overflow: hidden; }
		.two-up-ads .ad-1, .post-leaderboard .ad-1 { box-sizing: border-box; width: 50%; float: left; padding-left: 0.83333%; padding-right: 0.83333%; text-align: right; }
		.two-up-ads .ad-2, .post-leaderboard .ad-2 { box-sizing: border-box; width: 50%; float: right; padding-left: 0.83333%; padding-right: 0.83333%; text-align: left; padding-left: 40px; }

		@media (min-width: 0px) and (max-width: 767px) { .post-leaderboard img { width: 100%; } }

		.post-leaderboard > * { margin: 0 auto; text-align: center; display: block; }

		/** inline ads **/
		.th04ff7570 { background-color: #DCDDDE; max-width: 100%; overflow: hidden; text-align: center; }\
		.th04ff7570 > div, .th04ff7570 > ins { padding: 20px 0; margin: 0 auto; }
		.enable-fallbacks .th04ff7570 > div, .enable-fallbacks .th04ff7570 > ins { padding: 0 0 0 0; }
		@media only screen and (min-width: 768px) { .th04ff7570 > div, .th04ff7570 > ins { display: block; padding: 25px 10px 25px 0; }
		.enable-fallbacks .th04ff7570 > div, .enable-fallbacks .th04ff7570 > ins { padding: 0 0 0 0; } }

		.post-body .th04ff7570 { background-color: transparent; }

		.th8bb2a40f { width: 300px; height: 250px; }
		@media (min-device-width: 320px) and (max-device-width: 479px) { .th8bb2a40f { width: 300px; height: 250px; } }
		@media (min-width: 500px) { .th8bb2a40f { width: 320px; height: 400px; } }
		@media (min-device-width: 480px) and (max-device-width: 767px) { .th8bb2a40f { width: 300px; height: 250px; } }
		@media (min-width: 768px) { .th8bb2a40f { float: right; margin-left: 20px; width: 336px; height: 280px; } }
		@media (min-width: 1000px) { .th8bb2a40f { margin: 0 -105px 20px 20px; } }
		.enable-fallbacks .th8bb2a40f { display: none !important; }

		.th63ad2f86 { display: none; }
		.enable-fallbacks .th63ad2f86 { display: block; }
		.th63ad2f86 img { max-width: 100%; }

		.th63ad2f86.th5b44d43c { background-color: #dcddde; max-width: 100%; overflow: hidden; text-align: center; }
		.th63ad2f86.th5b44d43c > div { margin: 20px auto; padding: 0 0; }

		.thec56f00e { line-height: 0; max-width: 300px; position: relative; }
		.thec56f00e h3 { background: rgba(0, 0, 0, 0.7); bottom: 0; box-sizing: border-box; color: #fff; font-size: 1.17em; font-weight: 400; line-height: 1.3; margin: 0 0; padding: 0.25em 0.5em; position: absolute; text-align: left; width: 100%; }
		.post-body .thec56f00e h3 { font-size: 1em; }
		@media (min-width: 768px) { .post-body .thec56f00e { float: right; margin-left: 20px; width: 300px; height: 250px; } }
		@media (min-width: 1000px) { .post-body .thec56f00e { margin: 0 -105px 20px 20px; } }

		.th5b44d43c .thec56f00e { margin: 0 auto; }
		.th1a14c064 { cursor: pointer }
	</style>
	</head>
		<body class="post-template-default single single-post postid-175912 single-format-standard color-scheme-google mp6 customizer-styles-applied highlander-enabled highlander-light infinite-scroll">
					<!-- Google Tag Manager (noscript) -->
		<noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-THGGVXB"
		                  height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
		<!-- End Google Tag Manager (noscript) -->
						<div class="th69280b21">
				<div id="div-gpt-ad-1436850350386-0" class="inlinead"></div>
<script type='text/javascript'>
	// Make sure that nineto5ads exists, it will load ad once google tag exists
	window.nineto5ads = window.nineto5ads|| [];
	window.nineto5ads.push(function() {
		googletag.display("div-gpt-ad-1436850350386-0");
		googletag.pubads().refresh([adslot]);
	});
</script>			</div>
			<header>
				<div class="mobile-menu">
					<div class="elastic-container">
						<div class="navigation-bar">
		                    <!-- Start of navigation toggle -->
				            <div class="mobile-nav-toggle">
							    <a id="nav-toggle" href="#"><span></span></a>
							</div>
							  <!-- End of navigation toggle -->
						</div>
						<nav>
							<ul id="menu-below-ad" class="menu"><li id="menu-item-114572" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-114572"><a href="https://9to5mac.com">9to5Mac</a></li>
<li id="menu-item-114574" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-114574"><a href="https://9to5toys.com">9to5Toys</a></li>
<li id="menu-item-114573" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-114573"><a href="https://electrek.co/">Electrek</a></li>
<li id="menu-item-114575" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-114575"><a href="/community">Community</a></li>
<li id="menu-item-114576" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-114576"><a href="https://9to5mac.com/about/">About</a></li>
<li id="menu-item-114577" class="tipsli menu-item menu-item-type-custom menu-item-object-custom menu-item-114577"><a href="https://9to5mac.com/contact/">Tips/Contact</a></li>
</ul>						</nav>
						<div class="nav-social">
							<ul>
								<li>
									<a href="https://9to5google.com/push/" title="Signup for Safari Notifications"><i class="icon-pushup"></i></a>
<a href="http://eepurl.com/bdw6AH" title="Signup for our email list"><i class="icon-mail"></i></a>
<a href="http://www.facebook.com/pages/9to5Google/218132111544562" title="Like us on Facebook"><i class="icon-facebook"></i></a>
<a href="http://twitter.com/9to5google" title="Follow us on Twitter"><i class="icon-twitter"></i></a>
<a href="https://plus.google.com/103164410861123991325"  title="Add us on Google Plus"><i class="icon-google-plus"></i></a>
<a href="https://www.youtube.com/c/9to5google" title="View 9to5 on YouTube"><i class="icon-youtube"></i></a>
<a href="https://9to5google.com/feed" title="Follow our feed"><i class="icon-feed"></i></a>
								</li>
							</ul>
						</div>
					</div>
				</div><!-- .mobile-menu -->
				<div class="header-wrap">
					<div class="elastic-container header-top">
						<div class="logo">
							<a href="https://9to5google.com/" rel="home">
								<img src="https://9to5google.files.wordpress.com/2015/07/cropped-9to5-google-logo2.png" alt="" />
							</a>
							<div id="mobile-search-icon">
								<a id="search-toggle" href="#"><span class="search-container"></span><span class="close"></span></a>
							</div>
							<div id="mobile-nav-icon">
								<a id="mobile-main-nav-toggle" href="#"><span></span></a>
							</div>
						</div>
						<div class="header-right">
							<div class="search-container">
								
<form role="search" class="search-form" method="get" action="https://9to5google.com/">
	<label>
		<span class="screen-reader-text">Search</span>
		<input type="search" placeholder="search" name="s" class="searchInput" value="">
	</label>
	<input type="submit" value="search">
</form>
							</div>
							<div class="social">
								<a href="https://9to5google.com/push/" title="Signup for Safari Notifications"><i class="icon-pushup"></i></a>
<a href="http://eepurl.com/bdw6AH" title="Signup for our email list"><i class="icon-mail"></i></a>
<a href="http://www.facebook.com/pages/9to5Google/218132111544562" title="Like us on Facebook"><i class="icon-facebook"></i></a>
<a href="http://twitter.com/9to5google" title="Follow us on Twitter"><i class="icon-twitter"></i></a>
<a href="https://plus.google.com/103164410861123991325"  title="Add us on Google Plus"><i class="icon-google-plus"></i></a>
<a href="https://www.youtube.com/c/9to5google" title="View 9to5 on YouTube"><i class="icon-youtube"></i></a>
<a href="https://9to5google.com/feed" title="Follow our feed"><i class="icon-feed"></i></a>
							</div>
						</div>
													<nav class="site-nav header-nav">
								<ul id="menu-top-nav" class="menu"><li id="menu-item-145656" class="menu-item menu-item-type-taxonomy menu-item-object-ninetofive_guides menu-item-145656"><a href="https://9to5google.com/guides/android/">Android</a></li>
<li id="menu-item-145658" class="menu-item menu-item-type-taxonomy menu-item-object-ninetofive_guides menu-item-145658"><a href="https://9to5google.com/guides/chromeos/">Chrome/OS</a></li>
<li id="menu-item-145933" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-145933"><a href="https://9to5google.com/guides">Guides</a>
<ul class="sub-menu">
	<li id="menu-item-145934" class="menu-item menu-item-type-taxonomy menu-item-object-ninetofive_guides menu-item-145934 has-image"><a href="https://9to5google.com/guides/android/"><span>Android</span><img src="https://9to5google.files.wordpress.com/2015/10/android-versions.jpg?quality=82&#038;strip=all&#038;w=155"></a></li>
	<li id="menu-item-145935" class="menu-item menu-item-type-taxonomy menu-item-object-ninetofive_guides menu-item-145935 has-image"><a href="https://9to5google.com/guides/android-wear/"><span>Android Wear</span><img src="https://9to5google.files.wordpress.com/2016/07/android-wear-moto-360-close-up-1200-80.jpg?quality=82&#038;strip=all&#038;w=149"></a></li>
	<li id="menu-item-145938" class="menu-item menu-item-type-taxonomy menu-item-object-ninetofive_guides menu-item-145938 has-image"><a href="https://9to5google.com/guides/android-auto/"><span>Android Auto</span><img src="https://9to5google.files.wordpress.com/2016/07/unnamed1.png?w=130"></a></li>
	<li id="menu-item-145936" class="menu-item menu-item-type-taxonomy menu-item-object-ninetofive_guides menu-item-145936 has-image"><a href="https://9to5google.com/guides/nexus/"><span>Nexus</span><img src="https://9to5google.files.wordpress.com/2016/07/nexus-6p-topic-full.png?w=155"></a></li>
	<li id="menu-item-146068" class="menu-item menu-item-type-taxonomy menu-item-object-ninetofive_guides menu-item-146068 has-image"><a href="https://9to5google.com/guides/chromebook/"><span>Chromebook</span><img src="https://9to5google.files.wordpress.com/2016/07/hero-chromebook-pixel.png?w=155"></a></li>
</ul>
</li>
<li id="menu-item-145659" class="menu-item menu-item-type-taxonomy menu-item-object-ninetofive_guides menu-item-145659"><a href="https://9to5google.com/guides/google-apps/"><span>Google Apps</a></li>
<li id="menu-item-145657" class="menu-item menu-item-type-taxonomy menu-item-object-ninetofive_guides menu-item-145657"><a href="https://9to5google.com/guides/android-tv/"><span>Android TV</a></li>
<li id="menu-item-145661" class="menu-item menu-item-type-taxonomy menu-item-object-ninetofive_guides menu-item-145661"><a href="https://9to5google.com/guides/youtube/"><span>YouTube</a></li>
</ul>							</nav>
											</div>
									</div><!-- .header-wrap -->
			</header>
			<div id="header-placeholder"></div>

			<aside class="trending-wrapper"><div class="trending-items">
				<div>
					<a href="https://9to5google.com/2017/04/21/samsung-galaxy-s8-review/" rel="bookmark">
						<div class="title">Trending in Google</div>
						<p class="trending-excerpt">Review: Samsung Galaxy S8 brings a familiar formula even nearer to perfection&nbsp;[Video]</p>
					</a>
				</div>
			
				<div>
					<a href="https://9to5google.com/2017/04/20/alcatel-a30-review/" rel="bookmark">
						<div class="title">Trending in Google</div>
						<p class="trending-excerpt">Review: The Alcatel A30 offers Android Nougat and a decent camera for just&nbsp;$60</p>
					</a>
				</div>
			
				<div>
					<a href="https://9to5google.com/2017/04/08/best-samsung-galaxy-s8-plus-cases/" rel="bookmark">
						<div class="title">Trending in Google Corporate</div>
						<p class="trending-excerpt">Here are all of the best cases to go with your Samsung Galaxy S8 and S8+&nbsp;pre-order</p>
					</a>
				</div>
			
				<div>
					<a href="https://9to5google.com/2017/04/08/huawei-p10-review/" rel="bookmark">
						<div class="title">Trending in Google</div>
						<p class="trending-excerpt">Review: Huawei P10 packs excellent optics and good hardware into a forgettable phone&nbsp;[Video]</p>
					</a>
				</div>
			
				<div>
					<a href="https://9to5google.com/2017/04/07/lg-g6-review/" rel="bookmark">
						<div class="title">Trending in Google Corporate</div>
						<p class="trending-excerpt">LG G6 Review: The screen doesn&#8217;t cut corners, but software &amp; optimization do&nbsp;[Video]</p>
					</a>
				</div>
			
				<div>
					<a href="https://9to5google.com/2017/04/05/asus-chromebook-flip-c302ca-review/" rel="bookmark">
						<div class="title">Trending in Google</div>
						<p class="trending-excerpt">Review: ASUS Chromebook Flip C302CA is an underdog that deserves your&nbsp;attention</p>
					</a>
				</div>
			</div></aside>
		<div id="content">
					<div class="news-feed-header">
				<div class="elastic-container">
					<div class="currently-reading">
						<p>Today</p>
					</div><!-- .currently-reading -->
						<div class="stock-data GOOG-stock">
							<div class="current">
								<p>GOOG: 871.14</p>
							</div><!-- .current -->
								<div class="change change-down">
									-0.59
										<img src="https://s0.wp.com/wp-content/themes/vip/9to5-2015/images/stock-down.png" class="stock-down">
								</div><!-- .change -->
								<div class="stock-chart">
									<img src="https://chart.finance.yahoo.com/z?s=GOOG&#038;t=1d&#038;q=l&#038;l=on&#038;z=s&#038;region=us&#038;lang=en-US" alt="Stock Chart">
								</div><!-- .stock-chart -->
						</div><!-- stock-data -->


				</div><!-- .elastic-container -->
			</div><!-- .news-feed-header -->
			<div id="news-placeholder"></div>

		<article class="post-content" itemscope itemtype="http://schema.org/NewsArticle">
			<div itemprop="mainEntityOfPage">
				<div class="elastic-container">
					<h1 class="post-title" itemprop="headline"><a href="https://9to5google.com/2017/04/27/google-assistant-sdk/">Google Assistant can now run on other devices, developer preview SDK launching&nbsp;today</a></h1>
					<div class="post-meta">
						<p class="byline" itemprop="author" itemscope itemtype="https://schema.org/Person">
							<a href="https://9to5google.com/author/technacity/">
								<span itemprop="name">Abner Li</span>
							</a>
						</p>
						<p class="time-twitter">
							- Apr. 27th 2017 10:39 am PT
								<div class="icon-twitter"></div>
								<p><a href="https://twitter.com/technacity" target="_blank" class="twitter-handle">@technacity</a></p>
						</p>
						<div class="tags">
							<div class="post-cats">

									<a href="https://9to5google.com/guides/google-assistant/" title="View all posts in Google Assistant">Google Assistant</a>

								<meta itemprop="keywords" content="Google Assistant,"/>
							</div><!-- .post-cats -->
						</div><!-- .tags -->
						<meta itemprop="datePublished" content="2017-04-27 10:39:42"/>
						<meta itemprop="dateModified" content="2017-04-27 10:39:42"/>
					</div><!-- .post-meta -->
				</div><!-- .elastic-container -->
				<div class="feat-image-wrapper">
						<div itemprop="image" itemscope itemtype="https://schema.org/ImageObject">
							<meta itemprop="url" content="https://9to5google.files.wordpress.com/2017/04/google-assistant-sdk-e1493313856274.jpg?quality=82&#038;strip=all&#038;w=1000&#038;strip=all&#038;w=1600&#038;h=1000">
							<meta itemprop="height" content="688">
							<meta itemprop="width" content="1376">
						</div>
						<div class="feat-image wide">
							<a href="https://9to5google.com/2017/04/27/google-assistant-sdk/">
								<img src="https://9to5google.files.wordpress.com/2017/04/google-assistant-sdk-e1493313856274.jpg?quality=82&#038;strip=all&#038;w=1000&#038;strip=all&#038;w=1600&#038;h=1000" srcset="https://9to5google.files.wordpress.com/2017/04/google-assistant-sdk-e1493313856274.jpg?quality=82&amp;strip=all&amp;w=1000&amp;strip=all&amp;w=320&amp;h=1000 320w, https://9to5google.files.wordpress.com/2017/04/google-assistant-sdk-e1493313856274.jpg?quality=82&amp;strip=all&amp;w=1000&amp;strip=all&amp;w=640&amp;h=1000 640w, https://9to5google.files.wordpress.com/2017/04/google-assistant-sdk-e1493313856274.jpg?quality=82&amp;strip=all&amp;w=1000&amp;strip=all&amp;w=1024&amp;h=1000 1024w, https://9to5google.files.wordpress.com/2017/04/google-assistant-sdk-e1493313856274.jpg?quality=82&amp;strip=all&amp;w=1000&amp;strip=all&amp;w=1500&amp;h=1000 1500w, https://9to5google.files.wordpress.com/2017/04/google-assistant-sdk-e1493313856274.jpg?quality=82&amp;strip=all&amp;w=1000&amp;strip=all&amp;w=2000&amp;h=1000 2000w, https://9to5google.files.wordpress.com/2017/04/google-assistant-sdk-e1493313856274.jpg?quality=82&amp;strip=all&amp;w=1000&amp;strip=all&amp;w=2500&amp;h=1000 2500w">
							</a>
						</div><!-- .feat-image -->
					<div class="post-social-mobile">
						<a href="https://9to5google.com/2017/04/27/google-assistant-sdk/#comments" class="comments" itemprop="discussionUrl"><span class="dsq-postid" rel="175912 https://9to5google.com/?p=175912">View Comments</span></a>
						<div class="sharedaddy sd-sharing-enabled"><div class="robots-nocontent sd-block sd-social sd-social-text sd-sharing"><div class="sd-content"><ul><li class="share-facebook"><a rel="nofollow" data-shared="sharing-facebook-175912" class="share-facebook sd-button no-icon" href="https://9to5google.com/2017/04/27/google-assistant-sdk/?share=facebook" target="_blank" title="Share on Facebook"><span>Facebook</span></a></li><li class="share-twitter"><a rel="nofollow" data-shared="sharing-twitter-175912" class="share-twitter sd-button no-icon" href="https://9to5google.com/2017/04/27/google-assistant-sdk/?share=twitter" target="_blank" title="Click to share on Twitter"><span>Twitter</span></a></li><li class="share-google-plus-1"><a rel="nofollow" data-shared="sharing-google-175912" class="share-google-plus-1 sd-button no-icon" href="https://9to5google.com/2017/04/27/google-assistant-sdk/?share=google-plus-1" target="_blank" title="Click to share on Google+"><span>Google</span></a></li><li class="share-pinterest"><a rel="nofollow" data-shared="sharing-pinterest-175912" class="share-pinterest sd-button no-icon" href="https://9to5google.com/2017/04/27/google-assistant-sdk/?share=pinterest" target="_blank" title="Click to share on Pinterest"><span>Pinterest</span></a></li><li class="share-reddit"><a rel="nofollow" data-shared="" class="share-reddit sd-button no-icon" href="https://9to5google.com/2017/04/27/google-assistant-sdk/?share=reddit" target="_blank" title="Click to share on Reddit"><span>Reddit</span></a></li><li class="share-end"></li></ul></div></div></div>
					</div><!-- .post-social-mobile -->
				</div><!-- .feat-image-wrapper -->
				<div class="elastic-container">
					<div class="post-body" itemprop="articleBody">
						
<p>With a wider rollout of Assistant currently underway for <a href="https://9to5google.com/2017/03/08/google-assistant-non-pixel/">Android phones</a> and <a href="https://9to5google.com/2017/04/17/how-to-update-your-smartwatch-to-android-wear-2-0-manually-using-ota-downloads/">Wear</a>, Google today announced a developer preview SDK that will allow Assistant to be built into third-party devices.</p>
<p><span id="more-175912"></span>
	<ins class="adsbygoogle author_ad" style="display:block;" data-ad-client="ca-pub-7114551592991368" data-ad-slot="4679583531"></ins>
<script type="text/javascript">(adsbygoogle = window.adsbygoogle || []).push({});</script>
		
<div class="th63ad2f86 thec56f00e"><div class="th1a14c064" data-thafe73f0b="https://goo.gl/6Z2HlN"><img src="https://i1.wp.com/cdn02.nintendo-europe.com/media/images/08_content_images/news_5/2017/january_9/CI_NSwitch_Console_02.jpg?resize=300%2C250&#038;quality=82&#038;strip=all&#038;ssl=1"/><h3>Nintendo Switch</h3></div></div></p>
<p>Google touts self-built robots and voice-enabled <a href="https://9to5google.com/2016/03/16/android-experiment-smart-mirror/">smart mirrors</a> as examples of hardware prototypes that could feature Assistant.</p>
<p>As a developer preview, a number of features are still in development, including hotword support and companion app integration:</p>
<blockquote><p>The Google Assistant SDK includes a <a href="http://www.grpc.io/">gRPC</a> API, a Python open source client that handles authentication and access to the API, samples and documentation. The SDK allows you to capture a spoken query, for example &#8220;what&#8217;s on my calendar&#8221;, pass that up to the Google Assistant service and receive an audio response.</p></blockquote>
<p>Devices like the Raspberry Pi are suggested for initial prototyping, but Google emphasizes that Assistant will run on a wide variety of other platforms as long as they fit the <a href="https://developers.google.com/assistant/sdk/prototype/getting-started-other-platforms/">basic requirements</a>.</p>
<blockquote><p>We&#8217;ve created a new developer community on Google+ at <a href="https://g.co/assistantsdkdev">g.co/assistantsdkdev</a> for developers to keep up to date and discuss ideas. There is also a <a href="http://stackoverflow.com/questions/tagged/google-assistant-sdk">stackoverflow tag</a> [google-assistant-sdk] for questions, and a <a href="https://groups.google.com/forum/#!forum/google-assistant-sdk-updates">mailing list</a> to keep up to date on SDK news.</p></blockquote>
<p>Google encourages companies that are interested in making a commercial product to <a href="https://developers.google.com/assistant/sdk/interest">reach out</a>. The company also notes that Android Auto and Android TV will get Assistant support &#8220;soon.&#8221;</p>
<p><span class="embed-youtube" style="text-align:center; display: block;"><iframe class='youtube-player' type='text/html' width='704' height='426' src='https://www.youtube.com/embed/Wsic12MXlsc?version=3&#038;rel=1&#038;fs=1&#038;autohide=2&#038;showsearch=0&#038;showinfo=1&#038;iv_load_policy=1&#038;wmode=transparent' allowfullscreen='true' style='border:0;'></iframe></span></p>

					</div><!-- .post-body -->

				</div><!-- .elastic-container -->

				<div itemprop="publisher" itemscope itemtype="https://schema.org/Organization">
					<div itemprop="logo" itemscope itemtype="https://schema.org/ImageObject">
						<meta itemprop="url" content="https://9to5google.files.wordpress.com/2015/07/cropped-9to5-google-logo2.png">
						<meta itemprop="width" content="628">
						<meta itemprop="height" content="103">
					</div>
					<meta itemprop="name" content="9to5Google">
				</div>

			</div><!-- mainEntityOfPage -->

			<div class="author-bio-container">
				<div class="elastic-container">
					<div class="author-bio" itemprop="author" itemscope itemtype="https://schema.org/Person">
							<div class="author-bio-details">
								<a href="https://9to5google.com/author/technacity/">
									<img src="https://secure.gravatar.com/avatar/ba5acd965e31e2bfe2fbd4e37d8f68b9?s=512&#038;d=mm&#038;r=r" class="author-gravatar">
								</a>
								<h3>
									<a href="https://9to5google.com/author/technacity/">
										<span itemprop="name">Abner Li</span>
									</a>
								</h3>

									<p class="twitter">
										<a href="https://twitter.com/technacity" target="_blank" class="twitter-handle"><span class="icon-twitter"></span>@technacity</a>
									</p>

								<p class="author-excerpt">
									<p>Is interested in the minutiae of Google and Alphabet. Tips/talk: abner@9to5g.com</p>

								</p>
						</div>
					</div>
						<div class="author-gear">
							<h3>Favorite Gear</h3>
							<div class="author-gear-list">
								<div class="author-gear-item">
										<div class="author-gear-item-image">
											<a href="https://goo.gl/GmeUU0" target="_blank">
												<img src="https://i1.wp.com/i.imgur.com/e9KpWB2.png?resize=300%2C175&#038;quality=82&#038;strip=all&#038;ssl=1" title="Fitbit Charge 2" alt="Fitbit Charge 2" width="290" height="145"/>
											</a>
											<h4><a href="https://goo.gl/GmeUU0" target="_blank">Fitbit Charge 2</a></h4>
										</div>
								</div>
								<div class="author-gear-item">
										<div class="author-gear-item-image">
											<a href="https://goo.gl/VwZVSo" target="_blank">
												<img src="https://i0.wp.com/i.imgur.com/4axPc31.jpg?resize=300%2C175&#038;quality=82&#038;strip=all&#038;ssl=1" title="Breath of the Wild" alt="Breath of the Wild" width="290" height="145"/>
											</a>
											<h4><a href="https://goo.gl/VwZVSo" target="_blank">Breath of the Wild</a></h4>
										</div>
								</div>
								<div class="author-gear-item">
										<div class="author-gear-item-image">
											<a href="https://goo.gl/PFiDwG" target="_blank">
												<img src="https://i0.wp.com/i.imgur.com/dQqqHsk.png?resize=300%2C175&#038;quality=82&#038;strip=all&#038;ssl=1" title="Joy-Con" alt="Joy-Con" width="290" height="145"/>
											</a>
											<h4><a href="https://goo.gl/PFiDwG" target="_blank">Joy-Con</a></h4>
										</div>
								</div>
							</div>
						</div>
				</div>
			</div>

					<div class="elastic-container related-guides-container">
						<h1>Guides</h1>
							<div class="related-guides-item">
								<h3>Google Assistant</h3>
								<div class="related-guides-item-image">
									<a href="https://9to5google.com/guides/google-assistant/">
									<img src="https://s0.wp.com/wp-content/themes/vip/9to5-2015/images/default-9to5google-related-guide.png" title="Google Assistant" alt="Google Assistant" />
									</a>
								</div>
								<p></p>
								<div class='related-guides-action'>
								<a href="https://9to5google.com/guides/google-assistant/" class="related-guide-view-more">View THe Guide</a>
								</div>
							</div>
					</div>


				<div id="div-gpt-ad-1437016474156-0-175912" class="inlinead"></div>

		</article><!-- .post-content -->

					<div id="comments" class="comments-area post-body">
				<div class="elastic-container">
					<div id="disqus_thread">
	<div id="dsq-content">
		<ul id="dsq-comments">
					</ul>
			</div>
</div>
		
<a href="http://disqus.com" class="dsq-brlink">blog comments powered by <span class="logo-disqus">Disqus</span></a>

<script type="text/javascript" charset="utf-8">
	var disqus_url = "https:\/\/9to5google.com\/2017\/04\/27\/google-assistant-sdk\/";
	var disqus_identifier = "175912 http:\/\/9to5google.com\/?p=175912";
	var disqus_container_id = 'disqus_thread';
	var disqus_domain = "disqus.com";
	var disqus_shortname = "9to5googleprod";
		var disqus_config = function () {
	    var config = this; // Access to the config object

	    /* 
	       All currently supported events:
	        * preData — fires just before we request for initial data
	        * preInit - fires after we get initial data but before we load any dependencies
	        * onInit  - fires when all dependencies are resolved but before dtpl template is rendered
	        * afterRender - fires when template is rendered but before we show it
	        * onReady - everything is done
	     */

		config.callbacks.preData.push(function() {
			// clear out the container (its filled for SEO/legacy purposes)
			document.getElementById(disqus_container_id).innerHTML = '';
		})
		config.callbacks.onReady.push(function() {
/*
			// sync comments in the background so we don't block the page
			var req = new XMLHttpRequest();
			req.open('GET', '?cf_action=sync_comments&post_id=175912', true);
			req.send(null);
*/
		});
		
			};
	
	var facebookXdReceiverPath = "http:\/\/9to5google.wordpress.com\/wp-content\/themes\/vip\/plugins\/disqus\/xd_receiver.htm";
</script>

<script type="text/javascript" charset="utf-8">
	var DsqLocal = {
		'trackbacks': [
		],
		'trackback_url': "https:\/\/9to5google.com\/2017\/04\/27\/google-assistant-sdk\/trackback\/"	};
</script>

<script type="text/javascript" charset="utf-8">
(function() {
	var dsq = document.createElement('script'); dsq.type = 'text/javascript';
	dsq.async = true;
	dsq.src = '//' + disqus_shortname + '.' + disqus_domain + '/embed.js?pname=wordpress&pver=2.40';
	(document.getElementsByTagName('head')[0] || document.getElementsByTagName('body')[0]).appendChild(dsq);
})();
</script>
				</div><!-- .elastic-container -->
			</div><!-- #comments.comments-area -->
			</div><!-- #content -->


	<div id="tips-form" class="tips-form">
		<h2>Submit a Tip</h2>
		<a href="#" class="cancel">cancel</a>
		<form>
			<input type="hidden" id="tips-form-nonce" name="tips-form-nonce" value="fa188d46f9" /><input type="hidden" name="_wp_http_referer" value="/2017/04/27/google-assistant-sdk/" />						<input type="hidden" name="action" value="tips_submit">
			<input type="text" name="name" id="tips-form-name" placeholder="Name (optional)">
			<input type="text" name="email" id="tips-form-email" placeholder="Email (optional)">
			<textarea name="tip" id="tips-form-tip" placeholder="tips@9to5mac.com"></textarea>
			<p class="submit-text">
				<input type="submit">
				Submitting a tip constitutes permission to publish and syndicate. Please view our <a href="http://9to5mac.com/privacy/">tips policy</a> or see <a href="http://9to5mac.com/contact/">all contact options</a>.
			</p>
			<p class="response"></p>
		</form>
	</div><!-- #tips-form -->

	<div style="text-align:center">
		<a href="https://vip.wordpress.com/?utm_source=vip_powered_wpcom&#038;utm_medium=web&#038;utm_campaign=VIP%20Footer%20Credit" rel="generator nofollow" class="powered-by-wpcom"><img src="https://s0.wp.com/wp-content/themes/vip/plugins/vip-do-not-include-on-wpcom/vip-powered-wpcom/images/vip-powered-light-small.png" width="187" height="26" alt="Powered by WordPress.com VIP" /></a>	</div>

		<script type="text/javascript">
		//<![CDATA[
		var ninetofiveInfiniteScroll = {"settings":{"id":"content","ajaxurl":"https:\/\/9to5google.com\/?infinity=scrolling","currentday":"27.04.17","order":"DESC","offset":0,"history":{"host":"9to5google.com","path":"\/2017\/04\/27\/google-assistant-sdk\/page\/%d\/","use_trailing_slashes":true,"parameters":""},"query_args":{"page":0,"year":2017,"monthnum":4,"day":27,"name":"google-assistant-sdk","error":"","m":"","p":0,"post_parent":"","subpost":"","subpost_id":"","attachment":"","attachment_id":0,"static":"","pagename":"","page_id":0,"second":"","minute":"","hour":"","w":0,"category_name":"","tag":"","cat":"","tag_id":"","author":"","author_name":"","feed":"","tb":"","paged":0,"meta_key":"","meta_value":"","preview":"","s":"","sentence":"","title":"","fields":"","menu_order":"","embed":"","category__in":[],"category__not_in":[],"category__and":[],"post__in":[],"post__not_in":[],"post_name__in":[],"tag__in":[],"tag__not_in":[],"tag__and":[],"tag_slug__in":[],"tag_slug__and":[],"post_parent__in":[],"post_parent__not_in":[],"author__in":[],"author__not_in":[],"ignore_sticky_posts":false,"suppress_filters":false,"cache_results":false,"update_post_term_cache":true,"lazy_load_term_meta":true,"update_post_meta_cache":true,"post_type":"","posts_per_page":6,"nopaging":false,"comments_per_page":"75","no_found_rows":false,"order":"DESC"},"last_post_date":"2017-04-27 10:39:42","dfp_id":"1049447","post_id":175912,"stats":"blog=22427743&v=wpcom&tz=-7&user_id=0&post=175912&subd=9to5google&x_pagetype=infinite"}};
		//]]>
	</script>
<!-- wpcom_wp_footer -->
	<script type="text/javascript">
	// <![CDATA[
		var disqus_shortname = "9to5googleprod";
		var disqus_domain = "disqus.com";
		(function () {
			var nodes = document.getElementsByTagName('span');
			for (var i = 0, url; i < nodes.length; i++) {
				if (nodes[i].className.indexOf('dsq-postid') != -1) {
					var shorturl = nodes[i].getAttribute('rel');
					var new_rel = shorturl.replace( 'https:', 'http:' );
					nodes[i].parentNode.setAttribute('data-disqus-identifier', new_rel );
					url = nodes[i].parentNode.href.split('#', 1);
					if (url.length == 1) url = url[0];
					else url = url[1]
					nodes[i].parentNode.href = url + '#disqus_thread';
				}
			}
			var s = document.createElement('script'); s.async = true;
			s.type = 'text/javascript';
			s.src = '//' + disqus_domain + '/forums/' + disqus_shortname + '/count.js';
			(document.getElementsByTagName('HEAD')[0] || document.getElementsByTagName('BODY')[0]).appendChild(s);
		}());
	//]]>
	</script>
<script id='loop-template' type='x-tmpl-mustache'>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</script><script id='content-template' type='x-tmpl-mustache'><div class="extended">
	{{{ post_content }}}

	{{# product_link }}
		{{# product_price }}
			<div class="product_cta_lower">
				<a href="{{ product_link }}" class="product-button{{# savings_amount }} has-savings{{/ savings_amount }}" target="_blank">
					{{# savings_amount }}
						<span class="product-savings-amount">Get this deal<br/>{{ savings_amount }}</span>
					{{/ savings_amount }}
					<span class="product-price">{{ product_price }}</span>
				</a>
			</div>
		{{/ product_price }}
	{{/ product_link }}

	<div class="contract-mobile">
		<a href="#" class="less-link less-post"><span class="moretext">close full story</span> <span class="x-animate"></span></a>
	</div><!-- .contract-mobile -->
</div><!-- .extended -->
</script><script id='aside-template' type='x-tmpl-mustache'><div class="post-body">
	<div class="post-meta">
		<div class="tags">
			<div class="post-cats">
				{{# featured_tags }}
        	<a href="{{tag_link}}" title="View all posts in {{tag_name}}" class="featured_tag">{{tag_name}}</a>
        {{/ featured_tags }}
				{{# categories }}
					<a href="{{cat_link}}" title="View all posts in {{cat_name}}">{{cat_name}}</a>
				{{/ categories }}
			</div><!-- .post-cats -->
		</div><!-- .tags -->
	</div><!-- .post-meta -->
	{{# featured_image }}
		{{# product_link }}
			{{# product_price }}
				<div class="product_cta_image">
					<a href="{{ product_link }}" class="product-button{{# savings_amount }} has-savings{{/ savings_amount }}" target="_blank">
						{{# savings_amount }}
							<span class="product-savings-amount">Get this deal<br/>{{ savings_amount }}</span>
						{{/ savings_amount }}
						<span class="product-price">{{ product_price }}</span>
					</a>
				</div>
			{{/ product_price }}
		{{/ product_link }}

		<div class="feat-image-wrapper">
			{{# featured_image }}
				<div class="feat-image{{ image_class }}"><img src="{{featured_image}}" srcset="{{ srcset }}"></div>
			{{/ featured_image }}
			<div class="post-social-mobile">
				<a href="{{permalink}}#comments" class="comments">{{{comment_count}}}</a>
				{{{share_buttons}}}
			</div><!-- .post-social-mobile -->
		</div><!-- .feat-image-wrapper -->

	{{/ featured_image }}
	{{{post_content}}}
	{{# meta.display_author_ad }}
		{{{ meta.author_ad }}}
	{{/ meta.display_author_ad }}

	{{# product_link }}
		{{# product_price }}
			<div class="product_cta_lower">
				<a href="{{ product_link }}" class="product-button{{# savings_amount }} has-savings{{/ savings_amount }}" target="_blank">
					{{# savings_amount }}
						<span class="product-savings-amount">Get this deal<br/>{{ savings_amount }}</span>
					{{/ savings_amount }}
					<span class="product-price">{{ product_price }}</span>
				</a>
			</div>
		{{/ product_price }}
	{{/ product_link }}

	{{! Display the social sharing buttons at the bottom if we don't have a featured image. }}
	{{^ featured_image }}
		<div class="post-social">
			<a href="{{permalink}}#comments" class="comments">{{{comment_count}}}</a>
			{{{share_buttons}}}
		</div><!-- .post-social -->
	{{/ featured_image }}

	<div class="contract-mobile">
		<a href="#" class="less-link less-aside"><span class="moretext">close full story</span> <span class="x-animate"></span></a>
	</div><!-- .contract-mobile -->
</div><!-- .post-body -->
</script>	<div style="display:none">
	</div>
<script type='text/javascript'>
/* <![CDATA[ */
var HighlanderComments = {"loggingInText":"Logging In\u2026","submittingText":"Posting Comment\u2026","postCommentText":"Post Comment","connectingToText":"Connecting to %s","commentingAsText":"%1$s: You are commenting using your %2$s account.","logoutText":"Log Out","loginText":"Log In","connectURL":"https:\/\/9to5google.wordpress.com\/public.api\/connect\/?action=request","logoutURL":"https:\/\/9to5google.wordpress.com\/wp-login.php?action=logout&_wpnonce=fd46ae6d70","homeURL":"https:\/\/9to5google.com\/","postID":"175912","gravDefault":"mystery","enterACommentError":"Please enter a comment","enterEmailError":"Please enter your email address here","invalidEmailError":"Invalid email address","enterAuthorError":"Please enter your name here","gravatarFromEmail":"This picture will show whenever you leave a comment. Click to customize it.","logInToExternalAccount":"Log in to use details from one of these accounts.","change":"Change","changeAccount":"Change Account","comment_registration":"1","userIsLoggedIn":"","isJetpack":"0","text_direction":"ltr"};
/* ]]> */
</script>
<script type='text/javascript' src='https://s2.wp.com/_static/??/wp-content/js/jquery/jquery.autoresize.js,/wp-content/mu-plugins/highlander-comments/script.js?m=1479964158j'></script>

	<div id="carousel-reblog-box">
		<form action="#" name="carousel-reblog">
			<textarea id="carousel-reblog-content" name="carousel-reblog-content" placeholder="Add your thoughts here... (optional)"></textarea>
			<label for="carousel-reblog-to-blog-id" id="carousel-reblog-lblogid">Post to</label>
			<select name="carousel-reblog-to-blog-id" id="carousel-reblog-to-blog-id">
						</select>

			<div class="submit">
				<span class="canceltext"><a href="#" class="cancel">Cancel</a></span>
				<input type="submit" name="carousel-reblog-submit" class="button" id="carousel-reblog-submit" value="Reblog Post" />
				<input type="hidden" id="carousel-reblog-blog-id" value="22427743" />
				<input type="hidden" id="carousel-reblog-blog-url" value="https://9to5google.com" />
				<input type="hidden" id="carousel-reblog-blog-title" value="9to5Google" />
				<input type="hidden" id="carousel-reblog-post-url" value="" />
				<input type="hidden" id="carousel-reblog-post-title" value="" />
			</div>

			<input type="hidden" id="_wpnonce" name="_wpnonce" value="a6b4cdf7b5" /><input type="hidden" name="_wp_http_referer" value="/2017/04/27/google-assistant-sdk/" />		</form>

		<div class="arrow"></div>
	</div>
		<script type="text/javascript">
			var windowOpen;
		jQuery(document).on( 'ready post-load', function(){
			jQuery( 'a.share-facebook' ).on( 'click', function() {
				if ( 'undefined' !== typeof windowOpen ){ // If there's another sharing window open, close it.
					windowOpen.close();
				}
				windowOpen = window.open( jQuery(this).attr( 'href' ), 'wpcomfacebook', 'menubar=1,resizable=1,width=600,height=400' );
				return false;
			});
		});
		</script>
				<script type="text/javascript">
			var windowOpen;
		jQuery(document).on( 'ready post-load', function(){
			jQuery( 'a.share-twitter' ).on( 'click', function() {
				if ( 'undefined' !== typeof windowOpen ){ // If there's another sharing window open, close it.
					windowOpen.close();
				}
				windowOpen = window.open( jQuery(this).attr( 'href' ), 'wpcomtwitter', 'menubar=1,resizable=1,width=600,height=350' );
				return false;
			});
		});
		</script>
				<script type="text/javascript">
			var windowOpen;
		jQuery(document).on( 'ready post-load', function(){
			jQuery( 'a.share-google-plus-1' ).on( 'click', function() {
				if ( 'undefined' !== typeof windowOpen ){ // If there's another sharing window open, close it.
					windowOpen.close();
				}
				windowOpen = window.open( jQuery(this).attr( 'href' ), 'wpcomgoogle-plus-1', 'menubar=1,resizable=1,width=480,height=550' );
				return false;
			});
		});
		</script>
							<script type="text/javascript">
				jQuery(document).on('ready', function(){
					jQuery('body').on('click', 'a.share-pinterest', function(e){
						e.preventDefault();
						// Load Pinterest Bookmarklet code
						var s = document.createElement("script");
						s.type = "text/javascript";
						s.src = window.location.protocol + "//assets.pinterest.com/js/pinmarklet.js?r=" + ( Math.random() * 99999999 );
						var x = document.getElementsByTagName("script")[0];
						x.parentNode.insertBefore(s, x);
						// Trigger Stats
						var s = document.createElement("script");
						s.type = "text/javascript";
						s.src = this + ( this.toString().indexOf( '?' ) ? '&' : '?' ) + 'js_only=1';
						var x = document.getElementsByTagName("script")[0];
						x.parentNode.insertBefore(s, x);
					});
				});
			</script>
		<link rel='stylesheet' id='all-css-0-3' href='https://s0.wp.com/_static/??/wp-content/mu-plugins/tiled-gallery/tiled-gallery.css,/wp-content/mu-plugins/carousel/jetpack-carousel.css?m=1481571546j' type='text/css' media='all' />
<!--[if lte IE 8]>
<link rel='stylesheet' id='jetpack-carousel-ie8fix-css'  href='https://s1.wp.com/wp-content/mu-plugins/carousel/jetpack-carousel-ie8fix.css?m=1412618825h&#038;ver=20121024' type='text/css' media='all' />
<![endif]-->
<script type='text/javascript'>
/* <![CDATA[ */
var globalJSVars = {"ajaxurl":"https:\/\/9to5google.com\/wp-admin\/admin-ajax.php"};
/* ]]> */
</script>
<script type='text/javascript'>
/* <![CDATA[ */
var PushUpNotificationSettings = {"domain":"https:\/\/9to5google.wordpress.com","userID":"1","websitePushID":"web.com.9to5google","webServiceURL":"https:\/\/push.10up.com","prompt":"1"};
/* ]]> */
</script>
<script type='text/javascript'>
/* <![CDATA[ */
var stylesheetDirectory = "https:\/\/s0.wp.com\/wp-content\/themes\/vip\/9to5-2015";
/* ]]> */
</script>
<script type='text/javascript' src='https://s2.wp.com/_static/??-eJydjsEOgjAQRH/IskBE48H4LU27yGK7rWyL+vdCkMR4Um+TzMybgVtUJnBCTtALWBzJYLwXvWzgzfJZRZfPxAKOLihwzZix02wdDp/h1KGfIiNFOKTQqLqsGtAimGTeYGJMoaURC0/8Y5m4JaaESswQnPuasL6PWbocZ9Ki/rhg9BCyoFPaylolNi5bXPzg/YRRA0b3ePFP/lhtD3VZ7qp63z8BZo+F2g=='></script>
<script type='text/javascript' src='//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js?ver=0.1.1'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var mejsL10n = {"language":"en","strings":{"Close":"Close","Fullscreen":"Fullscreen","Turn off Fullscreen":"Turn off Fullscreen","Go Fullscreen":"Go Fullscreen","Download File":"Download File","Download Video":"Download Video","Play":"Play","Pause":"Pause","Captions\/Subtitles":"Captions\/Subtitles","None":"None","Time Slider":"Time Slider","Skip back %1 seconds":"Skip back %1 seconds","Video Player":"Video Player","Audio Player":"Audio Player","Volume Slider":"Volume Slider","Mute Toggle":"Mute Toggle","Unmute":"Unmute","Mute":"Mute","Use Up\/Down Arrow keys to increase or decrease volume.":"Use Up\/Down Arrow keys to increase or decrease volume.","Use Left\/Right Arrow keys to advance one second, Up\/Down arrows to advance ten seconds.":"Use Left\/Right Arrow keys to advance one second, Up\/Down arrows to advance ten seconds."}};
var _wpmejsSettings = {"pluginPath":"\/wp-includes\/js\/mediaelement\/"};
/* ]]> */
</script>
<script type='text/javascript'>
/* <![CDATA[ */
var wpcomVipAnalytics = {"is_404":"0","is_home":"0","is_single":"1","is_front_page":"0","is_archive":"0","percentToTrack":"1"};
/* ]]> */
</script>
<script type='text/javascript'>
/* <![CDATA[ */
var jetpackCarouselStrings = {"widths":[370,700,1000,1200,1400,2000],"is_logged_in":"","lang":"en","ajaxurl":"https:\/\/9to5google.com\/wp-admin\/admin-ajax.php","nonce":"e750d3bd22","display_exif":"1","display_geo":"1","single_image_gallery":"1","single_image_gallery_media_file":"","background_color":"black","comment":"Comment","post_comment":"Post Comment","write_comment":"Write a Comment...","loading_comments":"Loading Comments...","download_original":"View full size <span class=\"photo-size\">{0}<span class=\"photo-size-times\">\u00d7<\/span>{1}<\/span>","no_comment_text":"Please be sure to submit some text with your comment.","no_comment_email":"Please provide an email address to comment.","no_comment_author":"Please provide your name to comment.","comment_post_error":"Sorry, but there was an error posting your comment. Please try again later.","comment_approved":"Your comment was approved.","comment_unapproved":"Your comment is in moderation.","camera":"Camera","aperture":"Aperture","shutter_speed":"Shutter Speed","focal_length":"Focal Length","comment_registration":"1","require_name_email":"1","login_url":"https:\/\/9to5google.wordpress.com\/wp-login.php?redirect_to=https%3A%2F%2F9to5google.com%2F2017%2F04%2F27%2Fgoogle-assistant-sdk%2F","blog_id":"22427743","local_comments_commenting_as":"<p id=\"jp-carousel-commenting-as\">You must be <a href=\"#\" class=\"jp-carousel-comment-login\">logged in<\/a> to post a comment.<\/p>","reblog":"Reblog","reblogged":"Reblogged","reblog_add_thoughts":"Add your thoughts here... (optional)","reblogging":"Reblogging...","post_reblog":"Post Reblog","stats_query_args":"blog=22427743&v=wpcom&tz=-7&user_id=0&subd=9to5google","is_public":"1","reblog_enabled":""};
/* ]]> */
</script>
<script type='text/javascript' src='https://s0.wp.com/_static/??-eJx9j9EOwiAMRX/IDjXq9MH4LRUaUwSGFGb29zKNZibLnsotnFOqnhE4aFcMibKiPBlGcuQp5L8AGAxEhwOlxnNorKzUElvvpnnK6C7kt75UYblxELWFnuPoqKVOQjdk1rIAoKlCuGJSHiVTqifoekqJx8/8eguGzI4M3NA5SsN/mltO4vzS9lFG/lOa6auZmRpTV4ScspQj6jt8G5W5+PNmdzyt20O7b+0LpjGYJg=='></script>

	<script>
		(function($){
			$(document.body).on('post-load', function(){
				var nodes = document.querySelectorAll('span.dsq-postid');
				for (var i = 0, url; i < nodes.length; i++) {
					var shorturl = nodes[i].getAttribute('rel');
					var new_rel = shorturl.replace( 'https:', 'http:' );
					nodes[i].parentNode.setAttribute('data-disqus-identifier', new_rel );
					url = nodes[i].parentNode.href.split('#', 1);
					if (url.length == 1) url = url[0];
					else url = url[1]
					nodes[i].parentNode.href = url + '#disqus_thread';
				}

				var DISQUSWIDGETS = window.DISQUSWIDGETS || {};

				if ( Object.keys(DISQUSWIDGETS).length !== 0 && DISQUSWIDGETS.constructor === Object ) {
					DISQUSWIDGETS.getCount();
				}
			});
		})(jQuery);
	</script>

<script type="text/javascript">
// <![CDATA[
(function() {
try{
  if ( window.external &&'msIsSiteMode' in window.external) {
    if (window.external.msIsSiteMode()) {
      var jl = document.createElement('script');
      jl.type='text/javascript';
      jl.async=true;
      jl.src='/wp-content/plugins/ie-sitemode/custom-jumplist.php';
      var s = document.getElementsByTagName('script')[0];
      s.parentNode.insertBefore(jl, s);
    }
  }
}catch(e){}
})();
// ]]>
</script>		<!--// Begin OpenX Bidder //-->
		<script type="text/javascript" src="//nineto5mac-d.openx.net/w/1.0/jstag?nc=1049447-9to5google-desktop"></script>
		<script type='text/javascript'>
		// Make sure that googletag.cmd exists.
		window.googletag = window.googletag || {};
		googletag.cmd = googletag.cmd || [];
		(function() {
			var gads = document.createElement('script');
			gads.async = true;
			gads.type = 'text/javascript';
			gads.src = 'https://www.googletagservices.com/tag/js/gpt.js';
			var node = document.getElementsByTagName('script')[0];
			node.parentNode.insertBefore(gads, node);
		})();
		var secondaryMapping, adslot;

		googletag.cmd.push(function() {
			var mainMapping = googletag.sizeMapping().
				addSize([0, 0], [[320,50],[320,100]]).
				addSize([320, 400], [[320,50],[320,100]]).
				addSize([768, 200], [[468,60],[728,90]]).
				addSize([1050, 200], [[728,90],[970,70],[970,90],[970,250]]).
				build();

			secondaryMapping = googletag.sizeMapping().
				addSize([0, 0], [[300,250]]).
				addSize([320, 400], [[300,250]]).
				addSize([768, 200], [[300,250],[728,90]]).
				addSize([1050, 200], [[300,250],[728,90],[970,90],[970,250]]).
				build();

			adslot = googletag.defineSlot('/1049447/9to5google-728x90-TopMain-R', [[320, 100], [970, 90], [320, 50], [970, 250], [468, 60], [728, 90], [970, 70]], "div-gpt-ad-1436850350386-0").
				defineSizeMapping(mainMapping).
				addService(googletag.pubads());

			googletag.pubads().enableSingleRequest();
			googletag.pubads().collapseEmptyDivs();
			googletag.pubads().disableInitialLoad();
			googletag.enableServices();
		});

		window.nineto5ads = window.nineto5ads|| [];
		window.nineto5ads.forEach(function(ad){
			googletag.cmd.push(ad);
		});
		// Function to generate unique names for slots
		var nextSlotId = 1;
		function generateNextSlotName() {
			var id = nextSlotId++;
			return 'div-gpt-ad-' + id;
		}

		function loadAds( page, dfp_id ) {
			var $ads;

			if ( page === 1 ) {
				$ads = jQuery( '.post-content' ).find( '.inlinead:empty' );
			} else {
				$ads = jQuery( document.getElementById( 'infinite-view-' + ( page - 1 ) ) ).
					find( '.post-content .inlinead' );
			}

			$ads.each( function() {
				var slotName = generateNextSlotName(),
					slotDiv = document.createElement('div');

				slotDiv.id = slotName; // ID must be the same as slotName
				jQuery( this ).append( slotDiv );

				googletag.cmd.push( function() {
					var slot = googletag.defineSlot('/'+ dfp_id +'/9to5google-300x250-TopSidebarMain-R', [[300, 250], [970, 90], [970, 250], [728, 90]], slotName).
						defineSizeMapping(secondaryMapping).
						addService(googletag.pubads());

					// Display has to be called before
					// refresh and after the slot div is in the page.
					googletag.display(slotName);
					googletag.pubads().refresh([slot]);
				});
			});
		}
	</script>
	<script>
		// Check if our canRunAds variable is set
		if ( typeof canRunAds === 'undefined' || canRunAds === null ){
			document.body.classList.add( 'enable-fallbacks' );
		}

		if ( typeof OXHBConfig === 'undefined' || OXHBConfig === null ){
			document.body.classList.add( 'enable-fallbacks' );
		}

		(function($){
			$( '.th1a14c064' ).click( function () {
				window.open( $( this ).data( 'thafe73f0b' ) );
				return false;
			});
			
			$(document.body).on('post-load', function(){
				$( '.th1a14c064' ).click( function () {
					window.open( $( this ).data( 'thafe73f0b' ) );
					return false;
				});
			});
		})(jQuery);
	</script>
<script src="//stats.wp.com/w.js?56" type="text/javascript" async defer></script>
<script type="text/javascript">
_tkq = window._tkq || [];
_stq = window._stq || [];
_tkq.push(['storeContext', {'blog_id':'22427743','blog_tz':'-7','user_lang':'en','blog_lang':'en','user_id':'0'}]);
_stq.push(['view', {'blog':'22427743','v':'wpcom','tz':'-7','user_id':'0','post':'175912','subd':'9to5google'}]);
function st_vt() {var x=document.createElement("img");x.src="https://pixel.wp.com/g.gif?blog=22427743&v=wpcomvt&tz=-7&user_id=0&post=175912&subd=9to5google&rand="+Math.random();}
_stq.push(['extra', {'crypt':'UE40eW5QN0p8M2Y/RE1BNmNJfGhxNCVxUDExYmtib2E/SzdEJm0lUEtbdFU0fFk4cHZvcUFrZT90Tn4yQm1+R3NyNTdaY3ZNZFJuS3czaXFpJT9lMC56TmhYLjZfZnJRVmZ8ckZTYU9yaVpETGh0c01BS3lVVmM1SD9zVT9DMHclSWE9VVctQ0p+cDNHODBlekN6JiYvP3wsfEVCVGNsSnlUdjc5PS45PTZfTm12flgrfl90VHwvbmVpTCUyc3VqJSVyYlNwbE49VThMQUh3YUF2TkJuN3xWP0FkfCwwWFFYQz93MW9YZkNsJQ=='}]);
_stq.push([ 'clickTrackerInit', '22427743', '175912' ]);
	</script>
<noscript><img src="https://pixel.wp.com/b.gif?v=noscript" style="height:0px;width:0px;overflow:hidden" alt="" /></noscript>
<!-- Tracking Codes -->          <script type="text/javascript" src="//s.skimresources.com/js/3947X1518523.skimlinks.js"></script>
		<!-- End Tracking Codes --><script>
if ( 'object' === typeof wpcom_mobile_user_agent_info ) {

	wpcom_mobile_user_agent_info.init();
	var mobileStatsQueryString = "";
	
	if( false !== wpcom_mobile_user_agent_info.matchedPlatformName )
		mobileStatsQueryString += "&x_" + 'mobile_platforms' + '=' + wpcom_mobile_user_agent_info.matchedPlatformName;
	
	if( false !== wpcom_mobile_user_agent_info.matchedUserAgentName )
		mobileStatsQueryString += "&x_" + 'mobile_devices' + '=' + wpcom_mobile_user_agent_info.matchedUserAgentName;
	
	if( wpcom_mobile_user_agent_info.isIPad() )
		mobileStatsQueryString += "&x_" + 'ipad_views' + '=' + 'views';

	if( "" != mobileStatsQueryString ) {
		new Image().src = document.location.protocol + '//pixel.wp.com/g.gif?v=wpcom-no-pv' + mobileStatsQueryString + '&baba=' + Math.random();
	}
	
}
</script>
	</body>
</html>
<!--
	generated 87 seconds ago
	generated in 0.108 seconds
	served from batcache in 0.002 seconds
	expires in 213 seconds
-->
