<!DOCTYPE html>
<html lang="en">
	<head>
		<title>
			Apple Music for Android updated w/ bug fixes and performance improvements | 9to5Google		</title>

				<meta charset="UTF-8" />
		<meta name="viewport" content="width=device-width, initial-scale=1, maximum-scale=1.0, minimal-ui">
				<meta name="google-site-verification" content="Htm3pGW8rcBX6wK35FZMBNMbpuieOZ5c8F489axa8nw" />
<meta name="msvalidate.01" content="808CE29E29F1230249D24A893DE871FB" />
		<script src="https://s0.wp.com/wp-content/themes/vip/9to5-2015/assets/js/adsbygoogle.js"></script>

               <!-- Google Tag Manager -->
		<script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
				new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
				j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
				'https://www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
			})(window,document,'script','dataLayer','GTM-THGGVXB');</script>
		<!-- End Google Tag Manager -->
					<script src='https://r-login.wordpress.com/remote-login.php?action=js&amp;host=9to5google.com&amp;id=22427743&amp;t=1497581802&amp;back=https%3A%2F%2F9to5google.com%2F2017%2F06%2F15%2Fapple-music-for-android-updated-w-bug-fixes-and-performance-improvements%2F%3Futm_source%3Ddlvr.it%26utm_medium%3Dtwitter' type="text/javascript"></script>
		<script type="text/javascript">
		/* <![CDATA[ */
			if ( 'function' === typeof WPRemoteLogin ) {
				document.cookie = "wordpress_test_cookie=test; path=/";
				if ( document.cookie.match( /(;|^)\s*wordpress_test_cookie\=/ ) ) {
					WPRemoteLogin();
				}
			}
		/* ]]> */
		</script>
		<link rel='dns-prefetch' href='//s2.wp.com' />
<link rel='dns-prefetch' href='//s0.wp.com' />
<link rel='dns-prefetch' href='//s1.wp.com' />
<link rel='dns-prefetch' href='//pagead2.googlesyndication.com' />
<link rel='dns-prefetch' href='//www.googletagservices.com' />
<link rel='dns-prefetch' href='//9to5google.wordpress.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel="alternate" type="application/rss+xml" title="9to5Google &raquo; Feed" href="https://9to5google.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="9to5Google &raquo; Comments Feed" href="https://9to5google.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="9to5Google &raquo; Apple Music for Android updated w/ bug fixes and performance&nbsp;improvements Comments Feed" href="https://9to5google.com/2017/06/15/apple-music-for-android-updated-w-bug-fixes-and-performance-improvements/feed/" />

<!-- Jetpack Open Graph Tags -->
<meta property="og:type" content="article" />
<meta property="og:title" content="Apple Music for Android updated w/ bug fixes and performance improvements" />
<meta property="og:url" content="https://9to5google.com/2017/06/15/apple-music-for-android-updated-w-bug-fixes-and-performance-improvements/" />
<meta property="og:description" content="Apple today is rolling out a minor update to its Apple Music app on Android. The update brings the app to version 2.1 and brings under-the-hood improvements. The update is available now on the Play…" />
<meta property="article:published_time" content="2017-06-16T00:49:04+00:00" />
<meta property="article:modified_time" content="2017-06-16T00:49:04+00:00" />
<meta property="og:site_name" content="9to5Google" />
<meta property="og:image" content="https://9to5google.files.wordpress.com/2016/08/apple-music-android-wp-2.jpg?quality=82&amp;strip=all&amp;w=1000&amp;h=500" />
<meta property="og:image:width" content="1000" />
<meta property="og:image:height" content="500" />
<meta property="og:locale" content="en_US" />
<meta name="twitter:site" content="@9to5google" />
<meta name="twitter:text:title" content="Apple Music for Android updated w/ bug fixes and performance&nbsp;improvements" />
<meta name="twitter:image:src" content="https://9to5google.files.wordpress.com/2016/08/apple-music-android-wp-2.jpg?quality=82&amp;strip=all&amp;w=640" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:creator" content="@ChanceHMiller" />
<meta property="article:publisher" content="https://www.facebook.com/WordPresscom" />
<meta name="twitter:image" content="https://9to5google.files.wordpress.com/2016/08/apple-music-android-wp-2.jpg?quality=82&amp;strip=all&amp;w=1000&amp;h=500" />
	<script type="text/javascript">
		/* <![CDATA[ */
		function addLoadEvent(func) {
			var oldonload = window.onload;
			if (typeof window.onload != 'function') {
				window.onload = func;
			} else {
				window.onload = function () {
					oldonload();
					func();
				}
			}
		}
		/* ]]> */
	</script>
			<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s0.wp.com\/wp-content\/mu-plugins\/wpcom-smileys\/twemoji\/2\/72x72\/","ext":".png","svgUrl":"https:\/\/s0.wp.com\/wp-content\/mu-plugins\/wpcom-smileys\/twemoji\/2\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/s1.wp.com\/wp-includes\/js\/wp-emoji-release.min.js?m=1496863874h&ver=4.8-RC2-40878"}};
			!function(a,b,c){function d(a){var b,c,d,e,f=String.fromCharCode;if(!k||!k.fillText)return!1;switch(k.clearRect(0,0,j.width,j.height),k.textBaseline="top",k.font="600 32px Arial",a){case"flag":return k.fillText(f(55356,56826,55356,56819),0,0),b=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,56826,8203,55356,56819),0,0),c=j.toDataURL(),b===c&&(k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447),0,0),b=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447),0,0),c=j.toDataURL(),b!==c);case"emoji4":return k.fillText(f(55358,56794,8205,9794,65039),0,0),d=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55358,56794,8203,9794,65039),0,0),e=j.toDataURL(),d!==e}return!1}function e(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var f,g,h,i,j=b.createElement("canvas"),k=j.getContext&&j.getContext("2d");for(i=Array("flag","emoji4"),c.supports={everything:!0,everythingExceptFlag:!0},h=0;h<i.length;h++)c.supports[i[h]]=d(i[h]),c.supports.everything=c.supports.everything&&c.supports[i[h]],"flag"!==i[h]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[i[h]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(g=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",g,!1),a.addEventListener("load",g,!1)):(a.attachEvent("onload",g),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),f=c.source||{},f.concatemoji?e(f.concatemoji):f.wpemoji&&f.twemoji&&(e(f.twemoji),e(f.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='all-css-0-1' href='https://s0.wp.com/_static/??-eJx9jUEOgkAMAD9kLSIxejC+ZVkbWdguDe2G71tIvBkuTdvMZHAViHMxKoZcQXL9pKKY00SKI5mEOMF+naPqCf/jcV7I/yzBNoLpnQJlYseONJbbz9rWwVuHmVWchr6XhVTBJ6fKYIOHdu/Fz0t3bR9t092b8QtnYFC+' type='text/css' media='all' />
<link rel='stylesheet' id='googleFonts-css'  href='https://fonts.googleapis.com/css?family=Roboto%3A300%2C300italic%2C400%2C400italic%2C500%2C500italic%7CQuestrial&#038;ver=4.8-RC2-40878' type='text/css' media='all' />
<link rel='stylesheet' id='all-css-2-1' href='https://s1.wp.com/_static/??-eJyVkNEOgjAMRX/IUUFQeTB+y5x1FLuN0KHh750+oMZo5O3e9J6mt3DtlAk+oo8QG3QocKEO6hgqVSzzCrQIRgEjAsJkzllSC5hLqUdqPhtHRskc+Qklb3g4JqgVcHgkjZx2pF2vpmM9Yv8fl2av/gkR+BApnSqT+CjgBtXxYCllLAbFwehIwb8ZdWJN/S+0xwMHm6R9tH7abw9rSrAcDprvgb3b5WW9rlerYrtpbzl+qfY=' type='text/css' media='all' />
<link rel='stylesheet' id='screen-css-3-1' href='https://s1.wp.com/wp-content/themes/vip/plugins/wp-paginate/wp-paginate.css?m=1292836527h' type='text/css' media='screen' />
<script type='text/javascript' src='https://s1.wp.com/_static/??-eJyFztEKwjAMBdAfsquTiXsRv6XWOFKXtDbphn69HeiDMBQCgdzDJXZOBtmP5QJiQ517gfx4rybIxv4ChnDITqEh5A/2kRVYF0vxjCOYIpDdUG+16BpXXIqiBCIVraTfLyFPCPNfFkCT8zeTQfC5tJ7o2Hb9Yde3+24bXjRNW9I='></script>
<script type='text/javascript' src='https://www.googletagservices.com/tag/js/gpt.js?ver=0.1.1'></script>
<link rel='stylesheet' id='all-css-0-2' href='https://s1.wp.com/wp-content/mu-plugins/highlander-comments/style.css?m=1377793621h' type='text/css' media='all' />
<!--[if lt IE 8]>
<link rel='stylesheet' id='highlander-comments-ie7-css'  href='https://s1.wp.com/wp-content/mu-plugins/highlander-comments/style-ie7.css?m=1351637563h&#038;ver=20110606' type='text/css' media='all' />
<![endif]-->
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://9to5google.wordpress.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://s1.wp.com/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress.com" />
<link rel="canonical" href="http://9to5google.com/2017/06/15/apple-music-for-android-updated-w-bug-fixes-and-performance-improvements/" />
<link rel='shortlink' href='http://wp.me/p1w6tN-LfR' />
<link rel="alternate" type="application/json+oembed" href="https://public-api.wordpress.com/oembed/?format=json&amp;url=https%3A%2F%2F9to5google.com%2F2017%2F06%2F15%2Fapple-music-for-android-updated-w-bug-fixes-and-performance-improvements%2F&amp;for=wpcom-auto-discovery" /><link rel="alternate" type="application/xml+oembed" href="https://public-api.wordpress.com/oembed/?format=xml&amp;url=https%3A%2F%2F9to5google.com%2F2017%2F06%2F15%2Fapple-music-for-android-updated-w-bug-fixes-and-performance-improvements%2F&amp;for=wpcom-auto-discovery" /><link rel='openid.server' href='https://9to5google.wordpress.com/?openidserver=1' />
<link rel='openid.delegate' href='https://9to5google.wordpress.com/' />
<link rel="search" type="application/opensearchdescription+xml" href="https://9to5google.com/osd.xml" title="9to5Google" />
<link rel="search" type="application/opensearchdescription+xml" href="https://s1.wp.com/opensearch.xml" title="WordPress.com" />
<script type="text/javascript">
			// <![CDATA[
			(function () {
				var aE = function( o, t, f ) {
					if (o.addEventListener)
						o.addEventListener(t, f, false);
					else if (o.attachEvent) 
						o.attachEvent('on' + t, f);
				}		

				var confirmSubmit = function() {
					if ( confirm('Are you sure that you want to flag this comment?') ) {
						return true;
					}
					else 
						return false;
				}

				var init = function() {
					var links = document.getElementsByTagName('a');
					var nonce = '600afe117f';
					var nonce_key = '1d3ebb482e';
					var re = new RegExp(nonce_key, 'gi');
					for ( var i = 0; i < links.length; i++ ) {
						var href = links[i].getAttribute('href');
						// if it's a flagging link
						if ( re.exec(href) ) {
							// replace with correct nonce
							links[i].setAttribute('href', href.replace(re, nonce));
							links[i].onclick = confirmSubmit;
						}
					}
				}



				aE(window, 'load', init);
			}).call(this);
			//]]>
			</script>		<!--// Begin OpenX Bidder //-->
		<script type="text/javascript" src="//nineto5mac-d.openx.net/w/1.0/jstag?nc=1049447-9to5google-desktop"></script>
	     <script>
		window.googletag = window.googletag || {};
		var googletag = googletag || {};
		googletag.cmd = googletag.cmd || [];
     </script>
     <link rel="mask-icon" color="#296700" href="https://s0.wp.com/wp-content/themes/vip/9to5-2015/images/9to5-clock.svg">		<style type="text/css">
			.recentcomments a {
				display: inline !important;
				padding: 0 !important;
				margin: 0 !important;
			}

			table.recentcommentsavatartop img.avatar, table.recentcommentsavatarend img.avatar {
				border: 0px;
				margin: 0;
			}

			table.recentcommentsavatartop a, table.recentcommentsavatarend a {
				border: 0px !important;
				background-color: transparent !important;
			}

			td.recentcommentsavatarend, td.recentcommentsavatartop {
				padding: 0px 0px 1px 0px;
				margin: 0px;
			}

			td.recentcommentstextend {
				border: none !important;
				padding: 0px 0px 2px 10px;
			}

			.rtl td.recentcommentstextend {
				padding: 0px 10px 2px 0px;
			}

			td.recentcommentstexttop {
				border: none;
				padding: 0px 0px 0px 10px;
			}

			.rtl td.recentcommentstexttop {
				padding: 0px 10px 0px 0px;
			}
		</style>
		<meta name="application-name" content="9to5Google" /><meta name="msapplication-window" content="width=device-width;height=device-height" /><meta name="msapplication-tooltip" content="Beyond Good and Evil" /><meta name="msapplication-task" content="name=Subscribe;action-uri=https://9to5google.com/feed/;icon-uri=https://9to5google.files.wordpress.com/2017/03/favicon-bg-none-face-white.png?w=16" /><link rel="amphtml" href="https://9to5google.com/2017/06/15/apple-music-for-android-updated-w-bug-fixes-and-performance-improvements/amp/" /><style type="text/css" id="syntaxhighlighteranchor"></style>
<link rel="icon" href="https://9to5google.files.wordpress.com/2017/03/favicon-bg-none-face-white.png?w=32" sizes="32x32" />
<link rel="icon" href="https://9to5google.files.wordpress.com/2017/03/favicon-bg-none-face-white.png?w=192" sizes="192x192" />
<link rel="apple-touch-icon-precomposed" href="https://9to5google.files.wordpress.com/2017/03/favicon-bg-none-face-white.png?w=180" />
<meta name="msapplication-TileImage" content="https://9to5google.files.wordpress.com/2017/03/favicon-bg-none-face-white.png?w=256" />

	<style>
		.tha07fabfb { padding: 10px 0; text-align: center; }
          .color-scheme-mac .tha07fabfb { background-color: #0d4d7c; }
		.color-scheme-google .tha07fabfb { background-color: #16341B; }
		.color-scheme-toys .tha07fabfb { background-color: #6B393B; }
		.color-scheme-electrek .tha07fabfb { background-color: #00cacd; }
		.tha07fabfb .inlinead { background-color: transparent; min-height: 1px; }
		.tha07fabfb .inlinead > div { background-color: transparent; padding: 0; }

		.color-scheme-electrek .tha07fabfb { background-color: #939598; }

		.ad { margin: 0 auto; }

		@media (min-width: 0px) and (max-width: 767px) { .two-up-ads { display: none; } }

		.two-up-ads, .post-leaderboard { box-sizing: border-box; width: 100%; float: left; padding-left: 0.83333%; padding-right: 0.83333%; background-color: #ECECED; padding: 25px 0; }
		.two-up-ads .ad-1, .two-up-ads .ad-2, .post-leaderboard .ad-1, .post-leaderboard .ad-2 { display: inline-block; width: 300px; height: 250px; overflow: hidden; }
		.two-up-ads .ad-1, .post-leaderboard .ad-1 { box-sizing: border-box; width: 50%; float: left; padding-left: 0.83333%; padding-right: 0.83333%; text-align: right; }
		.two-up-ads .ad-2, .post-leaderboard .ad-2 { box-sizing: border-box; width: 50%; float: right; padding-left: 0.83333%; padding-right: 0.83333%; text-align: left; padding-left: 40px; }

		@media (min-width: 0px) and (max-width: 767px) { .post-leaderboard img { width: 100%; } }

		.post-leaderboard > * { margin: 0 auto; text-align: center; display: block; }

		/** inline ads **/
		.thdd260d0d { background-color: #DCDDDE; max-width: 100%; overflow: hidden; text-align: center; }\
		.thdd260d0d > div, .thdd260d0d > ins { padding: 20px 0; margin: 0 auto; }
		.enable-fallbacks .thdd260d0d > div, .enable-fallbacks .thdd260d0d > ins { padding: 0 0 0 0; }
		@media only screen and (min-width: 768px) { .thdd260d0d > div, .thdd260d0d > ins { display: block; padding: 25px 10px 25px 0; }
		.enable-fallbacks .thdd260d0d > div, .enable-fallbacks .thdd260d0d > ins { padding: 0 0 0 0; } }

		.post-body .thdd260d0d { background-color: transparent; }

		.th514e2698 { width: 300px; height: 250px; }
		@media (min-device-width: 320px) and (max-device-width: 479px) { .th514e2698 { width: 300px; height: 250px; } }
		@media (min-width: 500px) { .th514e2698 { width: 320px; height: 400px; } }
		@media (min-device-width: 480px) and (max-device-width: 767px) { .th514e2698 { width: 300px; height: 250px; } }
		@media (min-width: 768px) { .th514e2698 { float: right; margin-left: 20px; width: 336px; height: 280px; } }
		@media (min-width: 1000px) { .th514e2698 { margin: 0 -105px 20px 20px; } }
		.enable-fallbacks .th514e2698 { display: none !important; }

		.thed575dfa { display: none; }
		.enable-fallbacks .thed575dfa { display: block; }
		.thed575dfa img { max-width: 100%; }

		.thed575dfa.thf62d57f8 { background-color: #dcddde; max-width: 100%; overflow: hidden; text-align: center; }
		.thed575dfa.thf62d57f8 > div { margin: 20px auto; padding: 0 0; }

		.th9367b4e2 { line-height: 0; max-width: 300px; position: relative; }
		.th9367b4e2 h3 { background: rgba(0, 0, 0, 0.7); bottom: 0; box-sizing: border-box; color: #fff; font-size: 1.17em; font-weight: 400; line-height: 1.3; margin: 0 0; padding: 0.25em 0.5em; position: absolute; text-align: left; width: 100%; }
		.post-body .th9367b4e2 h3 { font-size: 1em; }
		@media (min-width: 768px) { .post-body .th9367b4e2 { float: right; margin-left: 20px; width: 300px; height: 250px; } }
		@media (min-width: 1000px) { .post-body .th9367b4e2 { margin: 0 -105px 20px 20px; } }

		.thf62d57f8 .th9367b4e2 { margin: 0 auto; }
		.th1d95b257 { cursor: pointer }
	</style>
	</head>
		<body class="post-template-default single single-post postid-181651 single-format-aside color-scheme-google mp6 customizer-styles-applied highlander-enabled highlander-light infinite-scroll">
					<!-- Google Tag Manager (noscript) -->
		<noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-THGGVXB"
		                  height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
		<!-- End Google Tag Manager (noscript) -->
						<div class="tha07fabfb">
				<div id="div-gpt-ad-1436850350386-0" class="inlinead"></div>
<script type='text/javascript'>
	// Make sure that nineto5ads exists, it will load ad once google tag exists
	window.nineto5ads = window.nineto5ads|| [];
	window.nineto5ads.push(function() {
		googletag.display("div-gpt-ad-1436850350386-0");
		googletag.pubads().refresh([adslot]);
	});
</script><div class="thed575dfa tha2db382f"><div class="th1d95b257" data-th4d772ac4="http://amzn.to/2ptg1ma"><img src="https://9to5google.files.wordpress.com/2017/05/best-usb-c.jpg?quality=82&strip=all"/></div></div>			</div>
			<header>
				<div class="mobile-menu">
					<div class="elastic-container">
						<div class="navigation-bar">
		                    <!-- Start of navigation toggle -->
				            <div class="mobile-nav-toggle">
							    <a id="nav-toggle" href="#"><span></span></a>
							</div>
							  <!-- End of navigation toggle -->
						</div>
						<nav>
							<ul id="menu-below-ad" class="menu"><li id="menu-item-114572" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-114572"><a href="https://9to5mac.com">9to5Mac</a></li>
<li id="menu-item-114574" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-114574"><a href="https://9to5toys.com">9to5Toys</a></li>
<li id="menu-item-114573" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-114573"><a href="https://electrek.co/">Electrek</a></li>
<li id="menu-item-114575" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-114575"><a href="/community">Community</a></li>
<li id="menu-item-114576" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-114576"><a href="https://9to5mac.com/about/">About</a></li>
<li id="menu-item-114577" class="tipsli menu-item menu-item-type-custom menu-item-object-custom menu-item-114577"><a href="https://9to5mac.com/contact/">Tips/Contact</a></li>
</ul>						</nav>
						<div class="nav-social">
							<ul>
								<li>
									<a href="https://9to5google.com/push/" title="Signup for Safari Notifications"><i class="icon-pushup"></i></a>
<a href="http://eepurl.com/bdw6AH" title="Signup for our email list"><i class="icon-mail"></i></a>
<a href="http://www.facebook.com/pages/9to5Google/218132111544562" title="Like us on Facebook"><i class="icon-facebook"></i></a>
<a href="http://twitter.com/9to5google" title="Follow us on Twitter"><i class="icon-twitter"></i></a>
<a href="https://plus.google.com/103164410861123991325"  title="Add us on Google Plus"><i class="icon-google-plus"></i></a>
<a href="https://www.youtube.com/c/9to5google" title="View 9to5 on YouTube"><i class="icon-youtube"></i></a>
<a href="https://9to5google.com/feed" title="Follow our feed"><i class="icon-feed"></i></a>
								</li>
							</ul>
						</div>
					</div>
				</div><!-- .mobile-menu -->
				<div class="header-wrap">
					<div class="elastic-container header-top">
						<div class="logo">
							<a href="https://9to5google.com/" rel="home">
								<img src="https://9to5google.files.wordpress.com/2015/07/cropped-9to5-google-logo2.png" alt="" />
							</a>
							<div id="mobile-search-icon">
								<a id="search-toggle" href="#"><span class="search-container"></span><span class="close"></span></a>
							</div>
							<div id="mobile-nav-icon">
								<a id="mobile-main-nav-toggle" href="#"><span></span></a>
							</div>
						</div>
						<div class="header-right">
							<div class="search-container">
								
<form role="search" class="search-form" method="get" action="https://9to5google.com/">
	<label>
		<span class="screen-reader-text">Search</span>
		<input type="search" placeholder="search" name="s" class="searchInput" value="">
	</label>
	<input type="submit" value="search">
</form>
							</div>
							<div class="social">
								<a href="https://9to5google.com/push/" title="Signup for Safari Notifications"><i class="icon-pushup"></i></a>
<a href="http://eepurl.com/bdw6AH" title="Signup for our email list"><i class="icon-mail"></i></a>
<a href="http://www.facebook.com/pages/9to5Google/218132111544562" title="Like us on Facebook"><i class="icon-facebook"></i></a>
<a href="http://twitter.com/9to5google" title="Follow us on Twitter"><i class="icon-twitter"></i></a>
<a href="https://plus.google.com/103164410861123991325"  title="Add us on Google Plus"><i class="icon-google-plus"></i></a>
<a href="https://www.youtube.com/c/9to5google" title="View 9to5 on YouTube"><i class="icon-youtube"></i></a>
<a href="https://9to5google.com/feed" title="Follow our feed"><i class="icon-feed"></i></a>
							</div>
						</div>
													<nav class="site-nav header-nav">
								<ul id="menu-top-nav" class="menu"><li id="menu-item-145656" class="menu-item menu-item-type-taxonomy menu-item-object-ninetofive_guides menu-item-145656"><a href="https://9to5google.com/guides/android/">Android</a></li>
<li id="menu-item-145658" class="menu-item menu-item-type-taxonomy menu-item-object-ninetofive_guides menu-item-145658"><a href="https://9to5google.com/guides/chromeos/">Chrome/OS</a></li>
<li id="menu-item-145933" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-145933"><a href="https://9to5google.com/guides">Guides</a>
<ul  class="sub-menu">
	<li id="menu-item-145934" class="menu-item menu-item-type-taxonomy menu-item-object-ninetofive_guides menu-item-145934 has-image"><a href="https://9to5google.com/guides/android/"><span>Android</span><img src="https://9to5google.files.wordpress.com/2015/10/android-versions.jpg?quality=82&#038;strip=all&#038;w=155"></a></li>
	<li id="menu-item-145935" class="menu-item menu-item-type-taxonomy menu-item-object-ninetofive_guides menu-item-145935 has-image"><a href="https://9to5google.com/guides/android-wear/"><span>Android Wear</span><img src="https://9to5google.files.wordpress.com/2017/02/android-wear-pay-2.jpg?quality=82&#038;strip=all&#038;w=155"></a></li>
	<li id="menu-item-145938" class="menu-item menu-item-type-taxonomy menu-item-object-ninetofive_guides menu-item-145938 has-image"><a href="https://9to5google.com/guides/android-auto/"><span>Android Auto</span><img src="https://9to5google.files.wordpress.com/2016/07/unnamed1.png?w=130"></a></li>
	<li id="menu-item-145936" class="menu-item menu-item-type-taxonomy menu-item-object-ninetofive_guides menu-item-145936 has-image"><a href="https://9to5google.com/guides/nexus/"><span>Nexus</span><img src="https://9to5google.files.wordpress.com/2016/07/nexus-6p-topic-full.png?w=155"></a></li>
	<li id="menu-item-146068" class="menu-item menu-item-type-taxonomy menu-item-object-ninetofive_guides menu-item-146068 has-image"><a href="https://9to5google.com/guides/chromebook/"><span>Chromebook</span><img src="https://9to5google.files.wordpress.com/2016/07/hero-chromebook-pixel.png?w=155"></a></li>
</ul>
</li>
<li id="menu-item-145659" class="menu-item menu-item-type-taxonomy menu-item-object-ninetofive_guides menu-item-145659"><a href="https://9to5google.com/guides/google-apps/"><span>Google Apps</a></li>
<li id="menu-item-145657" class="menu-item menu-item-type-taxonomy menu-item-object-ninetofive_guides menu-item-145657"><a href="https://9to5google.com/guides/android-tv/"><span>Android TV</a></li>
<li id="menu-item-145661" class="menu-item menu-item-type-taxonomy menu-item-object-ninetofive_guides menu-item-145661"><a href="https://9to5google.com/guides/youtube/"><span>YouTube</a></li>
</ul>							</nav>
											</div>
									</div><!-- .header-wrap -->
			</header>
			<div id="header-placeholder"></div>

			<aside class="trending-wrapper"><div class="trending-items">
				<div>
					<a href="https://9to5google.com/2017/06/09/conversation-with-andy-rubin-ambient-os-future-essential-products-ar/" rel="bookmark">
						<div class="title">Trending in Google</div>
						<p class="trending-excerpt">Andy Rubin on AmbientOS, future Essential products and AR&nbsp;[Interview]</p>
					</a>
				</div>
			
				<div>
					<a href="https://9to5google.com/2017/06/02/hands-on-mophie-juice-pack-battery-case-google-pixel-xl/" rel="bookmark">
						<div class="title">Trending in Google</div>
						<p class="trending-excerpt">Hands on: Mophie Juice Pack battery case for the Google Pixel&nbsp;XL</p>
					</a>
				</div>
			
				<div>
					<a href="https://9to5google.com/2017/06/02/best-android-phones-june-2017/" rel="bookmark">
						<div class="title">Trending in Google</div>
						<p class="trending-excerpt">Best Android phones you can buy [June&nbsp;2017]</p>
					</a>
				</div>
			
				<div>
					<a href="https://9to5google.com/2017/05/28/best-samsung-galaxy-s8-cases/" rel="bookmark">
						<div class="title">Trending in Google</div>
						<p class="trending-excerpt">Hands on with some of the best cases for the Samsung Galaxy&nbsp;S8</p>
					</a>
				</div>
			
				<div>
					<a href="https://9to5google.com/2017/05/25/best-android-apps-may-2017/" rel="bookmark">
						<div class="title">Trending in Google</div>
						<p class="trending-excerpt">Hands-on with 5 Android apps and games you should download in May 2017&nbsp;[Video]</p>
					</a>
				</div>
			
				<div>
					<a href="https://9to5google.com/2017/05/20/is-the-android-o-dev-preview-2-stable-enough-for-your-daily-driver-heres%e2%80%8b-our-experience-so-far/" rel="bookmark">
						<div class="title">Trending in Google</div>
						<p class="trending-excerpt">Is the Android O Dev Preview 2 stable enough for your daily driver? Here’s​ our experience so&nbsp;far</p>
					</a>
				</div>
			</div></aside>
		<div id="content">
					<div class="news-feed-header">
				<div class="elastic-container">
					<div class="currently-reading">
						<p>Today</p>
					</div><!-- .currently-reading -->
						<div class="stock-data GOOG-stock">
							<div class="current">
								<p>GOOG: 942.31</p>
							</div><!-- .current -->
								<div class="change change-down">
									-8.45
										<img src="https://s0.wp.com/wp-content/themes/vip/9to5-2015/images/stock-down.png" class="stock-down">
								</div><!-- .change -->
								<div class="stock-chart">
									<img src="https://chart.finance.yahoo.com/z?s=GOOG&#038;t=1d&#038;q=l&#038;l=on&#038;z=s&#038;region=us&#038;lang=en-US" alt="Stock Chart">
								</div><!-- .stock-chart -->
						</div><!-- stock-data -->


				</div><!-- .elastic-container -->
			</div><!-- .news-feed-header -->
			<div id="news-placeholder"></div>

		<article class="post-content" itemscope itemtype="http://schema.org/NewsArticle">
			<div itemprop="mainEntityOfPage">
				<div class="elastic-container">
					<h1 class="post-title" itemprop="headline"><a href="https://9to5google.com/2017/06/15/apple-music-for-android-updated-w-bug-fixes-and-performance-improvements/">Apple Music for Android updated w/ bug fixes and performance&nbsp;improvements</a></h1>
					<div class="post-meta">
						<p class="byline" itemprop="author" itemscope itemtype="https://schema.org/Person">
							<a href="https://9to5google.com/author/chmiller44/">
								<span itemprop="name">Chance Miller</span>
							</a>
						</p>
						<p class="time-twitter">
							- Jun. 15th 2017 5:49 pm PT
								<div class="icon-twitter"></div>
								<p><a href="https://twitter.com/ChanceHMiller" target="_blank" class="twitter-handle">@ChanceHMiller</a></p>
						</p>
						<div class="tags">
							<div class="post-cats">
									<a href="https://9to5google.com/feature/apps-updates/" title="View all posts in Apps &amp; Updates" class="featured_tag">Apps &amp; Updates</a>

									<a href="https://9to5google.com/guides/apple-music/" title="View all posts in apple music">apple music</a>

								<meta itemprop="keywords" content="apple music,"/>
							</div><!-- .post-cats -->
						</div><!-- .tags -->
						<meta itemprop="datePublished" content="2017-06-15 17:49:04"/>
						<meta itemprop="dateModified" content="2017-06-15 17:49:04"/>
					</div><!-- .post-meta -->
				</div><!-- .elastic-container -->
				<div class="feat-image-wrapper">
						<div itemprop="image" itemscope itemtype="https://schema.org/ImageObject">
							<meta itemprop="url" content="https://9to5google.files.wordpress.com/2016/08/apple-music-android-wp-2.jpg?quality=82&#038;strip=all&#038;w=1000&#038;h=500">
							<meta itemprop="height" content="500">
							<meta itemprop="width" content="1000">
						</div>
						<div class="feat-image wide">
							<a href="https://9to5google.com/2017/06/15/apple-music-for-android-updated-w-bug-fixes-and-performance-improvements/">
								<img src="https://9to5google.files.wordpress.com/2016/08/apple-music-android-wp-2.jpg?quality=82&#038;strip=all&#038;w=1000&#038;h=500" srcset="https://9to5google.files.wordpress.com/2016/08/apple-music-android-wp-2.jpg?quality=82&amp;strip=all&amp;w=320&amp;h=500 320w, https://9to5google.files.wordpress.com/2016/08/apple-music-android-wp-2.jpg?quality=82&amp;strip=all&amp;w=640&amp;h=500 640w, https://9to5google.files.wordpress.com/2016/08/apple-music-android-wp-2.jpg?quality=82&amp;strip=all&amp;w=1024&amp;h=500 1024w, https://9to5google.files.wordpress.com/2016/08/apple-music-android-wp-2.jpg?quality=82&amp;strip=all&amp;w=1500&amp;h=500 1500w, https://9to5google.files.wordpress.com/2016/08/apple-music-android-wp-2.jpg?quality=82&amp;strip=all&amp;w=2000&amp;h=500 2000w, https://9to5google.files.wordpress.com/2016/08/apple-music-android-wp-2.jpg?quality=82&amp;strip=all&amp;w=2500&amp;h=500 2500w">
							</a>
						</div><!-- .feat-image -->
					<div class="post-social-mobile">
						<a href="https://9to5google.com/2017/06/15/apple-music-for-android-updated-w-bug-fixes-and-performance-improvements/#comments" class="comments" itemprop="discussionUrl"><span class="dsq-postid" rel="181651 https://9to5google.com/?p=181651">View Comments</span></a>
						<div class="sharedaddy sd-sharing-enabled"><div class="robots-nocontent sd-block sd-social sd-social-text sd-sharing"><div class="sd-content"><ul><li class="share-facebook"><a rel="nofollow" data-shared="sharing-facebook-181651" class="share-facebook sd-button no-icon" href="https://9to5google.com/2017/06/15/apple-music-for-android-updated-w-bug-fixes-and-performance-improvements/?share=facebook" target="_blank" title="Share on Facebook"><span>Facebook</span></a></li><li class="share-twitter"><a rel="nofollow" data-shared="sharing-twitter-181651" class="share-twitter sd-button no-icon" href="https://9to5google.com/2017/06/15/apple-music-for-android-updated-w-bug-fixes-and-performance-improvements/?share=twitter" target="_blank" title="Click to share on Twitter"><span>Twitter</span></a></li><li class="share-google-plus-1"><a rel="nofollow" data-shared="sharing-google-181651" class="share-google-plus-1 sd-button no-icon" href="https://9to5google.com/2017/06/15/apple-music-for-android-updated-w-bug-fixes-and-performance-improvements/?share=google-plus-1" target="_blank" title="Click to share on Google+"><span>Google</span></a></li><li class="share-pinterest"><a rel="nofollow" data-shared="sharing-pinterest-181651" class="share-pinterest sd-button no-icon" href="https://9to5google.com/2017/06/15/apple-music-for-android-updated-w-bug-fixes-and-performance-improvements/?share=pinterest" target="_blank" title="Click to share on Pinterest"><span>Pinterest</span></a></li><li class="share-reddit"><a rel="nofollow" data-shared="" class="share-reddit sd-button no-icon" href="https://9to5google.com/2017/06/15/apple-music-for-android-updated-w-bug-fixes-and-performance-improvements/?share=reddit" target="_blank" title="Click to share on Reddit"><span>Reddit</span></a></li><li class="share-end"></li></ul></div></div></div>
					</div><!-- .post-social-mobile -->
				</div><!-- .feat-image-wrapper -->
				<div class="elastic-container">
					<div class="post-body" itemprop="articleBody">
						<p>Apple today is rolling out a minor update to its Apple Music app on Android. The update brings the app to version 2.1 and brings under-the-hood improvements. The update is available now on the Play Store.</p>
<p><span id="more-181651"></span>
	<ins class="adsbygoogle author_ad" style="display:block;" data-ad-client="ca-pub-4344806526196296" data-ad-slot="3606871832"></ins>
<script type="text/javascript">(adsbygoogle = window.adsbygoogle || []).push({});</script>
		
<div class="thed575dfa th9367b4e2"><div class="th1d95b257" data-th4d772ac4="http://www.amazon.com/Apple-MH0W2LL-Wi-Fi-NEWEST-VERSION/dp/B00OTWOAAQ/ref=sr_1_1?ie=UTF8&#038;sr=1-1&#038;s=pc&#038;keywords=ipad%25252Bair%25252B2&#038;tag=android067-20&#038;qid=1429315246"><img src="https://i0.wp.com/9to5mac.files.wordpress.com/2015/12/samsung-4k-display-01.png?resize=300%2C250&#038;quality=82&#038;strip=all&#038;ssl=1"/><h3>Samsung U28E590D 28-Inch 4K Monitor</h3></div></div></p>
<p>In the changelog, Apple simply states that the update includes minor app and performance improvements.</p>
<blockquote>
<p class="heading"><strong>What&#8217;s New</strong></p>
<p>This update includes minor app and performance improvements.</p></blockquote>
<p>Today&#8217;s smaller update follows a larger update back in April that marked the apps&#8217;s first major update. The <a href="https://9to5mac.com/2017/04/04/apple-music-android-ios-10-update/">update brought with an iOS</a> 10-style redesign, with lyric support, improved support for Beats 1, For You playlists, and more.</p>
<p>Apple Music for Android requires 4.3 Jelly Bean or higher, though it’s still not compatible with tablets. The app launched <a href="https://9to5mac.com/2015/11/10/apple-music-android-google-play-store/">back in November</a> and replaced the Beats Music app.  Apple Music on Android lists a 10 to 50 million install base according to the Play Store despite mixed reviews averaging at 3.5 of 5 stars.</p>
<p>Apple Music is available on the Play Store now for <a href="https://play.google.com/store/apps/details?id=com.apple.android.music&amp;hl=en">free</a>.</p>

					</div><!-- .post-body -->

				</div><!-- .elastic-container -->

				<div itemprop="publisher" itemscope itemtype="https://schema.org/Organization">
					<div itemprop="logo" itemscope itemtype="https://schema.org/ImageObject">
						<meta itemprop="url" content="https://9to5google.files.wordpress.com/2015/07/cropped-9to5-google-logo2.png">
						<meta itemprop="width" content="628">
						<meta itemprop="height" content="103">
					</div>
					<meta itemprop="name" content="9to5Google">
				</div>

			</div><!-- mainEntityOfPage -->

			<div class="author-bio-container">
				<div class="elastic-container">
					<div class="author-bio" itemprop="author" itemscope itemtype="https://schema.org/Person">
							<div class="author-bio-details">
								<a href="https://9to5google.com/author/chmiller44/">
									<img src="https://secure.gravatar.com/avatar/8ca0a5473ca1b059b4b0aa628da621ff?s=512&#038;d=mm&#038;r=r" class="author-gravatar">
								</a>
								<h3>
									<a href="https://9to5google.com/author/chmiller44/">
										<span itemprop="name">Chance Miller</span>
									</a>
								</h3>

									<p class="twitter">
										<a href="https://twitter.com/ChanceHMiller" target="_blank" class="twitter-handle"><span class="icon-twitter"></span>@ChanceHMiller</a>
									</p>

								<p class="author-excerpt">
									<p>Email: Chance@9to5mac.com</p>
<p>Chance currently writes for both 9to5Google and 9to5Mac, in addition to 9to5Toys.</p>

								</p>
						</div>
					</div>
						<div class="author-gear">
							<h3>Favorite Gear</h3>
							<div class="author-gear-list">
								<div class="author-gear-item">
										<div class="author-gear-item-image">
											<a href="http://www.amazon.com/Apple-MH0W2LL-Wi-Fi-NEWEST-VERSION/dp/B00OTWOAAQ/ref=sr_1_1?ie=UTF8&#038;qid=1429315246&#038;s=pc&#038;keywords=ipad%252Bair%252B2&#038;tag=android067-20&#038;sr=1-1" target="_blank">
												<img src="https://i0.wp.com/9to5mac.files.wordpress.com/2015/12/samsung-4k-display-01.png?resize=300%2C175&#038;quality=82&#038;strip=all&#038;ssl=1" title="Samsung U28E590D 28-Inch 4K Monitor" alt="Samsung U28E590D 28-Inch 4K Monitor" width="290" height="145"/>
											</a>
											<h4><a href="http://www.amazon.com/Apple-MH0W2LL-Wi-Fi-NEWEST-VERSION/dp/B00OTWOAAQ/ref=sr_1_1?ie=UTF8&#038;qid=1429315246&#038;s=pc&#038;keywords=ipad%252Bair%252B2&#038;tag=android067-20&#038;sr=1-1" target="_blank">Samsung U28E590D 28-Inch 4K Monitor</a></h4>
										</div>
								</div>
								<div class="author-gear-item">
										<div class="author-gear-item-image">
											<a href="http://www.amazon.com/Apple-iPhone-Space-Gray-Unlocked/dp/B00NQGP42Y/ref=sr_1_1?ie=UTF8&#038;qid=1429315272&#038;s=electronics&#038;keywords=iphone%252B6&#038;tag=android067-20&#038;sr=1-1" target="_blank">
												<img src="https://i0.wp.com/9to5mac.files.wordpress.com/2016/09/hue-lightstrip-plus.jpeg?resize=300%2C175&#038;quality=82&#038;strip=all&#038;ssl=1" title="Phillips Hue Light Strip" alt="Phillips Hue Light Strip" width="290" height="145"/>
											</a>
											<h4><a href="http://www.amazon.com/Apple-iPhone-Space-Gray-Unlocked/dp/B00NQGP42Y/ref=sr_1_1?ie=UTF8&#038;qid=1429315272&#038;s=electronics&#038;keywords=iphone%252B6&#038;tag=android067-20&#038;sr=1-1" target="_blank">Phillips Hue Light Strip</a></h4>
										</div>
								</div>
								<div class="author-gear-item">
										<div class="author-gear-item-image">
											<a href="https://www.amazon.com/All-New-Amazon-Echo-Dot-Add-Alexa-To-Any-Room/dp/B01DFKC2SO/ref=sr_1_1?sr=8-1&#038;ie=UTF8&#038;keywords=echo%2Bdot&#038;tag=android067-20&#038;qid=1489108320" target="_blank">
												<img src="https://i2.wp.com/9to5google.files.wordpress.com/2016/03/amazonechodotfronton-1.jpg?resize=300%2C175&#038;quality=82&#038;strip=all&#038;ssl=1" title="Amazon Echo Dot" alt="Amazon Echo Dot" width="290" height="145"/>
											</a>
											<h4><a href="https://www.amazon.com/All-New-Amazon-Echo-Dot-Add-Alexa-To-Any-Room/dp/B01DFKC2SO/ref=sr_1_1?sr=8-1&#038;ie=UTF8&#038;keywords=echo%2Bdot&#038;tag=android067-20&#038;qid=1489108320" target="_blank">Amazon Echo Dot</a></h4>
										</div>
								</div>
							</div>
						</div>
				</div>
			</div>

					<div class="elastic-container related-guides-container">
						<h1>Guides</h1>
							<div class="related-guides-item">
								<h3>apple music</h3>
								<div class="related-guides-item-image">
									<a href="https://9to5google.com/guides/apple-music/">
									<img src="https://s0.wp.com/wp-content/themes/vip/9to5-2015/images/default-9to5google-related-guide.png" title="apple music" alt="apple music" />
									</a>
								</div>
								<p></p>
								<div class='related-guides-action'>
								<a href="https://9to5google.com/guides/apple-music/" class="related-guide-view-more">View THe Guide</a>
								</div>
							</div>
					</div>



		</article><!-- .post-content -->

					<div id="comments" class="comments-area post-body">
				<div class="elastic-container">
					<div id="disqus_thread">
	<div id="dsq-content">
		<ul id="dsq-comments">
					</ul>
			</div>
</div>
		
<a href="http://disqus.com" class="dsq-brlink">blog comments powered by <span class="logo-disqus">Disqus</span></a>

<script type="text/javascript" charset="utf-8">
	var disqus_url = "https:\/\/9to5google.com\/2017\/06\/15\/apple-music-for-android-updated-w-bug-fixes-and-performance-improvements\/";
	var disqus_identifier = "181651 http:\/\/9to5google.com\/?p=181651";
	var disqus_container_id = 'disqus_thread';
	var disqus_domain = "disqus.com";
	var disqus_shortname = "9to5googleprod";
		var disqus_config = function () {
	    var config = this; // Access to the config object

	    /* 
	       All currently supported events:
	        * preData — fires just before we request for initial data
	        * preInit - fires after we get initial data but before we load any dependencies
	        * onInit  - fires when all dependencies are resolved but before dtpl template is rendered
	        * afterRender - fires when template is rendered but before we show it
	        * onReady - everything is done
	     */

		config.callbacks.preData.push(function() {
			// clear out the container (its filled for SEO/legacy purposes)
			document.getElementById(disqus_container_id).innerHTML = '';
		})
		config.callbacks.onReady.push(function() {
/*
			// sync comments in the background so we don't block the page
			var req = new XMLHttpRequest();
			req.open('GET', '?cf_action=sync_comments&post_id=181651', true);
			req.send(null);
*/
		});
		
			};
	
	var facebookXdReceiverPath = "http:\/\/9to5google.wordpress.com\/wp-content\/themes\/vip\/plugins\/disqus\/xd_receiver.htm";
</script>

<script type="text/javascript" charset="utf-8">
	var DsqLocal = {
		'trackbacks': [
		],
		'trackback_url': "https:\/\/9to5google.com\/2017\/06\/15\/apple-music-for-android-updated-w-bug-fixes-and-performance-improvements\/trackback\/"	};
</script>

<script type="text/javascript" charset="utf-8">
(function() {
	var dsq = document.createElement('script'); dsq.type = 'text/javascript';
	dsq.async = true;
	dsq.src = '//' + disqus_shortname + '.' + disqus_domain + '/embed.js?pname=wordpress&pver=2.40';
	(document.getElementsByTagName('head')[0] || document.getElementsByTagName('body')[0]).appendChild(dsq);
})();
</script>
				</div><!-- .elastic-container -->
			</div><!-- #comments.comments-area -->
			</div><!-- #content -->


	<div id="tips-form" class="tips-form">
		<h2>Submit a Tip</h2>
		<a href="#" class="cancel">cancel</a>
		<form>
			<input type="hidden" id="tips-form-nonce" name="tips-form-nonce" value="7cdd226fcd" /><input type="hidden" name="_wp_http_referer" value="/2017/06/15/apple-music-for-android-updated-w-bug-fixes-and-performance-improvements/?utm_source=dlvr.it&amp;utm_medium=twitter" />						<input type="hidden" name="action" value="tips_submit">
			<input type="text" name="name" id="tips-form-name" placeholder="Name (optional)">
			<input type="text" name="email" id="tips-form-email" placeholder="Email (optional)">
			<textarea name="tip" id="tips-form-tip" placeholder="tips@9to5mac.com"></textarea>
			<p class="submit-text">
				<input type="submit">
				Submitting a tip constitutes permission to publish and syndicate. Please view our <a href="http://9to5mac.com/privacy/">tips policy</a> or see <a href="http://9to5mac.com/contact/">all contact options</a>.
			</p>
			<p class="response"></p>
		</form>
	</div><!-- #tips-form -->

	<div style="text-align:center">
		<a href="https://vip.wordpress.com/?utm_source=vip_powered_wpcom&#038;utm_medium=web&#038;utm_campaign=VIP%20Footer%20Credit" rel="generator nofollow" class="powered-by-wpcom"><img src="https://s0.wp.com/wp-content/themes/vip/plugins/vip-do-not-include-on-wpcom/vip-powered-wpcom/images/vip-powered-light-small.png" width="187" height="26" alt="Powered by WordPress.com VIP" /></a>	</div>

		<script type="text/javascript">
		//<![CDATA[
		var ninetofiveInfiniteScroll = {"settings":{"id":"content","ajaxurl":"https:\/\/9to5google.com\/?infinity=scrolling","currentday":"15.06.17","order":"DESC","offset":0,"history":{"host":"9to5google.com","path":"\/2017\/06\/15\/apple-music-for-android-updated-w-bug-fixes-and-performance-improvements\/page\/%d\/","use_trailing_slashes":true,"parameters":"?utm_source=dlvr.it&utm_medium=twitter"},"query_args":{"page":0,"year":2017,"monthnum":6,"day":15,"name":"apple-music-for-android-updated-w-bug-fixes-and-performance-improvements","error":"","m":"","p":0,"post_parent":"","subpost":"","subpost_id":"","attachment":"","attachment_id":0,"static":"","pagename":"","page_id":0,"second":"","minute":"","hour":"","w":0,"category_name":"","tag":"","cat":"","tag_id":"","author":"","author_name":"","feed":"","tb":"","paged":0,"meta_key":"","meta_value":"","preview":"","s":"","sentence":"","title":"","fields":"","menu_order":"","embed":"","category__in":[],"category__not_in":[],"category__and":[],"post__in":[],"post__not_in":[],"post_name__in":[],"tag__in":[],"tag__not_in":[],"tag__and":[],"tag_slug__in":[],"tag_slug__and":[],"post_parent__in":[],"post_parent__not_in":[],"author__in":[],"author__not_in":[],"ignore_sticky_posts":false,"suppress_filters":false,"cache_results":false,"update_post_term_cache":true,"lazy_load_term_meta":true,"update_post_meta_cache":true,"post_type":"","posts_per_page":6,"nopaging":false,"comments_per_page":"75","no_found_rows":false,"order":"DESC"},"last_post_date":"2017-06-15 17:49:04","dfp_id":"1049447","post_id":181651,"stats":"blog=22427743&v=wpcom&tz=-7&user_id=0&post=181651&subd=9to5google&x_pagetype=infinite"}};
		//]]>
	</script>
<!-- wpcom_wp_footer -->
	<script type="text/javascript">
	// <![CDATA[
		var disqus_shortname = "9to5googleprod";
		var disqus_domain = "disqus.com";
		(function () {
			var nodes = document.getElementsByTagName('span');
			for (var i = 0, url; i < nodes.length; i++) {
				if (nodes[i].className.indexOf('dsq-postid') != -1) {
					var shorturl = nodes[i].getAttribute('rel');
					var new_rel = shorturl.replace( 'https:', 'http:' );
					nodes[i].parentNode.setAttribute('data-disqus-identifier', new_rel );
					url = nodes[i].parentNode.href.split('#', 1);
					if (url.length == 1) url = url[0];
					else url = url[1]
					nodes[i].parentNode.href = url + '#disqus_thread';
				}
			}
			var s = document.createElement('script'); s.async = true;
			s.type = 'text/javascript';
			s.src = '//' + disqus_domain + '/forums/' + disqus_shortname + '/count.js';
			(document.getElementsByTagName('HEAD')[0] || document.getElementsByTagName('BODY')[0]).appendChild(s);
		}());
	//]]>
	</script>
<script id='loop-template' type='x-tmpl-mustache'>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</script><script id='content-template' type='x-tmpl-mustache'><div class="extended">
	{{{ post_content }}}

	{{# product_link }}
		{{# product_price }}
			<div class="product_cta_lower">
				<a href="{{ product_link }}" class="product-button{{# savings_amount }} has-savings{{/ savings_amount }}" target="_blank">
					{{# savings_amount }}
						<span class="product-savings-amount">Get this deal<br/>{{ savings_amount }}</span>
					{{/ savings_amount }}
					<span class="product-price">{{ product_price }}</span>
				</a>
			</div>
		{{/ product_price }}
	{{/ product_link }}

	<div class="contract-mobile">
		<a href="#" class="less-link less-post"><span class="moretext">close full story</span> <span class="x-animate"></span></a>
	</div><!-- .contract-mobile -->
</div><!-- .extended -->
</script><script id='aside-template' type='x-tmpl-mustache'><div class="post-body">
	<div class="post-meta">
		<div class="tags">
			<div class="post-cats">
				{{# featured_tags }}
        	<a href="{{tag_link}}" title="View all posts in {{tag_name}}" class="featured_tag">{{tag_name}}</a>
        {{/ featured_tags }}
				{{# categories }}
					<a href="{{cat_link}}" title="View all posts in {{cat_name}}">{{cat_name}}</a>
				{{/ categories }}
			</div><!-- .post-cats -->
		</div><!-- .tags -->
	</div><!-- .post-meta -->
	{{# featured_image }}
		{{# product_link }}
			{{# product_price }}
				<div class="product_cta_image">
					<a href="{{ product_link }}" class="product-button{{# savings_amount }} has-savings{{/ savings_amount }}" target="_blank">
						{{# savings_amount }}
							<span class="product-savings-amount">Get this deal<br/>{{ savings_amount }}</span>
						{{/ savings_amount }}
						<span class="product-price">{{ product_price }}</span>
					</a>
				</div>
			{{/ product_price }}
		{{/ product_link }}

		<div class="feat-image-wrapper">
			{{# featured_image }}
				<div class="feat-image{{ image_class }}"><img src="{{featured_image}}" srcset="{{ srcset }}"></div>
			{{/ featured_image }}
			<div class="post-social-mobile">
				<a href="{{permalink}}#comments" class="comments">{{{comment_count}}}</a>
				{{{share_buttons}}}
			</div><!-- .post-social-mobile -->
		</div><!-- .feat-image-wrapper -->

	{{/ featured_image }}
	{{{post_content}}}
	{{# meta.display_author_ad }}
		{{{ meta.author_ad }}}
	{{/ meta.display_author_ad }}

	{{# product_link }}
		{{# product_price }}
			<div class="product_cta_lower">
				<a href="{{ product_link }}" class="product-button{{# savings_amount }} has-savings{{/ savings_amount }}" target="_blank">
					{{# savings_amount }}
						<span class="product-savings-amount">Get this deal<br/>{{ savings_amount }}</span>
					{{/ savings_amount }}
					<span class="product-price">{{ product_price }}</span>
				</a>
			</div>
		{{/ product_price }}
	{{/ product_link }}

	{{! Display the social sharing buttons at the bottom if we don't have a featured image. }}
	{{^ featured_image }}
		<div class="post-social">
			<a href="{{permalink}}#comments" class="comments">{{{comment_count}}}</a>
			{{{share_buttons}}}
		</div><!-- .post-social -->
	{{/ featured_image }}

	<div class="contract-mobile">
		<a href="#" class="less-link less-aside"><span class="moretext">close full story</span> <span class="x-animate"></span></a>
	</div><!-- .contract-mobile -->
</div><!-- .post-body -->
</script>	<div style="display:none">
	</div>
<script type='text/javascript'>
/* <![CDATA[ */
var HighlanderComments = {"loggingInText":"Logging In\u2026","submittingText":"Posting Comment\u2026","postCommentText":"Post Comment","connectingToText":"Connecting to %s","commentingAsText":"%1$s: You are commenting using your %2$s account.","logoutText":"Log Out","loginText":"Log In","connectURL":"https:\/\/9to5google.wordpress.com\/public.api\/connect\/?action=request","logoutURL":"https:\/\/9to5google.wordpress.com\/wp-login.php?action=logout&_wpnonce=73118efefa","homeURL":"https:\/\/9to5google.com\/","postID":"181651","gravDefault":"mystery","enterACommentError":"Please enter a comment","enterEmailError":"Please enter your email address here","invalidEmailError":"Invalid email address","enterAuthorError":"Please enter your name here","gravatarFromEmail":"This picture will show whenever you leave a comment. Click to customize it.","logInToExternalAccount":"Log in to use details from one of these accounts.","change":"Change","changeAccount":"Change Account","comment_registration":"1","userIsLoggedIn":"","isJetpack":"0","text_direction":"ltr"};
/* ]]> */
</script>
<script type='text/javascript' src='https://s2.wp.com/_static/??/wp-content/js/jquery/jquery.autoresize.js,/wp-content/mu-plugins/highlander-comments/script.js?m=1479964158j'></script>
		<script type="text/javascript">
			var windowOpen;
		jQuery(document).on( 'ready post-load', function(){
			jQuery( 'a.share-facebook' ).on( 'click', function() {
				if ( 'undefined' !== typeof windowOpen ){ // If there's another sharing window open, close it.
					windowOpen.close();
				}
				windowOpen = window.open( jQuery(this).attr( 'href' ), 'wpcomfacebook', 'menubar=1,resizable=1,width=600,height=400' );
				return false;
			});
		});
		</script>
				<script type="text/javascript">
			var windowOpen;
		jQuery(document).on( 'ready post-load', function(){
			jQuery( 'a.share-twitter' ).on( 'click', function() {
				if ( 'undefined' !== typeof windowOpen ){ // If there's another sharing window open, close it.
					windowOpen.close();
				}
				windowOpen = window.open( jQuery(this).attr( 'href' ), 'wpcomtwitter', 'menubar=1,resizable=1,width=600,height=350' );
				return false;
			});
		});
		</script>
				<script type="text/javascript">
			var windowOpen;
		jQuery(document).on( 'ready post-load', function(){
			jQuery( 'a.share-google-plus-1' ).on( 'click', function() {
				if ( 'undefined' !== typeof windowOpen ){ // If there's another sharing window open, close it.
					windowOpen.close();
				}
				windowOpen = window.open( jQuery(this).attr( 'href' ), 'wpcomgoogle-plus-1', 'menubar=1,resizable=1,width=480,height=550' );
				return false;
			});
		});
		</script>
							<script type="text/javascript">
				jQuery(document).on('ready', function(){
					jQuery('body').on('click', 'a.share-pinterest', function(e){
						e.preventDefault();
						// Load Pinterest Bookmarklet code
						var s = document.createElement("script");
						s.type = "text/javascript";
						s.src = window.location.protocol + "//assets.pinterest.com/js/pinmarklet.js?r=" + ( Math.random() * 99999999 );
						var x = document.getElementsByTagName("script")[0];
						x.parentNode.insertBefore(s, x);
						// Trigger Stats
						var s = document.createElement("script");
						s.type = "text/javascript";
						s.src = this + ( this.toString().indexOf( '?' ) ? '&' : '?' ) + 'js_only=1';
						var x = document.getElementsByTagName("script")[0];
						x.parentNode.insertBefore(s, x);
					});
				});
			</script>
		<link rel='stylesheet' id='all-css-0-3' href='https://s1.wp.com/wp-content/mu-plugins/tiled-gallery/tiled-gallery.css?m=1443731146h' type='text/css' media='all' />
<script type='text/javascript'>
/* <![CDATA[ */
var globalJSVars = {"ajaxurl":"https:\/\/9to5google.com\/wp-admin\/admin-ajax.php"};
/* ]]> */
</script>
<script type='text/javascript'>
/* <![CDATA[ */
var PushUpNotificationSettings = {"domain":"https:\/\/9to5google.wordpress.com","userID":"1","websitePushID":"web.com.9to5google","webServiceURL":"https:\/\/push.10up.com","prompt":"1"};
/* ]]> */
</script>
<script type='text/javascript'>
/* <![CDATA[ */
var stylesheetDirectory = "https:\/\/s0.wp.com\/wp-content\/themes\/vip\/9to5-2015";
/* ]]> */
</script>
<script type='text/javascript' src='https://s2.wp.com/_static/??-eJydjsEOgjAQRH/IWgFRORi/pWkXWWy3tdui/r0QJDGe1NskM/Nm5C0I7SkBJdmzNDCghnBf97ySb5bLIth8RmJp8QIsrxkydIqMhfgZTh24MTJgkE3ytSg3RS0VMySeNggJkm9xgLVD+rGM1CJhAsE6emu/JizvQ+Yuh4k0qz8uaBV9ZrBCGV6qSNpmA7PvnRsxIkKwjxf/5I7Fttk1VVUe9v0TZweF7g=='></script>
<script type='text/javascript' src='//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js?ver=0.1.1'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var mejsL10n = {"language":"en","strings":{"Close":"Close","Fullscreen":"Fullscreen","Turn off Fullscreen":"Turn off Fullscreen","Go Fullscreen":"Go Fullscreen","Download File":"Download File","Download Video":"Download Video","Play":"Play","Pause":"Pause","Captions\/Subtitles":"Captions\/Subtitles","None":"None","Time Slider":"Time Slider","Skip back %1 seconds":"Skip back %1 seconds","Video Player":"Video Player","Audio Player":"Audio Player","Volume Slider":"Volume Slider","Mute Toggle":"Mute Toggle","Unmute":"Unmute","Mute":"Mute","Use Up\/Down Arrow keys to increase or decrease volume.":"Use Up\/Down Arrow keys to increase or decrease volume.","Use Left\/Right Arrow keys to advance one second, Up\/Down arrows to advance ten seconds.":"Use Left\/Right Arrow keys to advance one second, Up\/Down arrows to advance ten seconds."}};
var _wpmejsSettings = {"pluginPath":"\/wp-includes\/js\/mediaelement\/"};
/* ]]> */
</script>
<script type='text/javascript'>
/* <![CDATA[ */
var wpcomVipAnalytics = {"is_404":"0","is_home":"0","is_single":"1","is_front_page":"0","is_archive":"0","percentToTrack":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='https://s0.wp.com/_static/??-eJx9jsEOgzAIhl9o2Gwzzh2WPQtricHQ2rRV49sPd1j00hP8kO8Ds0bgYGV2lM2YjSfHSEKeQjkFwOAgCm6UGs+hGfPF1FjdHfORsVMoP/2swnngkM0NFo67Q4teQtkK21wB0KkQPpiMx1woaQfTQinx/sx/VjEUFnIwoAil7ZyUevvXtX12fXfvH+34BbTvbSE='></script>

	<script>
		(function($){
			$(document.body).on('post-load', function(){
				var nodes = document.querySelectorAll('span.dsq-postid');
				for (var i = 0, url; i < nodes.length; i++) {
					var shorturl = nodes[i].getAttribute('rel');
					var new_rel = shorturl.replace( 'https:', 'http:' );
					nodes[i].parentNode.setAttribute('data-disqus-identifier', new_rel );
					url = nodes[i].parentNode.href.split('#', 1);
					if (url.length == 1) url = url[0];
					else url = url[1]
					nodes[i].parentNode.href = url + '#disqus_thread';
				}

				var DISQUSWIDGETS = window.DISQUSWIDGETS || {};

				if ( Object.keys(DISQUSWIDGETS).length !== 0 && DISQUSWIDGETS.constructor === Object ) {
					DISQUSWIDGETS.getCount();
				}
			});
		})(jQuery);
	</script>

<script type="text/javascript">
// <![CDATA[
(function() {
try{
  if ( window.external &&'msIsSiteMode' in window.external) {
    if (window.external.msIsSiteMode()) {
      var jl = document.createElement('script');
      jl.type='text/javascript';
      jl.async=true;
      jl.src='/wp-content/plugins/ie-sitemode/custom-jumplist.php';
      var s = document.getElementsByTagName('script')[0];
      s.parentNode.insertBefore(jl, s);
    }
  }
}catch(e){}
})();
// ]]>
</script>	<script type='text/javascript'>
		var secondaryMapping, adslot;

		googletag.cmd.push(function() {
			var mainMapping = googletag.sizeMapping().
				addSize([0, 0], [[320,50],[320,100]]).
				addSize([320, 400], [[320,50],[320,100]]).
				addSize([768, 200], [[468,60],[728,90]]).
				addSize([1050, 200], [[728,90],[970,70],[970,90],[970,250]]).
				build();

			secondaryMapping = googletag.sizeMapping().
				addSize([0, 0], [[300,250]]).
				addSize([320, 400], [[300,250]]).
				addSize([768, 200], [[300,250],[728,90]]).
				addSize([1050, 200], [[300,250],[728,90],[970,90],[970,250]]).
				build();

			adslot = googletag.defineSlot('/1049447/9to5google-728x90-TopMain-R', [[320, 100], [970, 90], [320, 50], [970, 250], [468, 60], [728, 90], [970, 70]], "div-gpt-ad-1436850350386-0").
				defineSizeMapping(mainMapping).
				addService(googletag.pubads());

			googletag.pubads().enableSingleRequest();
			googletag.pubads().collapseEmptyDivs();
			googletag.pubads().disableInitialLoad();
			googletag.enableServices();
		});

		window.nineto5ads = window.nineto5ads|| [];
		window.nineto5ads.forEach(function(ad){
			googletag.cmd.push(ad);
		});
		// Function to generate unique names for slots
		var nextSlotId = 1;
		function generateNextSlotName() {
			var id = nextSlotId++;
			return 'div-gpt-ad-' + id;
		}

		function loadAds( page, dfp_id ) {
			var $ads;

			if ( page === 1 ) {
				$ads = jQuery( '.post-content' ).find( '.inlinead:empty' );
			} else {
				$ads = jQuery( document.getElementById( 'infinite-view-' + ( page - 1 ) ) ).
					find( '.post-content .inlinead' );
			}

			$ads.each( function() {
				var slotName = generateNextSlotName(),
					slotDiv = document.createElement('div');

				slotDiv.id = slotName; // ID must be the same as slotName
				jQuery( this ).append( slotDiv );

				googletag.cmd.push( function() {
					var slot = googletag.defineSlot('/'+ dfp_id +'/9to5google-300x250-TopSidebarMain-R', [[300, 250], [970, 90], [970, 250], [728, 90]], slotName).
						defineSizeMapping(secondaryMapping).
						addService(googletag.pubads());

					// Display has to be called before
					// refresh and after the slot div is in the page.
					googletag.display(slotName);
					googletag.pubads().refresh([slot]);
				});
			});
		}
		
		function loadAuthorAds() {
			googletag.cmd.push( function() {
				googletag.pubads().refresh(null, {changeCorrelator: false});
			});
          }
	</script>
	<script>
		// Check if our canRunAds variable is set
		if ( typeof canRunAds === 'undefined' || canRunAds === null ){
			document.body.classList.add( 'enable-fallbacks' );
		}

		if ( typeof OXHBConfig === 'undefined' || OXHBConfig === null ){
			document.body.classList.add( 'enable-fallbacks' );
		}

		(function($){
			$( '.th1d95b257' ).click( function () {
				window.open( $( this ).data( 'th4d772ac4' ) );
				return false;
			});
			
			$(document.body).on('post-load', function(){
				$( '.th1d95b257' ).click( function () {
					window.open( $( this ).data( 'th4d772ac4' ) );
					return false;
				});
			});
		})(jQuery);
	</script>
<script src="//stats.wp.com/w.js?56" type="text/javascript" async defer></script>
<script type="text/javascript">
_tkq = window._tkq || [];
_stq = window._stq || [];
_tkq.push(['storeContext', {'blog_id':'22427743','blog_tz':'-7','user_lang':'en','blog_lang':'en','user_id':'0'}]);
_stq.push(['view', {'blog':'22427743','v':'wpcom','tz':'-7','user_id':'0','post':'181651','subd':'9to5google'}]);
function st_vt() {var x=document.createElement("img");x.src="https://pixel.wp.com/g.gif?blog=22427743&v=wpcomvt&tz=-7&user_id=0&post=181651&subd=9to5google&rand="+Math.random();}
_stq.push(['extra', {'crypt':'UE40eW5QN0p8M2Y/RE1BNmNJfGhxNCVxUDExYmtib2E/SzdEJm0lUEtbdFU0fFk4cHZvcUFrZT90Tn4yQm1+R3NyNTdaY3ZNZFJuS3czaXFpJT9lMC56TmhYLjZfZnJRVmZ8ckZTYU9yaVpETHF5dV09MWR5OWVwWXlNX1gxQSxrcWUlbHBNZFd3ZzJxMiw1UmxDP0lWYmI9Jm5pRG5icElzTTlRd1daW3hSeUJEZkktMCZQK3pNSk9ELHd4UVBXMDZoP11PS19mS0E2JUVrY2ZEUjlXdmRNbHdLbFszfG16ZGR6aXIxeFpJRA=='}]);
_stq.push([ 'clickTrackerInit', '22427743', '181651' ]);
	</script>
<noscript><img src="https://pixel.wp.com/b.gif?v=noscript" style="height:0px;width:0px;overflow:hidden" alt="" /></noscript>
<!-- Tracking Codes -->          <script type="text/javascript" src="//s.skimresources.com/js/3947X1518523.skimlinks.js"></script>
		<!-- End Tracking Codes --><script>
if ( 'object' === typeof wpcom_mobile_user_agent_info ) {

	wpcom_mobile_user_agent_info.init();
	var mobileStatsQueryString = "";
	
	if( false !== wpcom_mobile_user_agent_info.matchedPlatformName )
		mobileStatsQueryString += "&x_" + 'mobile_platforms' + '=' + wpcom_mobile_user_agent_info.matchedPlatformName;
	
	if( false !== wpcom_mobile_user_agent_info.matchedUserAgentName )
		mobileStatsQueryString += "&x_" + 'mobile_devices' + '=' + wpcom_mobile_user_agent_info.matchedUserAgentName;
	
	if( wpcom_mobile_user_agent_info.isIPad() )
		mobileStatsQueryString += "&x_" + 'ipad_views' + '=' + 'views';

	if( "" != mobileStatsQueryString ) {
		new Image().src = document.location.protocol + '//pixel.wp.com/g.gif?v=wpcom-no-pv' + mobileStatsQueryString + '&baba=' + Math.random();
	}
	
}
</script>
	</body>
</html>
<!--
	generated 212 seconds ago
	generated in 0.094 seconds
	served from batcache in 0.002 seconds
	expires in 88 seconds
-->
