<!DOCTYPE html>
<html lang="en-US">
	<head>
				<meta charset="UTF-8" />
		<meta name="viewport" content="width=device-width, initial-scale=1, maximum-scale=1.0, minimal-ui">
				<meta name='robots' content='index, follow, max-image-preview:large, max-snippet:-1, max-video-preview:-1' />
		<script>
			window.dataLayer = window.dataLayer || [];
						dataLayer.push({"pageType":"post","postCategory":["google-assistant","google-home"]});
					</script>
					<script src="https://9to5google.com/wp-content/themes/9to5-2015/assets/js/adsbygoogle.js"></script>

			
				<!-- Google Tag Manager -->
				<script>
				(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
					new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
					j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
					'https://www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
				})(window,document,'script','dataLayer','GTM-THGGVXB');
				</script>
				<!-- End Google Tag Manager -->

				
				<!-- Google Tag Manager -->
				<script>
				(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
					new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
					j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
					'https://www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
				})(window,document,'script','dataLayer','GTM-W5LZ9VX');
				</script>
				<!-- End Google Tag Manager -->

						<link rel="shortcut icon" href="/favicon.ico" type="image/x-icon" />
		<link rel="apple-touch-icon" href="/apple-touch-icon.png" />
		<link rel="apple-touch-icon" sizes="57x57" href="/apple-touch-icon-57x57.png" />
		<link rel="apple-touch-icon" sizes="72x72" href="/apple-touch-icon-72x72.png" />
		<link rel="apple-touch-icon" sizes="76x76" href="/apple-touch-icon-76x76.png" />
		<link rel="apple-touch-icon" sizes="114x114" href="/apple-touch-icon-114x114.png" />
		<link rel="apple-touch-icon" sizes="120x120" href="/apple-touch-icon-120x120.png" />
		<link rel="apple-touch-icon" sizes="144x144" href="/apple-touch-icon-144x144.png" />
		<link rel="apple-touch-icon" sizes="152x152" href="/apple-touch-icon-152x152.png" />
		<link rel="apple-touch-icon" sizes="180x180" href="/apple-touch-icon-180x180.png" />
		<link rel="icon" sizes="192x192" href="/wp-content/themes/9to5-2015/images/favicons/9to5google/icon-192x192.png">
		<link rel="manifest" href="/wp-content/themes/9to5-2015/images/favicons/9to5google/site.webmanifest">
		
	<!-- This site is optimized with the Yoast SEO Premium plugin v19.2.1 (Yoast SEO v19.6.1) - https://yoast.com/wordpress/plugins/seo/ -->
	<title>Google improving Assistant smart home command accuracy with AI</title>
	<meta name="description" content="Using voice commands to control smart home devices is very common, and something that Google Assistant is about to get better at with AI..." />
	<link rel="canonical" href="https://9to5google.com/2022/10/20/google-assistant-home-commands/" />
	<meta property="og:locale" content="en_US" />
	<meta property="og:type" content="article" />
	<meta property="og:title" content="Google using AI to improve accuracy of Assistant smart home commands, but warns of changes" />
	<meta property="og:description" content="Using voice commands to control smart home devices is very common, and something that Google Assistant is about to get better at with AI..." />
	<meta property="og:url" content="https://9to5google.com/2022/10/20/google-assistant-home-commands/" />
	<meta property="og:site_name" content="9to5Google" />
	<meta property="article:publisher" content="https://www.facebook.com/pages/9to5Google/218132111544562" />
	<meta property="article:published_time" content="2022-10-20T18:56:48+00:00" />
	<meta property="article:modified_time" content="2022-10-20T18:56:49+00:00" />
	<meta property="og:image" content="https://i0.wp.com/9to5google.com/wp-content/uploads/sites/4/2019/01/google_assistant_7.jpg?resize=1200%2C628&quality=82&strip=all&ssl=1" />
	<meta property="og:image:width" content="2500" />
	<meta property="og:image:height" content="1250" />
	<meta property="og:image:type" content="image/jpeg" />
	<meta name="author" content="Abner Li" />
	<meta name="twitter:card" content="summary_large_image" />
	<meta name="twitter:image" content="https://i0.wp.com/9to5google.com/wp-content/uploads/sites/4/2019/01/google_assistant_7.jpg?resize=1200%2C628&quality=82&strip=all&ssl=1" />
	<meta name="twitter:creator" content="@9to5Google" />
	<meta name="twitter:site" content="@9to5Google" />
	<meta name="twitter:label1" content="Written by" />
	<meta name="twitter:data1" content="Abner Li" />
	<meta name="twitter:label2" content="Est. reading time" />
	<meta name="twitter:data2" content="2 minutes" />
	<script type="application/ld+json" class="yoast-schema-graph">{"@context":"https://schema.org","@graph":[{"@type":"NewsArticle","@id":"https://9to5google.com/2022/10/20/google-assistant-home-commands/#article","isPartOf":{"@id":"https://9to5google.com/2022/10/20/google-assistant-home-commands/"},"author":{"name":"Abner Li","@id":"https://9to5google.com/#/schema/person/e88433b75582d2e278fdb57f4ccb41cc"},"headline":"Google using AI to improve accuracy of Assistant smart home commands, but warns of changes","datePublished":"2022-10-20T18:56:48+00:00","dateModified":"2022-10-20T18:56:49+00:00","mainEntityOfPage":{"@id":"https://9to5google.com/2022/10/20/google-assistant-home-commands/"},"wordCount":458,"commentCount":0,"publisher":{"@id":"https://9to5google.com/#organization"},"image":{"@id":"https://9to5google.com/2022/10/20/google-assistant-home-commands/#primaryimage"},"thumbnailUrl":"https://9to5google.com/wp-content/uploads/sites/4/2019/01/google_assistant_7.jpg?quality=82&strip=all","articleSection":["News"],"inLanguage":"en-US","potentialAction":[{"@type":"CommentAction","name":"Comment","target":["https://9to5google.com/2022/10/20/google-assistant-home-commands/#respond"]}],"copyrightYear":"2022","copyrightHolder":{"@id":"https://925.co/#organization"}},{"@type":"WebPage","@id":"https://9to5google.com/2022/10/20/google-assistant-home-commands/","url":"https://9to5google.com/2022/10/20/google-assistant-home-commands/","name":"Google improving Assistant smart home command accuracy with AI","isPartOf":{"@id":"https://9to5google.com/#website"},"primaryImageOfPage":{"@id":"https://9to5google.com/2022/10/20/google-assistant-home-commands/#primaryimage"},"image":{"@id":"https://9to5google.com/2022/10/20/google-assistant-home-commands/#primaryimage"},"thumbnailUrl":"https://9to5google.com/wp-content/uploads/sites/4/2019/01/google_assistant_7.jpg?quality=82&strip=all","datePublished":"2022-10-20T18:56:48+00:00","dateModified":"2022-10-20T18:56:49+00:00","description":"Using voice commands to control smart home devices is very common, and something that Google Assistant is about to get better at with AI...","breadcrumb":{"@id":"https://9to5google.com/2022/10/20/google-assistant-home-commands/#breadcrumb"},"inLanguage":"en-US","potentialAction":[{"@type":"ReadAction","target":["https://9to5google.com/2022/10/20/google-assistant-home-commands/"]}]},{"@type":"ImageObject","inLanguage":"en-US","@id":"https://9to5google.com/2022/10/20/google-assistant-home-commands/#primaryimage","url":"https://9to5google.com/wp-content/uploads/sites/4/2019/01/google_assistant_7.jpg?quality=82&strip=all&w=1000","contentUrl":"https://9to5google.com/wp-content/uploads/sites/4/2019/01/google_assistant_7.jpg?quality=82&strip=all&w=1000","width":2500,"height":1250,"caption":"Google Home Assistant pretty please"},{"@type":"BreadcrumbList","@id":"https://9to5google.com/2022/10/20/google-assistant-home-commands/#breadcrumb","itemListElement":[{"@type":"ListItem","position":1,"name":"Home","item":"https://9to5google.com/"},{"@type":"ListItem","position":2,"name":"Google using AI to improve accuracy of Assistant smart home commands, but warns of changes"}]},{"@type":"WebSite","@id":"https://9to5google.com/#website","url":"https://9to5google.com/","name":"9to5Google","description":"Google news, Pixel, Android, Home, Chrome OS, more","publisher":{"@id":"https://9to5google.com/#organization"},"potentialAction":[{"@type":"SearchAction","target":{"@type":"EntryPoint","urlTemplate":"https://9to5google.com/?s={search_term_string}"},"query-input":"required name=search_term_string"}],"inLanguage":"en-US"},{"@type":"NewsMediaOrganization","@id":"https://9to5google.com/#organization","name":"9to5Google","url":"https://9to5google.com/","sameAs":["https://www.instagram.com/9to5google","https://www.youtube.com/c/9to5google","https://www.facebook.com/pages/9to5Google/218132111544562","https://twitter.com/9to5Google"],"logo":{"@type":"ImageObject","inLanguage":"en-US","@id":"https://9to5google.com/#/schema/logo/image/","url":"https://9to5google.com/wp-content/uploads/sites/4/2018/09/9to5-google-logo.png","contentUrl":"https://9to5google.com/wp-content/uploads/sites/4/2018/09/9to5-google-logo.png","width":628,"height":103,"caption":"9to5Google"},"image":{"@id":"https://9to5google.com/#/schema/logo/image/"},"masthead":"https://9to5google.com/about/"},{"@type":"Person","@id":"https://9to5google.com/#/schema/person/e88433b75582d2e278fdb57f4ccb41cc","name":"Abner Li","image":{"@type":"ImageObject","inLanguage":"en-US","@id":"https://9to5google.com/#/schema/person/image/","url":"https://secure.gravatar.com/avatar/ba5acd965e31e2bfe2fbd4e37d8f68b9?s=96&d=mm&r=r","contentUrl":"https://secure.gravatar.com/avatar/ba5acd965e31e2bfe2fbd4e37d8f68b9?s=96&d=mm&r=r","caption":"Abner Li"},"url":"https://9to5google.com/author/technacity/"}]}</script>
	<!-- / Yoast SEO Premium plugin. -->


<link rel='dns-prefetch' href='//9to5mac-com.videoplayerhub.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="9to5Google &raquo; Feed" href="https://9to5google.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="9to5Google &raquo; Comments Feed" href="https://9to5google.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="9to5Google &raquo; Google using AI to improve accuracy of Assistant smart home commands, but warns of changes Comments Feed" href="https://9to5google.com/2022/10/20/google-assistant-home-commands/feed/" />
<link rel="alternate" type="application/rss+xml" title="9to5Google &raquo; Stories Feed" href="https://9to5google.com/web-stories/feed/"><script type="text/javascript">
window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/14.0.0\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/14.0.0\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/9to5google.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=6.0.3"}};
/*! This file is auto-generated */
!function(e,a,t){var n,r,o,i=a.createElement("canvas"),p=i.getContext&&i.getContext("2d");function s(e,t){var a=String.fromCharCode,e=(p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,e),0,0),i.toDataURL());return p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,t),0,0),e===i.toDataURL()}function c(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(o=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},r=0;r<o.length;r++)t.supports[o[r]]=function(e){if(!p||!p.fillText)return!1;switch(p.textBaseline="top",p.font="600 32px Arial",e){case"flag":return s([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])?!1:!s([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!s([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]);case"emoji":return!s([129777,127995,8205,129778,127999],[129777,127995,8203,129778,127999])}return!1}(o[r]),t.supports.everything=t.supports.everything&&t.supports[o[r]],"flag"!==o[r]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[o[r]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(e=t.source||{}).concatemoji?c(e.concatemoji):e.wpemoji&&e.twemoji&&(c(e.twemoji),c(e.wpemoji)))}(window,document,window._wpemojiSettings);
</script>
<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 0.07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='all-css-0' href='https://9to5google.com/_static/??-eJyNj9EOwjAIRX/IDo3J4h6M39JRMlHaNYVl6d87Z5Zsbz5e4AAH5uw4oUyBFFAVAqtBLyO+nXBffKmgVoWayKlZBk6wJ14KkQJ7EoqU7BCy+ErFCQ0e63/40tvnA4RjsvXE5LJMAycFJV/wCSRejTEX2v7/ipSlbBRcHtXU/YxWE93WPuL90rbtuetu1+4DN7ljDQ==' type='text/css' media='all' />
<style id='wp-block-library-inline-css'>
.has-text-align-justify{text-align:justify;}
</style>
<style id='global-styles-inline-css'>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</style>
<link rel='stylesheet' id='all-css-2' href='https://9to5google.com/wp-content/themes/9to5-2015/assets/css/darkmode.css?m=1666194751g' type='text/css' media='all' />
<link crossorigin="anonymous" rel='stylesheet' id='googleFonts-css'  href='https://fonts.googleapis.com/css?family=Roboto%3A300%2C300italic%2C400%2C400italic%2C500%2C500italic%7CQuestrial&#038;ver=6.0.3' media='all' />
<link rel='stylesheet' id='all-css-4' href='https://9to5google.com/_static/??-eJyVjEkKgDAQBD9kHCMm4kF8i8QBg1mEHhF/b1Dw7q2hqprOXbmchJOQrBwZNEg2qm20oRlgATmAELzb6rIq+lOox/jXyRUYdfTpy3xy4Vj45cuM1ZejT5niqK21euh6o28AzEi8' type='text/css' media='all' />
<script type="text/javascript" src="https://9to5google.com/_static/??-eJx9jEEOwiAQRS8kHTGCYdF4FgITBZ2hwlDj7UsaF65MfvI27314LypxePaIDfLYq2P9fDFR4im3A/yTFKVb9YK/cigsyAJyRxqJk2LU6agN+NZQ9o8VOZYK0dcHlYijvNKsrbXanS9G5w0cQTbG" ></script><script src='//9to5mac-com.videoplayerhub.com/gallery.js?ver=6.0.3' id='ninetofive-blockthrough-js'></script>
<link rel="https://api.w.org/" href="https://9to5google.com/wp-json/" /><link rel="alternate" type="application/json" href="https://9to5google.com/wp-json/wp/v2/posts/533122" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://9to5google.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://9to5google.com/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress 6.0.3" />
<link rel='shortlink' href='https://9to5google.com/?p=533122' />
<link rel="alternate" type="application/json+oembed" href="https://9to5google.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2F9to5google.com%2F2022%2F10%2F20%2Fgoogle-assistant-home-commands%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://9to5google.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2F9to5google.com%2F2022%2F10%2F20%2Fgoogle-assistant-home-commands%2F&#038;format=xml" />
<!-- Stream WordPress user activity plugin v3.9.1 -->
<style>img#wpstats{display:none}</style>
		<script>
		var PWT = {}; // PubMatic namespace.
		window.googletag = window.googletag || {};
		var googletag = googletag || {};
		googletag.cmd = googletag.cmd || [];
	</script>
	<link rel="mask-icon" color="#296700" href="https://9to5google.com/wp-content/themes/9to5-2015/images/9to5-clock.svg"><link rel="amphtml" href="https://9to5google.com/2022/10/20/google-assistant-home-commands/amp/">	<script type='text/javascript'>
		if ( document.cookie.indexOf('scroll0=') < 0 ) {
			googletag.cmd.push(function() {
				googletag.defineSlot( '/1049447/9to5google_Signal_1x1', [1, 1], 'div-gpt-ad-signal' ).addService(googletag.pubads());
				googletag.enableServices();
			});
		}
	</script>
		<script>
		PWT.jsLoaded = function(){ // PubMatic pwt.js on load callback is used to load GPT
			(function() {
				var gads = document.createElement('script');
				var useSSL = 'https:' == document.location.protocol;
				gads.src = (useSSL ? 'https:' : 'http:') + '//www.googletagservices.com/tag/js/gpt.js';
				var node = document.getElementsByTagName('script')[0];
				node.parentNode.insertBefore(gads, node);
			})();
		};
		(function() {
			var viewport = document.documentElement.clientWidth;
			var profileID = viewport < 768 ? '6841' : '6840';
			var purl = window.location.href;
			var url = '//ads.pubmatic.com/AdServer/js/pwt/161751/' + profileID;
			var profileVersionId = '';
			if(purl.indexOf('pwtv=')>0){
				var regexp = /pwtv=(.*?)(&|$)/g;
				var matches = regexp.exec(purl);
				if(matches.length >= 2 && matches[1].length > 0){
					profileVersionId = '/'+matches[1];
				}
			}
			var wtads = document.createElement('script');
			wtads.async = true;
			wtads.type = 'text/javascript';
			wtads.src = url+profileVersionId+'/pwt.js';
			var node = document.getElementsByTagName('script')[0];
			node.parentNode.insertBefore(wtads, node);
		})();
	</script>
		<script>
	//load the apstag.js library
	!function(a9,a,p,s,t,A,g){if(a[a9])return;function q(c,r){a[a9]._Q.push([c,r])}a[a9]={init:function(){q("i",arguments)},fetchBids:function(){q("f",arguments)},setDisplayBids:function(){},targetingKeys:function(){return[]},_Q:[]};A=p.createElement(s);A.async=!0;A.src=t;g=p.getElementsByTagName(s)[0];g.parentNode.insertBefore(A,g)}("apstag",window,document,"script","//c.amazon-adsystem.com/aax2/apstag.js");

	//initialize the apstag.js library on the page to allow bidding
	apstag.init({
		pubID: 'fee31bcb-d8b7-4565-8a5b-b1097e207e11',
		adServer: 'googletag'
	});
	</script>
	<meta name="msapplication-TileImage" content="https://9to5google.com/wp-content/uploads/sites/4/2017/03/favicon-bg-none-face-white.png?w=256" />

	<style>
		.th32d150c9 { padding: 10px 0; text-align: center; background: url('https://9to5google.com/wp-content/themes/9to5-2015/images/top-leaderboard-bg.png') repeat center; min-height: 120px; }
		@media (min-width: 1049px) {
			.th32d150c9 {
				min-height: 270px;
			}
		}

		.th32d150c9 .inlinead { background-color: transparent; min-height: 1px; }
		.th32d150c9 .inlinead > div { background-color: transparent; padding: 0; }

		.color-scheme-electrek .th32d150c9 { background-color: #939598; }

		.ad { margin: 0 auto; }

		@media (min-width: 0px) and (max-width: 767px) { .two-up-ads { display: none; } }

		.two-up-ads, .post-leaderboard { box-sizing: border-box; width: 100%; float: left; padding-left: 0.83333%; padding-right: 0.83333%; background-color: #ECECED; padding: 25px 0; }
		.two-up-ads .ad-1, .two-up-ads .ad-2, .post-leaderboard .ad-1, .post-leaderboard .ad-2 { display: inline-block; width: 300px; height: 250px; overflow: hidden; }
		.two-up-ads .ad-1, .post-leaderboard .ad-1 { box-sizing: border-box; width: 50%; float: left; padding-left: 0.83333%; padding-right: 0.83333%; text-align: right; }
		.two-up-ads .ad-2, .post-leaderboard .ad-2 { box-sizing: border-box; width: 50%; float: right; padding-left: 0.83333%; padding-right: 0.83333%; text-align: left; padding-left: 40px; }

		@media (min-width: 0px) and (max-width: 767px) { .post-leaderboard img { width: 100%; } }

		.post-leaderboard > * { margin: 0 auto; text-align: center; display: block; }

		/** inline ads **/
		.tha630499d { background: url('https://9to5google.com/wp-content/themes/9to5-2015/images/top-leaderboard-bg.png') repeat center; max-width: 100%; overflow: hidden; text-align: center; }\
		.tha630499d > div, .tha630499d > ins { padding: 20px 0; margin: 0 auto; }
		.darkmode--activated .th32d150c9,
		.darkmode--activated .tha630499d,
		.darkmode--activated .inlinead {
			background: url('https://9to5google.com/wp-content/themes/9to5-2015/images/top-leaderboard-bg-dark.png') repeat center;
			isolation: isolate;
		}
		@media only screen and (min-width: 768px) { .tha630499d > div, .tha630499d > ins { display: block; padding: 25px 10px 25px 0; }

		.post-body .tha630499d { background-color: transparent; }

		.thc78b6001 { width: 300px; min-height: 250px; isolation: isolate; }
		@media (min-device-width: 320px) and (max-device-width: 479px) { .thc78b6001 { width: 300px; min-height: 250px; } }
		@media (min-device-width: 480px) and (max-device-width: 767px) { .thc78b6001 { width: 300px; min-height: 250px; } }
		@media (min-width: 768px) { .thc78b6001 { float: right; margin-left: 20px; width: 336px; min-height: 280px; } }
		@media (min-width: 1000px) {
			.thc78b6001 { margin: 0 -105px 20px 20px; }
			.aside-post .thc78b6001 { margin-top: 20px; }
		}

		.the7952eea { line-height: 0; max-width: 300px; position: relative; }
		.the7952eea h3 { background: rgba(0, 0, 0, 0.7); bottom: 0; box-sizing: border-box; color: #fff; font-size: 1.17em; font-weight: 400; line-height: 1.3; margin: 0 0; padding: 0.25em 0.5em; position: absolute; text-align: left; width: 100%; }
		.post-body .the7952eea h3 { font-size: 1em; }
		@media (min-width: 768px) { .post-body .the7952eea { float: right; margin-left: 20px; width: 300px; height: 250px; } }
		@media (min-width: 1000px) { .post-body .the7952eea { margin: 0 -105px 20px 20px; } }

		.thaaff237b .the7952eea { margin: 0 auto; }
		.thee8814c9 { cursor: pointer }
	</style>

			<style type="text/css" id="wp-custom-css">
			 .darkmode--activated.color-scheme-google .author-content .post-title {
    color: #fff;
	 mix-blend-mode: difference;
}

body.darkmode--activated {
  background: #000;
  color: #fff;
}

.darkmode-layer--simple {
  display: none !important;
}

.share-customize-link {
  display: none;
}		</style>
					<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
			<script type="text/javascript">(adsbygoogle = window.adsbygoogle || []).push({ google_ad_client: "ca-pub-7114551592991368", enable_page_level_ads: true });</script>
			
		<script>
			document.documentElement.className = document.documentElement.className.replace('no-js', " ");
			document.documentElement.className += ' js ';
		</script>
	</head>
		<body class="post-template-default single single-post postid-533122 single-format-standard wp-embed-responsive color-scheme-google infinite-scroll">
			
				<!-- Google Tag Manager (noscript) -->
				<noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-THGGVXB" height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
				<!-- End Google Tag Manager (noscript) -->

				
				<!-- Google Tag Manager (noscript) -->
				<noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-W5LZ9VX" height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
				<!-- End Google Tag Manager (noscript) -->

				
			<div></div>
			<header class="site-header js-header-normal" id="js-site-header">
				<div class="site-header-inner">

					<div class="header-logo">
						<a href="https://9to5google.com/" rel="home">
							<img src="https://9to5google.com/wp-content/uploads/sites/4/2018/10/cropped-new-9to5-google-logo.png" alt="" />
						</a>
						<button aria-expanded="false" aria-controls="js-site-switcher" id="js-button-switcher" class="js-button button-site-switcher">
									<svg class="ninetofive-icon chevron-down js-regular-icon" aria-hidden="true">
									<use
				xlink:href="https://9to5google.com/wp-content/themes/9to5-2015/images/svg-sprite-2020.svg?ver=1666194751#ninetofive-icon-chevron-down"/>
		</svg>
											<svg class="ninetofive-icon chevron-up js-expanded-icon" aria-hidden="true">
									<use
				xlink:href="https://9to5google.com/wp-content/themes/9to5-2015/images/svg-sprite-2020.svg?ver=1666194751#ninetofive-icon-chevron-up"/>
		</svg>
									<span class="screen-reader-text">Switch site</span>
						</button>
					</div>
					<!-- .header-logo -->

					<nav id="primary-menu" class="primary-menu">
						<button class="js-mobile-menu-prev js-button" id="js-mobile-menu-prev" data-direction="1">
									<svg class="ninetofive-icon chevron-left " aria-hidden="true">
									<use
				xlink:href="https://9to5google.com/wp-content/themes/9to5-2015/images/svg-sprite-2020.svg?ver=1666194751#ninetofive-icon-chevron-left"/>
		</svg>
								</button>
						<button class="js-mobile-menu-next js-button" id="js-mobile-menu-next" data-direction="-1">
									<svg class="ninetofive-icon chevron-right " aria-hidden="true">
									<use
				xlink:href="https://9to5google.com/wp-content/themes/9to5-2015/images/svg-sprite-2020.svg?ver=1666194751#ninetofive-icon-chevron-right"/>
		</svg>
								</button>
						<ul id="menu-guides" class="primary-menu-ul"><li id="menu-item-340340" class="menu-item menu-item-type-taxonomy menu-item-object-ninetofive_featured menu-item-340340"><a href="https://9to5google.com/feature/exclusives/">Exclusives</a></li>
<li id="menu-item-367287" class="menu-item menu-item-type-taxonomy menu-item-object-ninetofive_guides menu-item-has-children menu-item-367287"><a href="https://9to5google.com/guides/google-pixel/">Pixel</a>
<ul class="sub-menu">
	<li id="menu-item-462133" class="menu-item menu-item-type-taxonomy menu-item-object-ninetofive_guides menu-item-462133"><a href="https://9to5google.com/guides/google-pixel-6/">Google Pixel 6</a></li>
	<li id="menu-item-462134" class="menu-item menu-item-type-taxonomy menu-item-object-ninetofive_guides menu-item-462134"><a href="https://9to5google.com/guides/google-pixel-6-pro/">Google Pixel 6 Pro</a></li>
	<li id="menu-item-502587" class="menu-item menu-item-type-taxonomy menu-item-object-ninetofive_guides menu-item-502587"><a href="https://9to5google.com/guides/google-pixel-6a/">Google Pixel 6a</a></li>
	<li id="menu-item-502592" class="menu-item menu-item-type-taxonomy menu-item-object-ninetofive_guides menu-item-502592"><a href="https://9to5google.com/guides/google-pixel-7/">Google Pixel 7</a></li>
	<li id="menu-item-502593" class="menu-item menu-item-type-taxonomy menu-item-object-ninetofive_guides menu-item-502593"><a href="https://9to5google.com/guides/google-pixel-7-pro/">Google Pixel 7 Pro</a></li>
	<li id="menu-item-502589" class="menu-item menu-item-type-taxonomy menu-item-object-ninetofive_guides menu-item-502589"><a href="https://9to5google.com/guides/google-pixel-buds-a-series/">Pixel Buds A-Series</a></li>
	<li id="menu-item-502590" class="menu-item menu-item-type-taxonomy menu-item-object-ninetofive_guides menu-item-502590"><a href="https://9to5google.com/guides/google-pixel-buds-pro/">Pixel Buds Pro</a></li>
	<li id="menu-item-502588" class="menu-item menu-item-type-taxonomy menu-item-object-ninetofive_guides menu-item-502588"><a href="https://9to5google.com/guides/google-pixel-watch/">Pixel Watch</a></li>
	<li id="menu-item-502591" class="menu-item menu-item-type-taxonomy menu-item-object-ninetofive_guides menu-item-502591"><a href="https://9to5google.com/guides/pixel-tablet/">Pixel Tablet</a></li>
</ul>
</li>
<li id="menu-item-367282" class="menu-item menu-item-type-taxonomy menu-item-object-ninetofive_guides menu-item-has-children menu-item-367282"><a href="https://9to5google.com/guides/google-nest/">Nest</a>
<ul class="sub-menu">
	<li id="menu-item-367286" class="menu-item menu-item-type-taxonomy menu-item-object-ninetofive_guides menu-item-367286"><a href="https://9to5google.com/guides/google-nest-hub/">Google Nest Hub</a></li>
	<li id="menu-item-367285" class="menu-item menu-item-type-taxonomy menu-item-object-ninetofive_guides menu-item-367285"><a href="https://9to5google.com/guides/google-nest-hub-max/">Google Nest Hub Max</a></li>
	<li id="menu-item-367284" class="menu-item menu-item-type-taxonomy menu-item-object-ninetofive_guides menu-item-367284"><a href="https://9to5google.com/guides/google-nest-mini/">Google Nest Mini</a></li>
	<li id="menu-item-387618" class="menu-item menu-item-type-taxonomy menu-item-object-ninetofive_guides menu-item-387618"><a href="https://9to5google.com/guides/google-nest-audio/">Google Nest Audio</a></li>
	<li id="menu-item-367283" class="menu-item menu-item-type-taxonomy menu-item-object-ninetofive_guides menu-item-367283"><a href="https://9to5google.com/guides/google-nest-wifi/">Google Nest Wifi</a></li>
	<li id="menu-item-387608" class="menu-item menu-item-type-taxonomy menu-item-object-ninetofive_guides menu-item-387608"><a href="https://9to5google.com/guides/google-wifi/">Google Wifi</a></li>
	<li id="menu-item-387609" class="menu-item menu-item-type-taxonomy menu-item-object-ninetofive_guides menu-item-387609"><a href="https://9to5google.com/guides/nest-thermostat/">Nest Thermostats</a></li>
	<li id="menu-item-387612" class="menu-item menu-item-type-taxonomy menu-item-object-ninetofive_guides menu-item-387612"><a href="https://9to5google.com/guides/nest-cam/">Nest Cam</a></li>
	<li id="menu-item-462137" class="menu-item menu-item-type-taxonomy menu-item-object-ninetofive_guides menu-item-462137"><a href="https://9to5google.com/guides/google-nest-doorbell/">Google Nest Doorbell</a></li>
	<li id="menu-item-367295" class="menu-item menu-item-type-taxonomy menu-item-object-ninetofive_guides menu-item-367295"><a href="https://9to5google.com/guides/nest-hello/">Nest Hello</a></li>
	<li id="menu-item-367296" class="menu-item menu-item-type-taxonomy menu-item-object-ninetofive_guides menu-item-367296"><a href="https://9to5google.com/guides/nest-protect/">Nest Protect</a></li>
</ul>
</li>
<li id="menu-item-145656" class="menu-item menu-item-type-taxonomy menu-item-object-ninetofive_guides menu-item-has-children menu-item-145656"><a href="https://9to5google.com/guides/android/">Android</a>
<ul class="sub-menu">
	<li id="menu-item-462136" class="menu-item menu-item-type-taxonomy menu-item-object-ninetofive_guides menu-item-462136"><a href="https://9to5google.com/guides/android-12/">Android 12</a></li>
	<li id="menu-item-517584" class="menu-item menu-item-type-taxonomy menu-item-object-ninetofive_guides menu-item-517584"><a href="https://9to5google.com/guides/android-13/">Android 13</a></li>
	<li id="menu-item-145938" class="menu-item menu-item-type-taxonomy menu-item-object-ninetofive_guides menu-item-145938"><a href="https://9to5google.com/guides/android-auto/">Auto</a></li>
	<li id="menu-item-387604" class="menu-item menu-item-type-taxonomy menu-item-object-ninetofive_guides menu-item-387604"><a href="https://9to5google.com/guides/wear-os/">Wear OS</a></li>
	<li id="menu-item-190109" class="menu-item menu-item-type-taxonomy menu-item-object-ninetofive_guides menu-item-190109"><a href="https://9to5google.com/guides/samsung/">Samsung</a></li>
	<li id="menu-item-190116" class="menu-item menu-item-type-taxonomy menu-item-object-ninetofive_guides menu-item-190116"><a href="https://9to5google.com/guides/oneplus/">OnePlus</a></li>
	<li id="menu-item-502596" class="menu-item menu-item-type-taxonomy menu-item-object-ninetofive_guides menu-item-502596"><a href="https://9to5google.com/guides/oppo/">Oppo</a></li>
	<li id="menu-item-502595" class="menu-item menu-item-type-taxonomy menu-item-object-ninetofive_guides menu-item-502595"><a href="https://9to5google.com/guides/xiaomi/">Xiaomi</a></li>
</ul>
</li>
<li id="menu-item-145658" class="menu-item menu-item-type-taxonomy menu-item-object-ninetofive_guides menu-item-has-children menu-item-145658"><a href="https://9to5google.com/guides/google-chrome/">Chrome</a>
<ul class="sub-menu">
	<li id="menu-item-502608" class="menu-item menu-item-type-taxonomy menu-item-object-ninetofive_guides menu-item-502608"><a href="https://9to5google.com/guides/google-chrome/">Google Chrome</a></li>
	<li id="menu-item-502598" class="menu-item menu-item-type-taxonomy menu-item-object-ninetofive_guides menu-item-502598"><a href="https://9to5google.com/guides/chrome-os/">ChromeOS</a></li>
</ul>
</li>
<li id="menu-item-387606" class="menu-item menu-item-type-taxonomy menu-item-object-ninetofive_guides menu-item-has-children menu-item-387606"><a href="https://9to5google.com/guides/google-tv/">TV</a>
<ul class="sub-menu">
	<li id="menu-item-502605" class="menu-item menu-item-type-taxonomy menu-item-object-ninetofive_guides menu-item-502605"><a href="https://9to5google.com/guides/google-tv/">Google TV</a></li>
	<li id="menu-item-145657" class="menu-item menu-item-type-taxonomy menu-item-object-ninetofive_guides menu-item-145657"><a href="https://9to5google.com/guides/android-tv/">Android TV</a></li>
	<li id="menu-item-190115" class="menu-item menu-item-type-taxonomy menu-item-object-ninetofive_guides menu-item-190115"><a href="https://9to5google.com/guides/chromecast/">Chromecast</a></li>
	<li id="menu-item-387607" class="menu-item menu-item-type-taxonomy menu-item-object-ninetofive_guides menu-item-387607"><a href="https://9to5google.com/guides/chromecast-with-google-tv/">Chromecast with Google TV</a></li>
</ul>
</li>
<li id="menu-item-387598" class="menu-item menu-item-type-taxonomy menu-item-object-ninetofive_guides menu-item-has-children menu-item-387598"><a href="https://9to5google.com/guides/google-workspace/">Workspace</a>
<ul class="sub-menu">
	<li id="menu-item-190151" class="menu-item menu-item-type-taxonomy menu-item-object-ninetofive_guides menu-item-190151"><a href="https://9to5google.com/guides/gmail/">Gmail</a></li>
	<li id="menu-item-367291" class="menu-item menu-item-type-taxonomy menu-item-object-ninetofive_guides menu-item-367291"><a href="https://9to5google.com/guides/google-meet/">Google Meet</a></li>
	<li id="menu-item-367292" class="menu-item menu-item-type-taxonomy menu-item-object-ninetofive_guides menu-item-367292"><a href="https://9to5google.com/guides/google-chat/">Google Chat</a></li>
	<li id="menu-item-190152" class="menu-item menu-item-type-taxonomy menu-item-object-ninetofive_guides menu-item-190152"><a href="https://9to5google.com/guides/google-calendar/">Google Calendar</a></li>
	<li id="menu-item-190157" class="menu-item menu-item-type-taxonomy menu-item-object-ninetofive_guides menu-item-190157"><a href="https://9to5google.com/guides/google-keep/">Google Keep</a></li>
	<li id="menu-item-190156" class="menu-item menu-item-type-taxonomy menu-item-object-ninetofive_guides menu-item-190156"><a href="https://9to5google.com/guides/google-drive/">Google Drive</a></li>
	<li id="menu-item-190153" class="menu-item menu-item-type-taxonomy menu-item-object-ninetofive_guides menu-item-190153"><a href="https://9to5google.com/guides/google-docs/">Google Docs</a></li>
</ul>
</li>
<li id="menu-item-145661" class="menu-item menu-item-type-taxonomy menu-item-object-ninetofive_guides menu-item-has-children menu-item-145661"><a href="https://9to5google.com/guides/youtube/">YouTube</a>
<ul class="sub-menu">
	<li id="menu-item-502609" class="menu-item menu-item-type-taxonomy menu-item-object-ninetofive_guides menu-item-502609"><a href="https://9to5google.com/guides/youtube/">YouTube</a></li>
	<li id="menu-item-502600" class="menu-item menu-item-type-taxonomy menu-item-object-ninetofive_guides menu-item-502600"><a href="https://9to5google.com/guides/youtube-music/">YouTube Music</a></li>
	<li id="menu-item-502601" class="menu-item menu-item-type-taxonomy menu-item-object-ninetofive_guides menu-item-502601"><a href="https://9to5google.com/guides/youtube-tv/">YouTube TV</a></li>
</ul>
</li>
<li id="menu-item-387594" class="menu-item menu-item-type-taxonomy menu-item-object-ninetofive_guides menu-item-387594"><a href="https://9to5google.com/guides/google-stadia/">Stadia</a></li>
<li id="menu-item-190122" class="menu-item menu-item-type-taxonomy menu-item-object-ninetofive_guides menu-item-has-children menu-item-190122"><a href="https://9to5google.com/guides/alphabet/">Alphabet</a>
<ul class="sub-menu">
	<li id="menu-item-190126" class="menu-item menu-item-type-taxonomy menu-item-object-ninetofive_guides menu-item-190126"><a href="https://9to5google.com/guides/waymo/">Waymo</a></li>
	<li id="menu-item-190127" class="menu-item menu-item-type-taxonomy menu-item-object-ninetofive_guides menu-item-190127"><a href="https://9to5google.com/guides/verily-life-sciences/">Verily Life Sciences</a></li>
	<li id="menu-item-190138" class="menu-item menu-item-type-taxonomy menu-item-object-ninetofive_guides menu-item-190138"><a href="https://9to5google.com/guides/deepmind/">DeepMind</a></li>
	<li id="menu-item-190142" class="menu-item menu-item-type-taxonomy menu-item-object-ninetofive_guides menu-item-190142"><a href="https://9to5google.com/guides/google-ventures/">Google Ventures</a></li>
	<li id="menu-item-190145" class="menu-item menu-item-type-taxonomy menu-item-object-ninetofive_guides menu-item-190145"><a href="https://9to5google.com/guides/google-fiber/">Google Fiber</a></li>
	<li id="menu-item-190147" class="menu-item menu-item-type-taxonomy menu-item-object-ninetofive_guides menu-item-190147"><a href="https://9to5google.com/guides/access-and-energy/">Access &amp; Energy</a></li>
	<li id="menu-item-190137" class="menu-item menu-item-type-taxonomy menu-item-object-ninetofive_guides menu-item-190137"><a href="https://9to5google.com/guides/calico/">Calico</a></li>
</ul>
</li>
<li id="menu-item-190188" class="menu-item menu-item-type-taxonomy menu-item-object-ninetofive_featured menu-item-190188"><a href="https://9to5google.com/feature/videos/">Videos</a></li>
<li id="menu-item-387671" class="menu-item menu-item-type-taxonomy menu-item-object-ninetofive_featured menu-item-387671"><a href="https://9to5google.com/feature/review/">Reviews</a></li>
</ul>					</nav>
					<!-- .primary-menu -->

					<div class="header-right-area">

						<button class="main-menu-toggle js-button" id="js-main-menu-toggle" aria-expanded="false" aria-controls="primary-menu">
									<svg class="ninetofive-icon hamburger js-regular-icon" aria-hidden="true">
									<use
				xlink:href="https://9to5google.com/wp-content/themes/9to5-2015/images/svg-sprite-2020.svg?ver=1666194751#ninetofive-icon-hamburger"/>
		</svg>
											<svg class="ninetofive-icon cross js-expanded-icon" aria-hidden="true">
									<use
				xlink:href="https://9to5google.com/wp-content/themes/9to5-2015/images/svg-sprite-2020.svg?ver=1666194751#ninetofive-icon-cross"/>
		</svg>
									<span class="screen-reader-text">Toggle main menu</span>
						</button>

						<div class="header-social" id="js-header-social">
							<a href="https://www.youtube.com/c/9to5google" title="View 9to5 on YouTube">
		<svg class="ninetofive-icon youtube " aria-hidden="true">
									<use
				xlink:href="https://9to5google.com/wp-content/themes/9to5-2015/images/svg-sprite-2020.svg?ver=1666194751#ninetofive-icon-youtube"/>
		</svg>
		</a>
<a href="https://www.facebook.com/9to5Google/" title="Like us on Facebook">
		<svg class="ninetofive-icon facebook " aria-hidden="true">
									<use
				xlink:href="https://9to5google.com/wp-content/themes/9to5-2015/images/svg-sprite-2020.svg?ver=1666194751#ninetofive-icon-facebook"/>
		</svg>
		</a>
<a href="http://twitter.com/9to5google" title="Follow us on Twitter">
		<svg class="ninetofive-icon twitter " aria-hidden="true">
									<use
				xlink:href="https://9to5google.com/wp-content/themes/9to5-2015/images/svg-sprite-2020.svg?ver=1666194751#ninetofive-icon-twitter"/>
		</svg>
		</a>
<a href="http://instagram.com/9to5google" title="Follow us on Instagram">
		<svg class="ninetofive-icon instagram " aria-hidden="true">
									<use
				xlink:href="https://9to5google.com/wp-content/themes/9to5-2015/images/svg-sprite-2020.svg?ver=1666194751#ninetofive-icon-instagram"/>
		</svg>
		</a>
<a href="https://itunes.apple.com/us/podcast/alphabet-scoop/id1359922601?mt=2" title="Subscribe to our weekly podcast">
		<svg class="ninetofive-icon podcast " aria-hidden="true">
									<use
				xlink:href="https://9to5google.com/wp-content/themes/9to5-2015/images/svg-sprite-2020.svg?ver=1666194751#ninetofive-icon-podcast"/>
		</svg>
		</a>
<div class="header-social-more" id="js-header-social-more" aria-hidden="true"><a href="https://apple.news/TMzMaigopSFChmI1nDK60mg" title="View 9to5 on Apple News">
		<svg class="ninetofive-icon applenews " aria-hidden="true">
									<use
				xlink:href="https://9to5google.com/wp-content/themes/9to5-2015/images/svg-sprite-2020.svg?ver=1666194751#ninetofive-icon-applenews"/>
		</svg>
		</a>
<a href="https://b.smartnews.be/r/8GkJ3uZKPl1eorSk" title="View 9to5 on SmartNews">
		<svg class="ninetofive-icon smartnews " aria-hidden="true">
									<use
				xlink:href="https://9to5google.com/wp-content/themes/9to5-2015/images/svg-sprite-2020.svg?ver=1666194751#ninetofive-icon-smartnews"/>
		</svg>
		</a>
<a href="https://flipboard.com/@9to5google" title="View 9to5 on FlipBoard">
		<svg class="ninetofive-icon flipboard " aria-hidden="true">
									<use
				xlink:href="https://9to5google.com/wp-content/themes/9to5-2015/images/svg-sprite-2020.svg?ver=1666194751#ninetofive-icon-flipboard"/>
		</svg>
		</a>
<a href="http://linkedin.com/company/9to5google" title="View 9to5 on LinkedIn">
		<svg class="ninetofive-icon linkedin " aria-hidden="true">
									<use
				xlink:href="https://9to5google.com/wp-content/themes/9to5-2015/images/svg-sprite-2020.svg?ver=1666194751#ninetofive-icon-linkedin"/>
		</svg>
		</a>
<a href="https://9to5google.com/push/" title="Signup for Safari Notifications">
		<svg class="ninetofive-icon pushup " aria-hidden="true">
									<use
				xlink:href="https://9to5google.com/wp-content/themes/9to5-2015/images/svg-sprite-2020.svg?ver=1666194751#ninetofive-icon-pushup"/>
		</svg>
		</a>
<a href="https://eepurl.com/bdw6AH" title="Signup for our email list">
		<svg class="ninetofive-icon email " aria-hidden="true">
									<use
				xlink:href="https://9to5google.com/wp-content/themes/9to5-2015/images/svg-sprite-2020.svg?ver=1666194751#ninetofive-icon-email"/>
		</svg>
		</a>
</div>							<button aria-expanded="false" aria-controls="js-header-social-more" id="js-button-social" class="js-button button-social-toggle">
										<svg class="ninetofive-icon dots-expand " aria-hidden="true">
									<use
				xlink:href="https://9to5google.com/wp-content/themes/9to5-2015/images/svg-sprite-2020.svg?ver=1666194751#ninetofive-icon-dots-expand"/>
		</svg>
										<span class="screen-reader-text">More social networks</span>
							</button>
						</div>
						<!-- .header-social -->

						<div class="header-icon-links">
							
<a href='https://9to5google.com/contact/' class='has-tooltip'>		<svg class="ninetofive-icon feedback " aria-hidden="true">
									<use
				xlink:href="https://9to5google.com/wp-content/themes/9to5-2015/images/svg-sprite-2020.svg?ver=1666194751#ninetofive-icon-feedback"/>
		</svg>
		<span class='header-tooltip'>Submit a Tip / Contact Us</span></a>
</li>

<a href='http://trade-in.9to5google.com/' class='has-tooltip'>		<svg class="ninetofive-icon cashback " aria-hidden="true">
									<use
				xlink:href="https://9to5google.com/wp-content/themes/9to5-2015/images/svg-sprite-2020.svg?ver=1666194751#ninetofive-icon-cashback"/>
		</svg>
		<span class='header-tooltip'>Trade In</span></a>
</li>
						</div>
						<!-- .header-icon-links -->
							<button id="dark-mode-toggle" class="button-darkmode-toggle" onclick="darkmode.toggle();">
		 		<svg class="ninetofive-icon dark-mode js-regular-icon" aria-hidden="true">
									<use
				xlink:href="https://9to5google.com/wp-content/themes/9to5-2015/images/svg-sprite-2020.svg?ver=1666194751#ninetofive-icon-dark-mode"/>
		</svg>
				<span class="screen-reader-text">Toggle dark mode</span>
	</button>
						<div class="header-search">
							
<form role="search" class="search-form" method="get" action="https://9to5google.com/" id="js-search-form">
	<label class="search-label">
		<span class="screen-reader-text">Search</span>
		<input type="search" placeholder="search" name="s" class="searchInput" value="">
	</label>
	<button type="submit" class="search-submit">
				<svg class="ninetofive-icon search " aria-hidden="true">
									<use
				xlink:href="https://9to5google.com/wp-content/themes/9to5-2015/images/svg-sprite-2020.svg?ver=1666194751#ninetofive-icon-search"/>
		</svg>
				<span class="screen-reader-text">Search</span>
	</button>
</form>
							<button aria-expanded="false" aria-controls="js-search-form" id="js-button-search" class="js-button button-search-toggle">
										<svg class="ninetofive-icon search js-regular-icon" aria-hidden="true">
									<use
				xlink:href="https://9to5google.com/wp-content/themes/9to5-2015/images/svg-sprite-2020.svg?ver=1666194751#ninetofive-icon-search"/>
		</svg>
												<svg class="ninetofive-icon cross js-expanded-icon" aria-hidden="true">
									<use
				xlink:href="https://9to5google.com/wp-content/themes/9to5-2015/images/svg-sprite-2020.svg?ver=1666194751#ninetofive-icon-cross"/>
		</svg>
										<span class="screen-reader-text">Toggle search</span>
							</button>
						</div>
						<!-- .header-search -->

					</div>
					<!-- .header-right-area -->

				</div>
				<!-- .site-header-inner -->

				<div class="site-switcher" id="js-site-switcher" aria-hidden="true">
					<ul class="site-switcher-list">
<li><a href='https://9to5mac.com'>		<svg class="ninetofive-icon ninetofive-mac " aria-hidden="true">
									<use
				xlink:href="https://9to5google.com/wp-content/themes/9to5-2015/images/svg-sprite-2020.svg?ver=1666194751#ninetofive-icon-ninetofive-mac"/>
		</svg>
		<span class='screen-reader-text'>9to5Mac</span></a></li>
</li>

<li><a href='https://9to5toys.com'>		<svg class="ninetofive-icon ninetofive-toys " aria-hidden="true">
									<use
				xlink:href="https://9to5google.com/wp-content/themes/9to5-2015/images/svg-sprite-2020.svg?ver=1666194751#ninetofive-icon-ninetofive-toys"/>
		</svg>
		<span class='screen-reader-text'>9to5Toys</span></a></li>
</li>

<li><a href='https://electrek.co'><div class="ninetofive-icon ninetofive-electrek"></div><span class='screen-reader-text'>Electrek</span></a></li>
</li>

<li class='menu-item-dronedj'><a href='https://dronedj.com'><div class="ninetofive-icon ninetofive-dronedj"></div><span class='screen-reader-text'>DroneDJ</span></a></li>
</li>

<li><a href='https://spaceexplored.com'>		<svg class="ninetofive-icon spaceexplored-logo " aria-hidden="true">
									<use
				xlink:href="https://9to5google.com/wp-content/themes/9to5-2015/images/svg-sprite-2020.svg?ver=1666194751#ninetofive-icon-spaceexplored-logo"/>
		</svg>
		<span class='screen-reader-text'>Space Explored</span></a></li>
</li>

<li class='site-switcher-text-only'><a href='https://9to5mac.com/about/'>About</a></li>
</li>

<li class='site-switcher-text-only'><a href='https://9to5mac.com/privacy/'>Privacy</a></li>
</li>
</ul>				</div>
				<!-- .site-switcher -->

			</header>
			<!-- .site-header -->

			<div class="site-header-placeholder"></div>

			<div class="order-control">

									<div class="th32d150c9 ad-container ad-container--leaderboard order-control__mobile-top">
						<div id="div-gpt-ad-1436850350386-0" class="inlinead"></div>
<script type='text/javascript'>
	// Make sure that nineto5ads exists, it will load ad once google tag exists
	window.nineto5ads = window.nineto5ads|| [];
	window.nineto5ads.push(function() {
		apstag.fetchBids({
			slots: [{
				slotID: "div-gpt-ad-1436850350386-0",
				slotName: "\/1049447\/9to5google-728x90-TopMain-R",
				sizes: [[728,90]]
			}],
			timeout: 2e3
			}, function(bids) {
				googletag.display("div-gpt-ad-1436850350386-0");
				apstag.setDisplayBids();
				googletag.pubads().refresh([adslot]);
		});
	});
</script>					</div>
					

					<div id="div-gpt-ad-signal" style="width: 0; height: 0;">
		<script>
			if ( document.cookie.indexOf('scroll0=') < 0 ) {
				googletag.cmd.push(function() { googletag.display('div-gpt-ad-signal'); });
			}
		</script>
	</div>
				</div><!-- .order-control -->
			
		<div id="content">
		

					<div class="news-feed-header">
				<div class="elastic-container">
					<div class="currently-reading">
						<p>Today</p>
					</div><!-- .currently-reading -->


				</div><!-- .elastic-container -->
			</div><!-- .news-feed-header -->
			<div id="news-placeholder"></div>

		<article class="post-content">
				<div class="elastic-container">
					<h1 class="post-title"><a href="https://9to5google.com/2022/10/20/google-assistant-home-commands/">Google using AI to improve accuracy of Assistant smart home commands, but warns of changes</a></h1>
					<div class="post-meta">
						<p class="byline">
							<a href="https://9to5google.com/author/technacity/">
								<span>Abner Li</span>
							</a>
						</p>
						<p class="time-twitter">
							- Oct. 20th 2022 11:56 am PT
								<div class="icon-twitter"></div>
								<p><a href="https://twitter.com/intent/follow?screen_name=technacity&original_referer=https%3A%2F%2F9to5google.com" target="_blank" class="twitter-handle">@technacity</a></p>
						</p>


							<div class="tags">
								<div class="post-cats">
								</div><!-- .post-cats -->
							</div><!-- .tags -->
					</div><!-- .post-meta -->
				</div><!-- .elastic-container -->
				<div class="feat-image-wrapper">
						<div class="feat-image wide js-single-top-img">
							<img src="https://9to5google.com/wp-content/uploads/sites/4/2019/01/google_assistant_7.jpg?quality=82&#038;strip=all&#038;w=1600" srcset="https://i0.wp.com/9to5google.com/wp-content/uploads/sites/4/2019/01/google_assistant_7.jpg?w=320&amp;quality=82&amp;strip=all&amp;ssl=1 320w, https://i0.wp.com/9to5google.com/wp-content/uploads/sites/4/2019/01/google_assistant_7.jpg?w=640&amp;quality=82&amp;strip=all&amp;ssl=1 640w, https://i0.wp.com/9to5google.com/wp-content/uploads/sites/4/2019/01/google_assistant_7.jpg?w=1024&amp;quality=82&amp;strip=all&amp;ssl=1 1024w, https://i0.wp.com/9to5google.com/wp-content/uploads/sites/4/2019/01/google_assistant_7.jpg?w=1500&amp;quality=82&amp;strip=all&amp;ssl=1 1500w, https://i0.wp.com/9to5google.com/wp-content/uploads/sites/4/2019/01/google_assistant_7.jpg?w=2000&amp;quality=82&amp;strip=all&amp;ssl=1 2000w, https://i0.wp.com/9to5google.com/wp-content/uploads/sites/4/2019/01/google_assistant_7.jpg?w=2500&amp;quality=82&amp;strip=all&amp;ssl=1 2500w" width="1600" height="800" alt="Google Home Assistant pretty please" loading="lazy">
						</div><!-- .feat-image -->
					<div class="post-social-mobile">
						<a href="https://9to5google.com/2022/10/20/google-assistant-home-commands/#comments" class="comments">4 Comments</a>
						<div class="sharedaddy sd-sharing-enabled"><div class="robots-nocontent sd-block sd-social sd-social-text sd-sharing"><div class="sd-content"><ul><li class="share-facebook"><a rel="nofollow noopener noreferrer" data-shared="sharing-facebook-533122" class="share-facebook sd-button no-icon" href="https://9to5google.com/2022/10/20/google-assistant-home-commands/?share=facebook" target="_blank" title="Click to share on Facebook" ><span>Facebook</span></a></li><li class="share-twitter"><a rel="nofollow noopener noreferrer" data-shared="sharing-twitter-533122" class="share-twitter sd-button no-icon" href="https://9to5google.com/2022/10/20/google-assistant-home-commands/?share=twitter" target="_blank" title="Click to share on Twitter" ><span>Twitter</span></a></li><li class="share-pinterest"><a rel="nofollow noopener noreferrer" data-shared="sharing-pinterest-533122" class="share-pinterest sd-button no-icon" href="https://9to5google.com/2022/10/20/google-assistant-home-commands/?share=pinterest" target="_blank" title="Click to share on Pinterest" ><span>Pinterest</span></a></li><li class="share-linkedin"><a rel="nofollow noopener noreferrer" data-shared="sharing-linkedin-533122" class="share-linkedin sd-button no-icon" href="https://9to5google.com/2022/10/20/google-assistant-home-commands/?share=linkedin" target="_blank" title="Click to share on LinkedIn" ><span>LinkedIn</span></a></li><li class="share-reddit"><a rel="nofollow noopener noreferrer" data-shared="" class="share-reddit sd-button no-icon" href="https://9to5google.com/2022/10/20/google-assistant-home-commands/?share=reddit" target="_blank" title="Click to share on Reddit" ><span>Reddit</span></a></li><li class="share-end"></li></ul></div></div></div>
					</div><!-- .post-social-mobile -->
				</div><!-- .feat-image-wrapper -->
				<div class="elastic-container">

					<div class="post-body">
						<p>Using voice commands to control smart home devices is very common, and something that Google Assistant is about to <a href="https://www.googlenestcommunity.com/t5/Blog/Better-control-of-your-smart-devices-with-Google-Assistant/ba-p/263916">get better</a> at&nbsp;through the use of AI.</p>
<p><span id="more-533122"></span><ins class="adsbygoogle author_ad"
			style="display:block;"
			data-ad-host="ca-host-pub-5506057612223327"
			data-ad-client="ca-pub-7114551592991368"
			data-ad-format="auto"></ins>
		<script>
			(adsbygoogle = window.adsbygoogle || []).push({});
		</script></p>
<p>Google says it &#8220;worked hard to apply state of the art improvements in AI to how Assistant understands your commands to control your home.&#8221; Specifically, large scale neural networks were leveraged to &#8220;learn from examples to predict the most accurate action to take given a user&#8217;s command.&#8221;</p>
<p>The first Google Assistant upgrade is &#8220;better device recognition by type&#8221;:</p>
<blockquote class="wp-block-quote">
<p>For commands like “Turn the fan off” or “Kitchen lights on”, Assistant is now able to better match your request to the devices in your home based on their type and which room the device you’re talking to is in. </p>
</blockquote>
<p>Assistant is now also able to better interpret commands that don&#8217;t feature the exact device name. This includes when it only hears partial or approximate matches:</p>
<blockquote class="wp-block-quote">
<p>For example, “Turn the lamp off” may match to a device in your home named “bedroom lamp”, and “Turn on the stair light” will better match a light named “stairs”.</p>
</blockquote>
<p>Google&#8217;s final improvement makes Assistant &#8220;better able to determine what specific action to take on your device and where that action should happen.&#8221;</p>
<blockquote class="wp-block-quote">
<p>For example, “Have the Roomba clean the kitchen, living room, and dining room” is now able to more accurately understand the specific areas of your home you are referring to.</p>
</blockquote>
<p>These three changes to Google Assistant means that your existing smart home commands &#8220;may change from what you’re used to, and it’s even possible that some commands that worked in the past may no longer work.&#8221;</p>
<p>Google says it conducted &#8220;extensive testing&#8221; and is slowly rolling the changes to &#8220;groups of users at different times, and want to monitor outcomes along the way so that we can refine our models appropriately.&#8221;&nbsp;</p>
<p>The company is actively asking users to submit examples of commands that no longer work in the Google Nest Community&#8217;s <a href="https://www.googlenestcommunity.com/t5/Home-Automation/Submit-feedback-on-Google-Assistant-voice-commands/td-p/264050">Home Automation forum</a>, as its work continues:</p>
<blockquote class="wp-block-quote">
<p>We’re very excited about the transition to AI for the control of smart devices and the improvements to Assistant that it will enable in the future. Our team will continue working hard to ensure Assistant is able to understand you the way you naturally and most comfortably speak.</p>
</blockquote>
<h2 id="h-more-on-google-assistant">More on Google Assistant:</h2>
<ul>
<li><a href="https://9to5google.com/2022/10/04/google-home-app-redesign/">Here’s the thoroughly rebuilt and redesigned Google Home app&nbsp;[Gallery]</a></li>
<li><a href="https://9to5google.com/2022/10/12/google-home-smartthings-matter/">Google Home and Samsung SmartThings will use Matter to share control of your smart home</a></li>
<li><a href="https://9to5google.com/2022/10/19/google-home-device-trigger-routines/">Google Home app starts rolling out device triggers for Assistant routines [Gallery]</a></li>
<li><a href="https://9to5google.com/2022/10/09/pixel-tablet-ui-android/">A look at the Pixel Tablet UI: Android, Smart Display, Google Home, and Camera [Gallery]</a></li>
</ul>
	<div class="google-news-link">
		<p class="mb-0"><a target="_blank" rel="nofollow" href="https://news.google.com/publications/CAAqBwgKMMqA-Qow-c_gAg?hl=en-US&#038;gl=US&#038;ceid=US:en">
			<em>Add 9to5Google to your Google News feed.</em>&nbsp;
					<svg class="ninetofive-icon google-news-follow " height="30" width="166" aria-hidden="true">
							<title>Google News</title>
										<desc>google-news</desc>
						<use
				xlink:href="https://9to5google.com/wp-content/themes/9to5-2015/images/svg-sprite-2020.svg?ver=1666194751#ninetofive-icon-google-news-follow"/>
		</svg>
				</a></p>
	</div>
	<div class="ad-disclaimer-container"><p class="disclaimer-affiliate"><em>FTC: We use income earning auto affiliate links.</em> <a href="https://9to5mac.com/about/#affiliate">More.</a></p><!-- post ad --></div><div id="after_disclaimer_placement"></div><hr /><p style="text-align: center"><a href="https://www.youtube.com/c/9to5google?sub_confirmation=1"><i>Check out 9to5Google on YouTube for more news:</i></a></p><!-- youtube embed --><div class="fluid-width-video-wrapper"><iframe title="Recent Videos" src="https://www.youtube.com/embed/B2gqUTp_Ohc?playlist=l1qdNuUY3lk,GqCOSeOPDSE,xravTup2FPw,v3DvobdAMis,nuTf7jkQsKc,xe6Z3GVUzsU,K3WyPNte6xI,7TY8VE2ANM8,AS97FhAcbps" frameborder="0" allow="accelerometer; autoplay; encrypted-media; gyroscope; picture-in-picture" allowfullscreen width="1000" height="563"></iframe></div>
					</div><!-- .post-body -->


						<div class="visitor-promo" data-nosnippet="true">You’re reading 9to5Google — experts who break news about Google and its surrounding ecosystem, day after day. Be sure to check out <a href="http://9to5google.com/">our homepage</a> for all the latest news, and follow 9to5Google on <a href="http://twitter.com/9to5google">Twitter</a>, <a href="http://facebook.com/9to5google">Facebook</a>, and <a href="https://www.linkedin.com/company/9to5google.com/">LinkedIn</a> to stay in the loop. Don’t know where to start? Check out our <a href="https://9to5google.com/feature/exclusive/">exclusive stories</a>, <a href="https://9to5google.com/guides/reviews/">reviews</a>, <a href="https://9to5google.com/guides/how-to/">how-tos</a>, and <a href="https://www.youtube.com/9to5google">subscribe to our YouTube channel</a></div>
				</div><!-- .elastic-container -->

				<div class="elastic-container">
					<div class="related-guides-container">
						<h1>Guides</h1>
						<div class="related-guides-list">
							<div class="related-guides-item">
								<a href="https://9to5google.com/guides/google-assistant/">
								<div class="related-guides-item-image">
									<img src="https://9to5google.com/wp-content/uploads/sites/4/2019/02/google-assistant-hq-trivia.png?w=290&#038;h=145&#038;crop=1" title="Google Assistant" alt="Google Assistant" loading="lazy" />
								</div>
								<h3>Google Assistant</h3>
								<p>Assistant is Google&#039;s personal assistant that is capable of answering questions, performing automated tasks, and more</p>
								</a>
							</div>
							<div class="related-guides-item">
								<a href="https://9to5google.com/guides/google-home/">
								<div class="related-guides-item-image">
									<img src="https://9to5google.com/wp-content/uploads/sites/4/2016/11/google-home-picture.jpeg?quality=82&#038;strip=all&#038;w=290&#038;h=145&#038;crop=1" title="Google Home" alt="Google Home" loading="lazy" />
								</div>
								<h3>Google Home</h3>
								<p></p>
								</a>
							</div>
						</div>
							<div class="post-cats"></div>
							<!-- .post-cats -->
					</div>
				</div>

			<div class="elastic-container">
				<div class="author-bio-container">
					<h2 class="bio-title">About the Author</h2>
					<div class="author-bio">
							<div class="author-bio-details">
								<a href="https://9to5google.com/author/technacity/">
									<img src="https://secure.gravatar.com/avatar/ba5acd965e31e2bfe2fbd4e37d8f68b9?s=128&#038;d=mm&#038;r=r" class="author-gravatar" loading="lazy">
								</a>
								<h3>
									<a href="https://9to5google.com/author/technacity/">
										<span>Abner Li</span>
									</a>
								</h3>

									<p class="twitter">
										<a href="https://twitter.com/intent/follow?screen_name=technacity&original_referer=https%3A%2F%2F9to5google.com" target="_blank" class="twitter-handle"><span class="icon-twitter"></span>@technacity</a>
									</p>

								<div class="author-excerpt">
									<p>Editor-in-chief. Interested in the minutiae of Google and Alphabet. Tips/talk: abner@9to5g.com</p>

								</div>
						</div>
					</div>
				</div>
			</div>




				<div class="ad-container ad-container--river"><div id="div-gpt-ad-1437016474156-0-533122" class="inlinead"></div></div>

		</article><!-- .post-content -->

	<aside class="trending-wrapper"><div class="trending-items trending-items--single">			<a href="https://9to5google.com/2022/10/20/new-google-phone-messages-icons/" rel="bookmark">
				<div class="trending-grid-item">
										<div class="img-wrap" style="background-image: url(https://9to5google.com/wp-content/uploads/sites/4/2022/10/new-google-messages-phone-contacts-icon.jpeg?quality=82&#038;strip=all&#038;w=1600);"></div>
					
					<p class="trending-excerpt">Here are the new Google Phone &amp; Messages icons</p>
				</div>
			</a>
						<a href="https://9to5google.com/2022/10/20/google-my-ad-center-rolling-out/" rel="bookmark">
				<div class="trending-grid-item">
										<div class="img-wrap" style="background-image: url(https://9to5google.com/wp-content/uploads/sites/4/2022/10/Google-My-Ad-Center-Hub-cover.jpeg?quality=82&#038;strip=all&#038;w=1600);"></div>
					
					<p class="trending-excerpt">Google &#039;My Ad Center&#039; lets people customize their ads</p>
				</div>
			</a>
						<a href="https://9to5google.com/2022/10/20/google-messages-youtube-pip/" rel="bookmark">
				<div class="trending-grid-item">
										<div class="img-wrap" style="background-image: url(https://9to5google.com/wp-content/uploads/sites/4/2022/10/new-google-messages-icon-1.jpeg?quality=82&#038;strip=all&#038;w=1600);"></div>
					
					<p class="trending-excerpt">Messages: YouTube PiP, free RCS over inflight Wi-Fi</p>
				</div>
			</a>
						<a href="https://9to5google.com/2022/10/20/searching-for-stadia-prelude/" rel="bookmark">
				<div class="trending-grid-item">
										<div class="img-wrap" style="background-image: url(https://9to5google.com/wp-content/uploads/sites/4/2021/05/google_stadia_logo_controller_1.jpg?quality=82&#038;strip=all&#038;w=1600);"></div>
					
					<p class="trending-excerpt">Searching for Stadia: Prelude, remember what was lost</p>
				</div>
			</a>
			</div></aside>
					<div id="comments" class="comments-area post-body">
				<div class="elastic-container">
					
<script
	async
	src="https://launcher.spot.im/spot/sp_rVSSRN5u"
	data-theme="light"
	data-spotim-module="spotim-launcher">
</script>

<div
	data-spotim-module="conversation"
	data-post-url="https://9to5google.com/2022/10/20/google-assistant-home-commands/"
	data-post-id="533122">
</div>

<div data-spotim-module="pitc"></div>
				</div><!-- .elastic-container -->
			</div><!-- #comments.comments-area -->
			</div><!-- #content -->


	<div style="text-align:center">
		<a href="https://wpvip.com/?utm_source=vip_powered_wpcom&#038;utm_medium=web&#038;utm_campaign=VIP%20Footer%20Credit&#038;utm_term=9to5google.com" rel="generator nofollow" class="powered-by-wpcom"><img src="https://9to5google.com/wp-content/mu-plugins/vip-helpers/images/vip-powered-light-small.png?ver=20220317" width="187" height="26" alt="Powered by WordPress VIP" /></a>	</div>

		<script type="text/javascript">
		//<![CDATA[
		var ninetofiveInfiniteScroll = {"settings":{"id":"content","ajaxurl":"https:\/\/9to5google.com\/?infinity=scrolling","currentday":"20.10.22","order":"DESC","offset":0,"history":{"host":"9to5google.com","path":"\/2022\/10\/20\/google-assistant-home-commands\/page\/%d\/","use_trailing_slashes":true,"parameters":""},"query_args":{"page":0,"year":2022,"monthnum":10,"day":20,"name":"google-assistant-home-commands","error":"","m":"","p":0,"post_parent":"","subpost":"","subpost_id":"","attachment":"","attachment_id":0,"pagename":"","page_id":0,"second":"","minute":"","hour":"","w":0,"category_name":"","tag":"","cat":"","tag_id":"","author":"","author_name":"","feed":"","tb":"","paged":0,"meta_key":"","meta_value":"","preview":"","s":"","sentence":"","title":"","fields":"","menu_order":"","embed":"","category__in":[],"category__not_in":[],"category__and":[],"post__in":[],"post__not_in":[],"post_name__in":[],"tag__in":[],"tag__not_in":[],"tag__and":[],"tag_slug__in":[],"tag_slug__and":[],"post_parent__in":[],"post_parent__not_in":[],"author__in":[],"author__not_in":[],"ignore_sticky_posts":false,"suppress_filters":false,"cache_results":false,"update_post_term_cache":true,"lazy_load_term_meta":true,"update_post_meta_cache":true,"post_type":"","posts_per_page":48,"nopaging":false,"comments_per_page":"75","no_found_rows":false,"order":"DESC"},"last_post_date":"2022-10-20 11:56:48","dfp_id":"1049447","post_id":533122,"stats":"blog=146091833&host=9to5google.com&v=ext&j=1:11.4&x_pagetype=infinite-jetpack","google_analytics":false}};
		//]]>
	</script>
	<script>
	(function(a,c,d,e){if(!a[c]){var b=a[c]={};b[d]=[];b[e]=function(a){b[d].push(a)}}})(window,'Scroll','_q','do');
	Scroll.config = {
		detected: document.cookie.indexOf("scroll0=") > -1
	};
	</script>
	<script id='loop-template' type='x-tmpl-mustache'>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</script><script id='content-template' type='x-tmpl-mustache'><div class="extended">
	{{{ post_content }}}

	{{# product_link }}
		{{# product_price }}
			<div class="product_cta_lower">
				<a href="{{ product_link }}" class="product-button{{# savings_amount }} has-savings{{/ savings_amount }}" target="_blank">
					{{# savings_amount }}
						<span class="product-savings-amount">Get this deal<br/>{{ savings_amount }}</span>
					{{/ savings_amount }}
					<span class="product-price">{{ product_price }}</span>
				</a>
			</div>
		{{/ product_price }}
	{{/ product_link }}
	
	<div class="extended-comment-cta">
	  <a href="{{ permalink }}#comments" class="comments">{{{ comment_count }}}</a>
	</div>

</div><!-- .extended -->
</script><script id='aside-template' type='x-tmpl-mustache'><div class="post-body">

	{{# featured_image }}
		{{# product_link }}
			{{# product_price }}
				<div class="product_cta_image">
					<a href="{{ product_link }}" class="product-button{{# savings_amount }} has-savings{{/ savings_amount }}" target="_blank">
						{{# savings_amount }}
							<span class="product-savings-amount">Get this deal<br/>{{ savings_amount }}</span>
						{{/ savings_amount }}
						<span class="product-price">{{ product_price }}</span>
					</a>
				</div>
			{{/ product_price }}
		{{/ product_link }}

		<div class="feat-image-wrapper">
			{{# featured_image }}
				<div class="feat-image{{ image_class }}"><img src="{{featured_image}}" alt="{{ featured_image_alt }}" srcset="{{ srcset }}" loading="lazy"></div>
			{{/ featured_image }}
		</div><!-- .feat-image-wrapper -->
		<div class="post-social-mobile">
			<a href="{{permalink}}#comments" class="comments">{{{comment_count}}}</a>
			{{{share_buttons}}}
		</div><!-- .post-social-mobile -->

	{{/ featured_image }}
	{{{post_content}}}
	{{# meta.display_author_ad }}
		{{{ meta.author_ad }}}
	{{/ meta.display_author_ad }}

	{{# product_link }}
		{{# product_price }}
			<div class="product_cta_lower">
				<a href="{{ product_link }}" class="product-button{{# savings_amount }} has-savings{{/ savings_amount }}" target="_blank">
					{{# savings_amount }}
						<span class="product-savings-amount">Get this deal<br/>{{ savings_amount }}</span>
					{{/ savings_amount }}
					<span class="product-price">{{ product_price }}</span>
				</a>
			</div>
		{{/ product_price }}
	{{/ product_link }}

	<div class="post-cats">
		{{# featured_tags }}
		<a href="{{tag_link}}" title="View all posts in {{tag_name}}" class="featured_tag">{{tag_name}}</a>
		{{/ featured_tags }}
		{{# categories }}
			<a href="{{cat_link}}" title="View all posts in {{cat_name}}">{{cat_name}}</a>
		{{/ categories }}
	</div><!-- .post-cats -->

	<div class="extended-comment-cta">
		<a href="{{ permalink }}#comments" class="comments">{{{ comment_count }}}</a>
	</div>

</div><!-- .post-body -->
</script>			<script>
		var options = {
			saveInCookies: true, // default: true,
			autoMatchOsTheme: true // default: true
		}

		const darkmode = new Darkmode(options);
	</script>
<script id='mediaelement-js-extra'>
var _wpmejsSettings = {"pluginPath":"\/wp-includes\/js\/mediaelement\/","classPrefix":"mejs-","stretching":"responsive"};
</script>
<script id='ninetofive-js-extra'>
var globalJSVars = {"ajaxurl":"https:\/\/9to5google.com\/wp-admin\/admin-ajax.php"};
</script>
<script id='pushup-js-extra'>
var PushUpNotificationSettings = {"domain":"https:\/\/9to5google.com","userID":"1","websitePushID":"web.com.9to5google","webServiceURL":"https:\/\/push.10up.com","prompt":"1"};
</script>
<script type="text/javascript" src="https://9to5google.com/_static/??-eJyVzr0OwjAMBOAXIjVBtKgD4lkgdalL4kSxU1Sent+BgYFuN9x3Orgm4yIrsoIOGFCg1VibzdrWcBRBFRgFQuwwM92yiUVT0WqUFfxHmRg19jRhFYgXQOKemBSNuBy9/6WTL2digVRkKOmJ3um7S+x86fA16WIID2cyJj8vvDMhdzGDKLnLfCKVjz+EvW2axrbbXW3HO+4zeJk=" ></script><script id='mediaelement-core-js-before'>
var mejsL10n = {"language":"en","strings":{"mejs.download-file":"Download File","mejs.install-flash":"You are using a browser that does not have Flash player enabled or installed. Please turn on your Flash player plugin or download the latest version from https:\/\/get.adobe.com\/flashplayer\/","mejs.fullscreen":"Fullscreen","mejs.play":"Play","mejs.pause":"Pause","mejs.time-slider":"Time Slider","mejs.time-help-text":"Use Left\/Right Arrow keys to advance one second, Up\/Down arrows to advance ten seconds.","mejs.live-broadcast":"Live Broadcast","mejs.volume-help-text":"Use Up\/Down Arrow keys to increase or decrease volume.","mejs.unmute":"Unmute","mejs.mute":"Mute","mejs.volume-slider":"Volume Slider","mejs.video-player":"Video Player","mejs.audio-player":"Audio Player","mejs.captions-subtitles":"Captions\/Subtitles","mejs.captions-chapters":"Chapters","mejs.none":"None","mejs.afrikaans":"Afrikaans","mejs.albanian":"Albanian","mejs.arabic":"Arabic","mejs.belarusian":"Belarusian","mejs.bulgarian":"Bulgarian","mejs.catalan":"Catalan","mejs.chinese":"Chinese","mejs.chinese-simplified":"Chinese (Simplified)","mejs.chinese-traditional":"Chinese (Traditional)","mejs.croatian":"Croatian","mejs.czech":"Czech","mejs.danish":"Danish","mejs.dutch":"Dutch","mejs.english":"English","mejs.estonian":"Estonian","mejs.filipino":"Filipino","mejs.finnish":"Finnish","mejs.french":"French","mejs.galician":"Galician","mejs.german":"German","mejs.greek":"Greek","mejs.haitian-creole":"Haitian Creole","mejs.hebrew":"Hebrew","mejs.hindi":"Hindi","mejs.hungarian":"Hungarian","mejs.icelandic":"Icelandic","mejs.indonesian":"Indonesian","mejs.irish":"Irish","mejs.italian":"Italian","mejs.japanese":"Japanese","mejs.korean":"Korean","mejs.latvian":"Latvian","mejs.lithuanian":"Lithuanian","mejs.macedonian":"Macedonian","mejs.malay":"Malay","mejs.maltese":"Maltese","mejs.norwegian":"Norwegian","mejs.persian":"Persian","mejs.polish":"Polish","mejs.portuguese":"Portuguese","mejs.romanian":"Romanian","mejs.russian":"Russian","mejs.serbian":"Serbian","mejs.slovak":"Slovak","mejs.slovenian":"Slovenian","mejs.spanish":"Spanish","mejs.swahili":"Swahili","mejs.swedish":"Swedish","mejs.tagalog":"Tagalog","mejs.thai":"Thai","mejs.turkish":"Turkish","mejs.ukrainian":"Ukrainian","mejs.vietnamese":"Vietnamese","mejs.welsh":"Welsh","mejs.yiddish":"Yiddish"}};
</script>
<script src='https://9to5google.com/wp-includes/js/mediaelement/mediaelement-and-player.min.js?ver=4.2.16' id='mediaelement-core-js'></script>
<script type="text/javascript" src="https://9to5google.com/_static/??-eJzTLy/QzcxLzilNSS3WzyrWz01NyUxMzUnNTc0rQeHo5mamFyWWpOrlZubpZRXr6OPTCJRD5kP12OfaGpqZmRlYWloYW2YBAA79LG0=" ></script>
	<script>
		(function($){
			$(document.body).on('post-load', function(){
				var nodes = document.querySelectorAll('span.dsq-postid');
				for (var i = 0, url; i < nodes.length; i++) {
					var shorturl = nodes[i].getAttribute('rel');
					var new_rel = shorturl ? shorturl.replace( 'https:', 'http:' ) : '';
					nodes[i].parentNode.setAttribute('data-disqus-identifier', new_rel );
					url = nodes[i].parentNode.href.split('#', 1);
					if (url.length == 1) url = url[0];
					else url = url[1];
					nodes[i].parentNode.href = url + '#disqus_thread';
				}

				var DISQUSWIDGETS = window.DISQUSWIDGETS || {};

				if ( Object.keys(DISQUSWIDGETS).length !== 0 && DISQUSWIDGETS.constructor === Object ) {
					DISQUSWIDGETS.getCount({reset: true});
				}
			});
		})(jQuery);
	</script>

	<script type='text/javascript'>
		var secondaryMapping, adslot;

		googletag.cmd.push(function() {
			var mainMapping = googletag.sizeMapping().
				addSize([0, 0], [[320,50],[320,100]]).
				addSize([320, 400], [[320,50],[320,100]]).
				addSize([768, 200], [[468,60],[728,90]]).
				addSize([1050, 200], [[728,90],[970,70],[970,90],[970,250]]).
				build();

			secondaryMapping = googletag.sizeMapping().
				addSize([0, 0], [[300,250]]).
				addSize([320, 400], [[300,250]]).
				addSize([768, 200], [[300,250],[728,90]]).
				addSize([1050, 200], [[300,250],[728,90],[970,90],[970,250]]).
				build();

			adslot = googletag.defineSlot('/1049447/9to5google-728x90-TopMain-R', [[320, 100], [970, 90], [320, 50], [970, 250], [468, 60], [728, 90], [970, 70]], "div-gpt-ad-1436850350386-0").
				defineSizeMapping(mainMapping).
				addService(googletag.pubads());

			googletag.pubads().enableSingleRequest();
			googletag.pubads().collapseEmptyDivs();
			googletag.pubads().disableInitialLoad();
			googletag.enableServices();
		});

		window.nineto5ads = window.nineto5ads|| [];
		window.nineto5ads.forEach(function(ad){
			googletag.cmd.push(ad);
		});

		// Function to generate unique names for slots
		var nextSlotId = 1;
		function generateNextSlotName() {
			var id = nextSlotId++;
			return 'div-gpt-ad-' + id;
		}

		function loadAds( page, dfp_id ) {
			// Bail if it is a Twitter Blue/Scroll user (no ads)
			if ( document.cookie.indexOf( 'scroll0=' ) > -1 ) {
				return;
			}

			var $adsToBeFilled;
			var adSlotsConfig = [];
			var gptSlots = [];

			if ( page === 1 ) {
				$adsToBeFilled = jQuery( '.post-content' ).find( '.inlinead:empty' );
			} else {
				$adsToBeFilled = jQuery( document.getElementById( 'infinite-view-' + ( page - 1 ) ) ).find( '.post-content .inlinead' );
			}

			$adsToBeFilled.each( function() {
				var slotName = generateNextSlotName(),
					slotDiv = document.createElement('div');

				slotDiv.id = slotName; // ID must be the same as slotName
				jQuery( this ).append( slotDiv );

				adSlotsConfig.push( {
					slotID: "\/1049447\/9to5google-300x250-TopSidebarMain-R", //example: 'div-gpt-ad-1475102693815-0'
					slotName: slotName, //example: 12345/box-1
					sizes: [[300, 250], [970, 90], [970, 250], [728, 90]]
				} );
			});

			apstag.fetchBids({
				slots: adSlotsConfig,
				timeout: 2e3
			}, function(bids) {
				googletag.cmd.push( function() {
					adSlotsConfig.forEach( function( slot ) {
						var newSlot = googletag.defineSlot("\/1049447\/9to5google-300x250-TopSidebarMain-R", [[300, 250], [970, 90], [970, 250], [728, 90]], slot.slotName).
							defineSizeMapping( secondaryMapping ).
							addService(googletag.pubads());

						gptSlots.push( newSlot );

						googletag.display( slot.slotName );
					} );

					apstag.setDisplayBids();
					googletag.pubads().refresh( gptSlots );
				});
			});
		}
	</script>
	<script src='https://stats.wp.com/e-202242.js' defer></script>
<script>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:11.4',blog:'146091833',post:'533122',tz:'-7',srv:'9to5google.com',hp:'vip'} ]);
	_stq.push([ 'clickTrackerInit', '146091833', '533122' ]);
</script>
<!-- Tracking Codes -->		<script type="text/javascript">
			var vglnk = {key: 'b8f771eed689587b82c4635131ce08d7'};
			(function(d, t) {
				var s = d.createElement(t);
				s.type = 'text/javascript';
				s.async = true;
				s.src = '//cdn.viglink.com/api/vglnk.js';
				var r = d.getElementsByTagName(t)[0];
				r.parentNode.insertBefore(s, r);
			}(document, 'script'));
		</script>
		<!-- End Tracking Codes -->
	</body>
</html>