<!DOCTYPE html>
<html lang="en-US">
	<head>
				<meta charset="UTF-8" />
		<meta name="viewport" content="width=device-width, initial-scale=1, maximum-scale=1.0, minimal-ui">
				<title>Say goodbye? I say Allo: A brief look at the past, present, and future of Google messaging - 9to5Google</title>
<!-- Jetpack Site Verification Tags -->
<meta name="google-site-verification" content="Htm3pGW8rcBX6wK35FZMBNMbpuieOZ5c8F489axa8nw" />
<meta name="msvalidate.01" content="808CE29E29F1230249D24A893DE871FB" />
		<script src="https://9to5google.com/wp-content/themes/9to5-2015/assets/js/adsbygoogle.js"></script>

               <!-- Google Tag Manager -->
		<script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
				new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
				j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
				'https://www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
			})(window,document,'script','dataLayer','GTM-THGGVXB');</script>
		<!-- End Google Tag Manager -->
			
<!-- This site is optimized with the Yoast SEO Premium plugin v9.2.1 - https://yoast.com/wordpress/plugins/seo/ -->
<meta name="description" content="Over the past week, the narrative around Google&#039;s messaging apps has been defined by planned deprecations that 9to5Google first reported about..."/>
<link rel="canonical" href="https://9to5google.com/2018/12/07/google-messaging-allo-hangouts-future/" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:description" content="Over the past week, the narrative around Google&#039;s messaging apps has been defined by planned deprecations that 9to5Google first reported about..." />
<meta name="twitter:title" content="Say goodbye? I say Allo: A brief look at the past, present, and future of Google messaging - 9to5Google" />
<meta name="twitter:site" content="@9to5Google" />
<meta name="twitter:image" content="https://9to5google.com/wp-content/uploads/sites/4/2018/12/google_messaging_apps_1.jpg?quality=82&#038;strip=all" />
<meta name="twitter:creator" content="@9to5Google" />
<script type='application/ld+json'>{"@context":"https:\/\/schema.org","@type":"Organization","url":"https:\/\/9to5google.com\/","sameAs":["https:\/\/www.facebook.com\/pages\/9to5Google\/218132111544562","https:\/\/www.instagram.com\/9to5google","https:\/\/www.youtube.com\/c\/9to5google","https:\/\/twitter.com\/9to5Google"],"@id":"https:\/\/9to5google.com\/#organization","name":"9to5Google","logo":"https:\/\/9to5google.com\/wp-content\/uploads\/sites\/4\/2018\/09\/9to5-google-logo.png"}</script>
<!-- / Yoast SEO Premium plugin. -->

<link rel='dns-prefetch' href='//s0.wp.com' />
<link rel='dns-prefetch' href='//pagead2.googlesyndication.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="9to5Google &raquo; Feed" href="https://9to5google.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="9to5Google &raquo; Comments Feed" href="https://9to5google.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="9to5Google &raquo; Say goodbye? I say Allo: A brief look at the past, present, and future of Google messaging Comments Feed" href="https://9to5google.com/2018/12/07/google-messaging-allo-hangouts-future/feed/" />
		<link href="https://9to5google.com/wp-content/themes/9to5-2015/images/favicons/9to5google/9to5google-touch-icon-iphone.png" rel="apple-touch-icon" />
		<link href="https://9to5google.com/wp-content/themes/9to5-2015/images/favicons/9to5google/9to5google-touch-icon-ipad.png" rel="apple-touch-icon" sizes="152x152" />
		<link href="https://9to5google.com/wp-content/themes/9to5-2015/images/favicons/9to5google/9to5google-touch-icon-ipad-retina.png" rel="apple-touch-icon" sizes="167x167" />
		<link href="https://9to5google.com/wp-content/themes/9to5-2015/images/favicons/9to5google/9to5google-touch-icon-iphone-retina.png" rel="apple-touch-icon" sizes="180x180" />
		<link href="https://9to5google.com/wp-content/themes/9to5-2015/images/favicons/9to5google/9to5google-icon-hires.png" rel="icon" sizes="192x192" />
		<link href="https://9to5google.com/wp-content/themes/9to5-2015/images/favicons/9to5google/9to5google-icon-normal.png" rel="icon" sizes="128x128" />
	
<!-- Jetpack Open Graph Tags -->
<meta property="og:type" content="article" />
<meta property="og:title" content="Say goodbye? I say Allo: A brief look at the past, present, and future of Google messaging" />
<meta property="og:url" content="https://9to5google.com/2018/12/07/google-messaging-allo-hangouts-future/" />
<meta property="og:description" content="Over the past week, the narrative around Google&#8217;s messaging and communication services has been defined by a spate of planned deprecations — both of which 9to5Google first reported about. Whi…" />
<meta property="article:published_time" content="2018-12-07T20:33:16+00:00" />
<meta property="article:modified_time" content="2018-12-07T20:55:27+00:00" />
<meta property="og:site_name" content="9to5Google" />
<meta property="og:image" content="https://9to5google.com/wp-content/uploads/sites/4/2018/12/google_messaging_apps_1.jpg?quality=82&#038;strip=all&#038;w=1600" />
<meta property="og:image:width" content="1600" />
<meta property="og:image:height" content="800" />
<meta property="og:locale" content="en_US" />
<meta name="twitter:creator" content="@technacity" />
<meta name="twitter:text:title" content="Say goodbye? I say Allo: A brief look at the past, present, and future of Google messaging" />
<meta name="twitter:image" content="https://9to5google.com/wp-content/uploads/sites/4/2018/12/google_messaging_apps_1.jpg?quality=82&#038;strip=all&#038;w=1600" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:site" content="@9to5google" />

<!-- End Jetpack Open Graph Tags -->
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/11\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/11\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/9to5google.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=4.9.8"}};
			!function(a,b,c){function d(a,b){var c=String.fromCharCode;l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,a),0,0);var d=k.toDataURL();l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,b),0,0);var e=k.toDataURL();return d===e}function e(a){var b;if(!l||!l.fillText)return!1;switch(l.textBaseline="top",l.font="600 32px Arial",a){case"flag":return!(b=d([55356,56826,55356,56819],[55356,56826,8203,55356,56819]))&&(b=d([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]),!b);case"emoji":return b=d([55358,56760,9792,65039],[55358,56760,8203,9792,65039]),!b}return!1}function f(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var g,h,i,j,k=b.createElement("canvas"),l=k.getContext&&k.getContext("2d");for(j=Array("flag","emoji"),c.supports={everything:!0,everythingExceptFlag:!0},i=0;i<j.length;i++)c.supports[j[i]]=e(j[i]),c.supports.everything=c.supports.everything&&c.supports[j[i]],"flag"!==j[i]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[j[i]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(h=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",h,!1),a.addEventListener("load",h,!1)):(a.attachEvent("onload",h),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),g=c.source||{},g.concatemoji?f(g.concatemoji):g.wpemoji&&g.twemoji&&(f(g.twemoji),f(g.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='googleFonts-css'  href='https://fonts.googleapis.com/css?family=Roboto%3A300%2C300italic%2C400%2C400italic%2C500%2C500italic%7CQuestrial&#038;ver=4.9.8' type='text/css' media='all' />
<link rel='stylesheet' id='all-css-2' href='https://9to5google.com/_static/??-eJyVj9EOgjAMRX/IUUGW4IPxW5atgUo3CB0h/L0Do4EHjbz1pvfc9sLUK9uFiCFCbNCjwDV2WhXnXIMRwShgRUCYbJul6QRHCLU6jnFxZpTMU/hgFCyPDl97Z6ShFPTF8hDw6MggpxPp1Fb0bGYcFGNt7PwfnnZbvYPebfyoeh5rCgnH2Bvbgu/cmFrARK5eiklnybBa/96JI2GRGJ2qDTMO8y+1hN79Ldflpaq0LosntWKysg==' type='text/css' media='all' />
<script type='text/javascript'>
/* <![CDATA[ */
var _wpmejsSettings = {"pluginPath":"\/wp-includes\/js\/mediaelement\/","classPrefix":"mejs-","stretching":"responsive"};
/* ]]> */
</script>
<script type='text/javascript' src='https://9to5google.com/_static/??-eJzTLy/QzcxLzilNSS3WzwKiwtLUokoopZdVrKOPT4FubmZ6UWJJql5uZh5QsX2uraGpsbGRibmBmUEWACVVIKU='></script>
<script type='text/javascript'>
var mejsL10n = {"language":"en","strings":{"mejs.install-flash":"You are using a browser that does not have Flash player enabled or installed. Please turn on your Flash player plugin or download the latest version from https:\/\/get.adobe.com\/flashplayer\/","mejs.fullscreen-off":"Turn off Fullscreen","mejs.fullscreen-on":"Go Fullscreen","mejs.download-video":"Download Video","mejs.fullscreen":"Fullscreen","mejs.time-jump-forward":["Jump forward 1 second","Jump forward %1 seconds"],"mejs.loop":"Toggle Loop","mejs.play":"Play","mejs.pause":"Pause","mejs.close":"Close","mejs.time-slider":"Time Slider","mejs.time-help-text":"Use Left\/Right Arrow keys to advance one second, Up\/Down arrows to advance ten seconds.","mejs.time-skip-back":["Skip back 1 second","Skip back %1 seconds"],"mejs.captions-subtitles":"Captions\/Subtitles","mejs.captions-chapters":"Chapters","mejs.none":"None","mejs.mute-toggle":"Mute Toggle","mejs.volume-help-text":"Use Up\/Down Arrow keys to increase or decrease volume.","mejs.unmute":"Unmute","mejs.mute":"Mute","mejs.volume-slider":"Volume Slider","mejs.video-player":"Video Player","mejs.audio-player":"Audio Player","mejs.ad-skip":"Skip ad","mejs.ad-skip-info":["Skip in 1 second","Skip in %1 seconds"],"mejs.source-chooser":"Source Chooser","mejs.stop":"Stop","mejs.speed-rate":"Speed Rate","mejs.live-broadcast":"Live Broadcast","mejs.afrikaans":"Afrikaans","mejs.albanian":"Albanian","mejs.arabic":"Arabic","mejs.belarusian":"Belarusian","mejs.bulgarian":"Bulgarian","mejs.catalan":"Catalan","mejs.chinese":"Chinese","mejs.chinese-simplified":"Chinese (Simplified)","mejs.chinese-traditional":"Chinese (Traditional)","mejs.croatian":"Croatian","mejs.czech":"Czech","mejs.danish":"Danish","mejs.dutch":"Dutch","mejs.english":"English","mejs.estonian":"Estonian","mejs.filipino":"Filipino","mejs.finnish":"Finnish","mejs.french":"French","mejs.galician":"Galician","mejs.german":"German","mejs.greek":"Greek","mejs.haitian-creole":"Haitian Creole","mejs.hebrew":"Hebrew","mejs.hindi":"Hindi","mejs.hungarian":"Hungarian","mejs.icelandic":"Icelandic","mejs.indonesian":"Indonesian","mejs.irish":"Irish","mejs.italian":"Italian","mejs.japanese":"Japanese","mejs.korean":"Korean","mejs.latvian":"Latvian","mejs.lithuanian":"Lithuanian","mejs.macedonian":"Macedonian","mejs.malay":"Malay","mejs.maltese":"Maltese","mejs.norwegian":"Norwegian","mejs.persian":"Persian","mejs.polish":"Polish","mejs.portuguese":"Portuguese","mejs.romanian":"Romanian","mejs.russian":"Russian","mejs.serbian":"Serbian","mejs.slovak":"Slovak","mejs.slovenian":"Slovenian","mejs.spanish":"Spanish","mejs.swahili":"Swahili","mejs.swedish":"Swedish","mejs.tagalog":"Tagalog","mejs.thai":"Thai","mejs.turkish":"Turkish","mejs.ukrainian":"Ukrainian","mejs.vietnamese":"Vietnamese","mejs.welsh":"Welsh","mejs.yiddish":"Yiddish"}};
</script>
<script type='text/javascript' src='https://9to5google.com/wp-includes/js/mediaelement/mediaelement-and-player.min.js?ver=4.2.6-78496d1'></script>
<script type='text/javascript' src='https://9to5google.com/_static/??-eJx9zEEOwjAMRNELkbpQCivEUVBIrMjBNlHjCHH7RhUbNl1+aebBpzjSwC1ihVxBMJJHRkG1v3BCafGGg5AOuR6gH8Nbbds1V7gl0k6gFR9e8OgoPBtxBCPG6JJnxuW7Vz/6LrfjPE2n83W8jHkFQnk7Fw=='></script>
<link rel='https://api.w.org/' href='https://9to5google.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://9to5google.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://9to5google.com/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress 4.9.8" />
<link rel='shortlink' href='https://wp.me/p9SZ9T-15Nx' />
<link rel="alternate" type="application/json+oembed" href="https://9to5google.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2F9to5google.com%2F2018%2F12%2F07%2Fgoogle-messaging-allo-hangouts-future%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://9to5google.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2F9to5google.com%2F2018%2F12%2F07%2Fgoogle-messaging-allo-hangouts-future%2F&#038;format=xml" />

<link rel='dns-prefetch' href='//v0.wordpress.com'/>
<style type='text/css'>img#wpstats{display:none}</style>	<script type='text/javascript' src='https://www.googletagservices.com/tag/js/gpt.js' async></script>
	<script type='text/javascript' src='https://9to5google.com/wp-content/themes/9to5-2015/assets/js/vendor/prebid1.20.0.js' async></script>
	<script>
	!function(a9,a,p,s,t,A,g){if(a[a9])return;function q(c,r){a[a9]._Q.push([c,r])}a[a9]={init:function(){q("i",arguments)},fetchBids:function(){q("f",arguments)},setDisplayBids:function(){},targetingKeys:function(){return[]},_Q:[]};A=p.createElement(s);A.async=!0;A.src=t;g=p.getElementsByTagName(s)[0];g.parentNode.insertBefore(A,g)}("apstag",window,document,"script","//c.amazon-adsystem.com/aax2/apstag.js");
	</script>
	<script>
		window.googletag = window.googletag || {};
		var googletag = googletag || {};
		googletag.cmd = googletag.cmd || [];
	</script>
		<script type="text/javascript">
	var ninetofiveHeaderBidderData = {
		districtmTag: 13893414,
		districtmDmxTag: 242604,
		sovrn: [{"sizes":[[300,250]],"below_the_fold_id":586242},{"sizes":[[728,90]],"above_the_fold_id":586239,"below_the_fold_id":586243},{"sizes":[[970,250]],"above_the_fold_id":586240,"below_the_fold_id":586244},{"sizes":[[970,90]],"above_the_fold_id":586241,"below_the_fold_id":586245}],
		appnexus: [{"below_the_fold_sizes":[[728,90],[970,90],[970,250],[300,250]],"above_the_fold_sizes":[[728,90],[970,90],[970,250]],"below_the_fold_id":13866598,"above_the_fold_id":13866595}]	};

	var aboveTheFold = true;
	/**
	 *  Build ad units from bidding partners.
	 *
	 * @param {string}  slotID       The slot ID.
	 * @param {array}   sizes        The default sizes.
	 * @param {boolean} aboveTheFold Is the ad above the fold?
	 */
	var ninetofiveGetHeaderBidderAdUnits = function( slotID, sizes, aboveTheFold ) {
		adUnits = [];

		// District M
		adUnits.push( {
			code: slotID,
			mediaTypes: { banner: { sizes: sizes } },
			bids: [	{
				bidder: 'districtm',
				params: {
					placementId: ninetofiveHeaderBidderData.districtmTag
				}
			} ]
		} );

		// District M DMX
		adUnits.push( {
			code: slotID,
			mediaTypes: { banner: { sizes: sizes } },
			bids: [	{
				bidder: 'districtmDMX',
				params: {
					dmxid: ninetofiveHeaderBidderData.districtmDmxTag,
					memberid: 101574
				}
			} ]
		} );

		// Sovrn
		ninetofiveHeaderBidderData.sovrn.forEach( function( asovrn ) {
			adUnits.push( {
				code: slotID,
				mediaTypes: { banner: { sizes: asovrn.sizes } },
				bids: [	{
					bidder: 'sovrn',
					params: {
						tagid: ( aboveTheFold && asovrn.above_the_fold_id ) ?
							asovrn.above_the_fold_id :
							asovrn.below_the_fold_id
					}
				} ]
			} );

		} );

		// Sovrn
		ninetofiveHeaderBidderData.appnexus.forEach( function( anapnexus ) {
			adUnits.push( {
				code: slotID,
				mediaTypes: { banner: {
					sizes: aboveTheFold ? anapnexus.above_the_fold_sizes : anapnexus.below_the_fold_sizes
				} },
				bids: [	{
					bidder: 'appnexus',
					params: {
						placementId: ( aboveTheFold && anapnexus.above_the_fold_id ) ?
							anapnexus.above_the_fold_id :
							anapnexus.below_the_fold_id
					}
				} ]
			} );
		} );

		return adUnits;
	};
	</script>
	<link rel="mask-icon" color="#296700" href="https://9to5google.com/wp-content/themes/9to5-2015/images/9to5-clock.svg"><link rel="amphtml" href="https://9to5google.com/2018/12/07/google-messaging-allo-hangouts-future/amp/"><link rel="icon" href="https://9to5google.com/wp-content/uploads/sites/4/2017/03/favicon-bg-none-face-white.png?w=32" sizes="32x32" />
<link rel="icon" href="https://9to5google.com/wp-content/themes/9to5-2015/images/favicons/9to5google/9to5google-icon-hires.png" sizes="192x192" />
<link rel="apple-touch-icon-precomposed" href="https://9to5google.com/wp-content/themes/9to5-2015/images/favicons/9to5google/9to5google-touch-icon-iphone-retina.png" />
<meta name="msapplication-TileImage" content="https://9to5google.com/wp-content/uploads/sites/4/2017/03/favicon-bg-none-face-white.png?w=256" />

	<style>
		.th91673b49 { padding: 10px 0; text-align: center; background: url('https://9to5google.com/wp-content/themes/9to5-2015/images/top-leaderboard-bg.png') repeat center; min-height: 110px;}
		.th91673b49 .inlinead { background-color: transparent; min-height: 1px; }
		.th91673b49 .inlinead > div { background-color: transparent; padding: 0; }

		.color-scheme-electrek .th91673b49 { background-color: #939598; }

		.ad { margin: 0 auto; }

		@media (min-width: 0px) and (max-width: 767px) { .two-up-ads { display: none; } }

		.two-up-ads, .post-leaderboard { box-sizing: border-box; width: 100%; float: left; padding-left: 0.83333%; padding-right: 0.83333%; background-color: #ECECED; padding: 25px 0; }
		.two-up-ads .ad-1, .two-up-ads .ad-2, .post-leaderboard .ad-1, .post-leaderboard .ad-2 { display: inline-block; width: 300px; height: 250px; overflow: hidden; }
		.two-up-ads .ad-1, .post-leaderboard .ad-1 { box-sizing: border-box; width: 50%; float: left; padding-left: 0.83333%; padding-right: 0.83333%; text-align: right; }
		.two-up-ads .ad-2, .post-leaderboard .ad-2 { box-sizing: border-box; width: 50%; float: right; padding-left: 0.83333%; padding-right: 0.83333%; text-align: left; padding-left: 40px; }

		@media (min-width: 0px) and (max-width: 767px) { .post-leaderboard img { width: 100%; } }

		.post-leaderboard > * { margin: 0 auto; text-align: center; display: block; }

		/** inline ads **/
		.thf05754f5 { background-color: #DCDDDE; max-width: 100%; overflow: hidden; text-align: center; }\
		.thf05754f5 > div, .thf05754f5 > ins { padding: 20px 0; margin: 0 auto; }
		.enable-fallbacks .thf05754f5 > div, .enable-fallbacks .thf05754f5 > ins { padding: 0 0 0 0; }
		@media only screen and (min-width: 768px) { .thf05754f5 > div, .thf05754f5 > ins { display: block; padding: 25px 10px 25px 0; }
		.enable-fallbacks .thf05754f5 > div, .enable-fallbacks .thf05754f5 > ins { padding: 0 0 0 0; } }

		.post-body .thf05754f5 { background-color: transparent; }

		.thabfdb541 { width: 300px; height: 250px; }
		@media (min-device-width: 320px) and (max-device-width: 479px) { .thabfdb541 { width: 300px; height: 250px; } }
		@media (min-width: 500px) { .thabfdb541 { width: 320px; height: 400px; } }
		@media (min-device-width: 480px) and (max-device-width: 767px) { .thabfdb541 { width: 300px; height: 250px; } }
		@media (min-width: 768px) { .thabfdb541 { float: right; margin-left: 20px; width: 336px; height: 280px; } }
		@media (min-width: 1000px) {
               .thabfdb541 { margin: 0 -105px 20px 20px; }
               .aside-post .thabfdb541 { margin-top: 20px; }
          }
		.enable-fallbacks .thabfdb541 { display: none !important; }

		.th6b50ef6c { display: none; }
		.enable-fallbacks .th6b50ef6c { display: block; }
		.th6b50ef6c img { max-width: 100%; }

		.th6b50ef6c.thf287934f { background: url('https://9to5google.com/wp-content/themes/9to5-2015/images/top-leaderboard-bg.png') repeat center; max-width: 100%; overflow: hidden; text-align: center; }
		.th6b50ef6c.thf287934f > div { margin: 20px auto; padding: 0 0; }

		.th10af5578 { line-height: 0; max-width: 300px; position: relative; }
		.th10af5578 h3 { background: rgba(0, 0, 0, 0.7); bottom: 0; box-sizing: border-box; color: #fff; font-size: 1.17em; font-weight: 400; line-height: 1.3; margin: 0 0; padding: 0.25em 0.5em; position: absolute; text-align: left; width: 100%; }
		.post-body .th10af5578 h3 { font-size: 1em; }
		@media (min-width: 768px) { .post-body .th10af5578 { float: right; margin-left: 20px; width: 300px; height: 250px; } }
		@media (min-width: 1000px) { .post-body .th10af5578 { margin: 0 -105px 20px 20px; } }

		.thf287934f .th10af5578 { margin: 0 auto; }
		.thfdf0ab77 { cursor: pointer }
          .th1deda670 { display: none; }
	</style>
	</head>
		<body class="post-template-default single single-post postid-260619 single-format-standard color-scheme-google infinite-scroll">
					<!-- Google Tag Manager (noscript) -->
		<noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-THGGVXB"
		                  height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
		<!-- End Google Tag Manager (noscript) -->
			
			<div></div>
			<header class="site-header js-header-normal" id="js-site-header">
				<div class="site-header-inner">

					<div class="header-logo">
						<a href="https://9to5google.com/" rel="home">
							<img src="https://9to5google.com/wp-content/uploads/sites/4/2018/10/cropped-new-9to5-google-logo.png" alt="" />
						</a>
						<button aria-expanded="false" aria-controls="js-site-switcher" id="js-button-switcher" class="js-button button-site-switcher">
									<svg class="ninetofive-icon chevron-down js-regular-icon" aria-hidden="true">
									<use
				xlink:href="https://9to5google.com/wp-content/themes/9to5-2015/images/svg-sprite-1.svg#ninetofive-icon-chevron-down"/>
		</svg>
											<svg class="ninetofive-icon chevron-up js-expanded-icon" aria-hidden="true">
									<use
				xlink:href="https://9to5google.com/wp-content/themes/9to5-2015/images/svg-sprite-1.svg#ninetofive-icon-chevron-up"/>
		</svg>
									<span class="screen-reader-text">Switch site</span>
						</button>
					</div>
					<!-- .header-logo -->

					<nav id="primary-menu" class="primary-menu">
						<button class="js-mobile-menu-prev js-button" id="js-mobile-menu-prev" data-direction="1">
									<svg class="ninetofive-icon chevron-left " aria-hidden="true">
									<use
				xlink:href="https://9to5google.com/wp-content/themes/9to5-2015/images/svg-sprite-1.svg#ninetofive-icon-chevron-left"/>
		</svg>
								</button>
						<button class="js-mobile-menu-next js-button" id="js-mobile-menu-next" data-direction="-1">
									<svg class="ninetofive-icon chevron-right " aria-hidden="true">
									<use
				xlink:href="https://9to5google.com/wp-content/themes/9to5-2015/images/svg-sprite-1.svg#ninetofive-icon-chevron-right"/>
		</svg>
								</button>
						<ul id="menu-guides" class="primary-menu-ul"><li id="menu-item-145933" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-145933"><a href="http://9to5google.com/guides">Guides</a>
<ul class="sub-menu">
	<li id="menu-item-190195" class="menu-item menu-item-type-taxonomy menu-item-object-ninetofive_guides menu-item-190195"><a href="https://9to5google.com/guides/google-corporate/">GOOG</a></li>
	<li id="menu-item-190186" class="menu-item menu-item-type-taxonomy menu-item-object-ninetofive_guides menu-item-190186"><a href="https://9to5google.com/guides/android/">Android</a></li>
	<li id="menu-item-190162" class="menu-item menu-item-type-taxonomy menu-item-object-ninetofive_guides menu-item-190162"><a href="https://9to5google.com/guides/android-basics/">Android Basics</a></li>
	<li id="menu-item-190191" class="menu-item menu-item-type-taxonomy menu-item-object-ninetofive_guides menu-item-190191"><a href="https://9to5google.com/guides/best-phones/">Best Phones</a></li>
	<li id="menu-item-244977" class="menu-item menu-item-type-taxonomy menu-item-object-ninetofive_guides menu-item-244977"><a href="https://9to5google.com/guides/google-pixel-3-xl/">Google Pixel 3 XL</a></li>
	<li id="menu-item-244979" class="menu-item menu-item-type-taxonomy menu-item-object-ninetofive_guides menu-item-244979"><a href="https://9to5google.com/guides/htc-u12/">HTC U12</a></li>
	<li id="menu-item-244978" class="menu-item menu-item-type-taxonomy menu-item-object-ninetofive_guides menu-item-244978"><a href="https://9to5google.com/guides/samsung-galaxy-s9/">Samsung Galaxy S9</a></li>
	<li id="menu-item-244980" class="menu-item menu-item-type-taxonomy menu-item-object-ninetofive_guides menu-item-244980"><a href="https://9to5google.com/guides/oneplus-6/">OnePlus 6</a></li>
	<li id="menu-item-244981" class="menu-item menu-item-type-taxonomy menu-item-object-ninetofive_guides menu-item-244981"><a href="https://9to5google.com/guides/oneplus-6t/">OnePlus 6T</a></li>
</ul>
</li>
<li id="menu-item-190111" class="menu-item menu-item-type-taxonomy menu-item-object-ninetofive_guides menu-item-has-children menu-item-190111"><a href="https://9to5google.com/guides/google/">Google</a>
<ul class="sub-menu">
	<li id="menu-item-244984" class="menu-item menu-item-type-taxonomy menu-item-object-ninetofive_guides menu-item-244984"><a href="https://9to5google.com/guides/google-pixel-2/">Google Pixel 2</a></li>
	<li id="menu-item-244985" class="menu-item menu-item-type-taxonomy menu-item-object-ninetofive_guides menu-item-244985"><a href="https://9to5google.com/guides/google-pixel-2-xl/">Google Pixel 2 XL</a></li>
	<li id="menu-item-244976" class="menu-item menu-item-type-taxonomy menu-item-object-ninetofive_guides menu-item-244976"><a href="https://9to5google.com/guides/google-pixel-3/">Google Pixel 3</a></li>
	<li id="menu-item-244983" class="menu-item menu-item-type-taxonomy menu-item-object-ninetofive_guides menu-item-244983"><a href="https://9to5google.com/guides/google-pixel-3-xl/">Google Pixel 3 XL</a></li>
	<li id="menu-item-190113" class="menu-item menu-item-type-taxonomy menu-item-object-ninetofive_guides menu-item-190113"><a href="https://9to5google.com/guides/google-home/">Google Home</a></li>
	<li id="menu-item-190114" class="menu-item menu-item-type-taxonomy menu-item-object-ninetofive_guides menu-item-190114"><a href="https://9to5google.com/guides/google-wifi/">Google Wifi</a></li>
	<li id="menu-item-190181" class="menu-item menu-item-type-taxonomy menu-item-object-ninetofive_guides menu-item-190181"><a href="https://9to5google.com/guides/google-daydream/">Google Daydream</a></li>
	<li id="menu-item-190115" class="menu-item menu-item-type-taxonomy menu-item-object-ninetofive_guides menu-item-190115"><a href="https://9to5google.com/guides/chromecast/">Chromecast</a></li>
	<li id="menu-item-190161" class="menu-item menu-item-type-taxonomy menu-item-object-ninetofive_guides menu-item-190161"><a href="https://9to5google.com/guides/nexus/">Nexus</a></li>
	<li id="menu-item-190622" class="menu-item menu-item-type-taxonomy menu-item-object-ninetofive_guides menu-item-190622"><a href="https://9to5google.com/guides/google-cardboard/">Google Cardboard</a></li>
</ul>
</li>
<li id="menu-item-145656" class="menu-item menu-item-type-taxonomy menu-item-object-ninetofive_guides menu-item-has-children menu-item-145656"><a href="https://9to5google.com/guides/android/">Android</a>
<ul class="sub-menu">
	<li id="menu-item-190109" class="menu-item menu-item-type-taxonomy menu-item-object-ninetofive_guides menu-item-190109"><a href="https://9to5google.com/guides/samsung/">Samsung</a></li>
	<li id="menu-item-190107" class="menu-item menu-item-type-taxonomy menu-item-object-ninetofive_guides menu-item-190107"><a href="https://9to5google.com/guides/motorola/">Motorola</a></li>
	<li id="menu-item-190108" class="menu-item menu-item-type-taxonomy menu-item-object-ninetofive_guides menu-item-190108"><a href="https://9to5google.com/guides/lg/">LG</a></li>
	<li id="menu-item-190110" class="menu-item menu-item-type-taxonomy menu-item-object-ninetofive_guides menu-item-190110"><a href="https://9to5google.com/guides/htc/">HTC</a></li>
	<li id="menu-item-190116" class="menu-item menu-item-type-taxonomy menu-item-object-ninetofive_guides menu-item-190116"><a href="https://9to5google.com/guides/oneplus/">OnePlus</a></li>
	<li id="menu-item-190117" class="menu-item menu-item-type-taxonomy menu-item-object-ninetofive_guides menu-item-190117"><a href="https://9to5google.com/guides/lenovo/">Lenovo</a></li>
	<li id="menu-item-190118" class="menu-item menu-item-type-taxonomy menu-item-object-ninetofive_guides menu-item-190118"><a href="https://9to5google.com/guides/huawei/">Huawei</a></li>
	<li id="menu-item-190193" class="menu-item menu-item-type-taxonomy menu-item-object-ninetofive_guides menu-item-190193"><a href="https://9to5google.com/guides/asus/">Asus</a></li>
</ul>
</li>
<li id="menu-item-145935" class="menu-item menu-item-type-taxonomy menu-item-object-ninetofive_guides menu-item-145935"><a href="https://9to5google.com/guides/wear-os/">Wear</a></li>
<li id="menu-item-145938" class="menu-item menu-item-type-taxonomy menu-item-object-ninetofive_guides menu-item-145938"><a href="https://9to5google.com/guides/android-auto/">Auto</a></li>
<li id="menu-item-145657" class="menu-item menu-item-type-taxonomy menu-item-object-ninetofive_guides menu-item-145657"><a href="https://9to5google.com/guides/android-tv/">TV</a></li>
<li id="menu-item-145658" class="menu-item menu-item-type-taxonomy menu-item-object-ninetofive_guides menu-item-has-children menu-item-145658"><a href="https://9to5google.com/guides/chromeos/">Chrome/OS</a>
<ul class="sub-menu">
	<li id="menu-item-146068" class="menu-item menu-item-type-taxonomy menu-item-object-ninetofive_guides menu-item-146068"><a href="https://9to5google.com/guides/chromebook/">Chromebooks</a></li>
	<li id="menu-item-190119" class="menu-item menu-item-type-taxonomy menu-item-object-ninetofive_guides menu-item-190119"><a href="https://9to5google.com/guides/chromecast/">Chromecast</a></li>
	<li id="menu-item-190183" class="menu-item menu-item-type-taxonomy menu-item-object-ninetofive_guides menu-item-190183"><a href="https://9to5google.com/guides/chromecast-ultra/">Chromecast Ultra</a></li>
	<li id="menu-item-190184" class="menu-item menu-item-type-taxonomy menu-item-object-ninetofive_guides menu-item-190184"><a href="https://9to5google.com/guides/chromecast-audio/">Chromecast Audio</a></li>
</ul>
</li>
<li id="menu-item-145661" class="menu-item menu-item-type-taxonomy menu-item-object-ninetofive_guides menu-item-has-children menu-item-145661"><a href="https://9to5google.com/guides/youtube/">YouTube</a>
<ul class="sub-menu">
	<li id="menu-item-190174" class="menu-item menu-item-type-taxonomy menu-item-object-ninetofive_guides menu-item-190174"><a href="https://9to5google.com/guides/youtube-tv/">YouTube TV</a></li>
	<li id="menu-item-190175" class="menu-item menu-item-type-taxonomy menu-item-object-ninetofive_guides menu-item-190175"><a href="https://9to5google.com/guides/youtube-kids/">YouTube Kids</a></li>
	<li id="menu-item-190176" class="menu-item menu-item-type-taxonomy menu-item-object-ninetofive_guides menu-item-190176"><a href="https://9to5google.com/guides/youtube-red/">YouTube Red</a></li>
</ul>
</li>
<li id="menu-item-190122" class="menu-item menu-item-type-taxonomy menu-item-object-ninetofive_guides menu-item-has-children menu-item-190122"><a href="https://9to5google.com/guides/alphabet/">Alphabet</a>
<ul class="sub-menu">
	<li id="menu-item-190125" class="menu-item menu-item-type-taxonomy menu-item-object-ninetofive_guides menu-item-190125"><a href="https://9to5google.com/guides/nest/">Nest</a></li>
	<li id="menu-item-190126" class="menu-item menu-item-type-taxonomy menu-item-object-ninetofive_guides menu-item-190126"><a href="https://9to5google.com/guides/waymo/">Waymo</a></li>
	<li id="menu-item-190127" class="menu-item menu-item-type-taxonomy menu-item-object-ninetofive_guides menu-item-190127"><a href="https://9to5google.com/guides/verily-life-sciences/">Verily Life Sciences</a></li>
	<li id="menu-item-190137" class="menu-item menu-item-type-taxonomy menu-item-object-ninetofive_guides menu-item-190137"><a href="https://9to5google.com/guides/calico/">Calico</a></li>
	<li id="menu-item-190138" class="menu-item menu-item-type-taxonomy menu-item-object-ninetofive_guides menu-item-190138"><a href="https://9to5google.com/guides/deepmind/">DeepMind</a></li>
	<li id="menu-item-190139" class="menu-item menu-item-type-taxonomy menu-item-object-ninetofive_guides menu-item-190139"><a href="https://9to5google.com/guides/jigsaw/">Jigsaw</a></li>
	<li id="menu-item-190142" class="menu-item menu-item-type-taxonomy menu-item-object-ninetofive_guides menu-item-190142"><a href="https://9to5google.com/guides/google-ventures/">Google Ventures</a></li>
	<li id="menu-item-190145" class="menu-item menu-item-type-taxonomy menu-item-object-ninetofive_guides menu-item-190145"><a href="https://9to5google.com/guides/google-fiber/">Google Fiber</a></li>
	<li id="menu-item-190147" class="menu-item menu-item-type-taxonomy menu-item-object-ninetofive_guides menu-item-190147"><a href="https://9to5google.com/guides/access-and-energy/">Access &amp; Energy</a></li>
</ul>
</li>
<li id="menu-item-190149" class="menu-item menu-item-type-taxonomy menu-item-object-ninetofive_guides menu-item-has-children menu-item-190149"><a href="https://9to5google.com/guides/g-suite/">G Suite</a>
<ul class="sub-menu">
	<li id="menu-item-190151" class="menu-item menu-item-type-taxonomy menu-item-object-ninetofive_guides menu-item-190151"><a href="https://9to5google.com/guides/gmail/">Gmail</a></li>
	<li id="menu-item-190152" class="menu-item menu-item-type-taxonomy menu-item-object-ninetofive_guides menu-item-190152"><a href="https://9to5google.com/guides/google-calendar/">Google Calendar</a></li>
	<li id="menu-item-190153" class="menu-item menu-item-type-taxonomy menu-item-object-ninetofive_guides menu-item-190153"><a href="https://9to5google.com/guides/google-docs/">Google Docs</a></li>
	<li id="menu-item-190154" class="menu-item menu-item-type-taxonomy menu-item-object-ninetofive_guides menu-item-190154"><a href="https://9to5google.com/guides/google-plus/">Google Plus</a></li>
	<li id="menu-item-190155" class="menu-item menu-item-type-taxonomy menu-item-object-ninetofive_guides menu-item-190155"><a href="https://9to5google.com/guides/hangouts/">Google Hangouts</a></li>
	<li id="menu-item-190156" class="menu-item menu-item-type-taxonomy menu-item-object-ninetofive_guides menu-item-190156"><a href="https://9to5google.com/guides/google-drive/">Google Drive</a></li>
	<li id="menu-item-190157" class="menu-item menu-item-type-taxonomy menu-item-object-ninetofive_guides menu-item-190157"><a href="https://9to5google.com/guides/google-keep/">Google Keep</a></li>
	<li id="menu-item-190158" class="menu-item menu-item-type-taxonomy menu-item-object-ninetofive_guides menu-item-190158"><a href="https://9to5google.com/guides/google-vault/">Google Vault</a></li>
	<li id="menu-item-190159" class="menu-item menu-item-type-taxonomy menu-item-object-ninetofive_guides menu-item-190159"><a href="https://9to5google.com/guides/jamboard/">Jamboard</a></li>
</ul>
</li>
<li id="menu-item-190188" class="menu-item menu-item-type-taxonomy menu-item-object-ninetofive_featured menu-item-190188"><a href="https://9to5google.com/feature/videos/">Videos</a></li>
</ul>					</nav>
					<!-- .primary-menu -->

					<div class="header-right-area">

						<button class="main-menu-toggle js-button" id="js-main-menu-toggle" aria-expanded="false" aria-controls="primary-menu">
									<svg class="ninetofive-icon hamburger js-regular-icon" aria-hidden="true">
									<use
				xlink:href="https://9to5google.com/wp-content/themes/9to5-2015/images/svg-sprite-1.svg#ninetofive-icon-hamburger"/>
		</svg>
											<svg class="ninetofive-icon cross js-expanded-icon" aria-hidden="true">
									<use
				xlink:href="https://9to5google.com/wp-content/themes/9to5-2015/images/svg-sprite-1.svg#ninetofive-icon-cross"/>
		</svg>
									<span class="screen-reader-text">Toggle main menu</span>
						</button>

						<div class="header-social" id="js-header-social">
							<a href="https://www.youtube.com/c/9to5google" title="View 9to5 on YouTube">
		<svg class="ninetofive-icon youtube " aria-hidden="true">
									<use
				xlink:href="https://9to5google.com/wp-content/themes/9to5-2015/images/svg-sprite-1.svg#ninetofive-icon-youtube"/>
		</svg>
		</a>
<a href="https://www.facebook.com/pages/9to5Google/218132111544562" title="Like us on Facebook">
		<svg class="ninetofive-icon facebook " aria-hidden="true">
									<use
				xlink:href="https://9to5google.com/wp-content/themes/9to5-2015/images/svg-sprite-1.svg#ninetofive-icon-facebook"/>
		</svg>
		</a>
<a href="http://twitter.com/9to5google" title="Follow us on Twitter">
		<svg class="ninetofive-icon twitter " aria-hidden="true">
									<use
				xlink:href="https://9to5google.com/wp-content/themes/9to5-2015/images/svg-sprite-1.svg#ninetofive-icon-twitter"/>
		</svg>
		</a>
<a href="http://instagram.com/9to5google" title="Follow us on Instagram">
		<svg class="ninetofive-icon instagram " aria-hidden="true">
									<use
				xlink:href="https://9to5google.com/wp-content/themes/9to5-2015/images/svg-sprite-1.svg#ninetofive-icon-instagram"/>
		</svg>
		</a>
<a href="https://itunes.apple.com/us/podcast/alphabet-scoop/id1359922601?mt=2" title="Subscribe to our weekly podcast">
		<svg class="ninetofive-icon podcast " aria-hidden="true">
									<use
				xlink:href="https://9to5google.com/wp-content/themes/9to5-2015/images/svg-sprite-1.svg#ninetofive-icon-podcast"/>
		</svg>
		</a>
<div class="header-social-more" id="js-header-social-more" aria-hidden="true"><a href="https://plus.google.com/103164410861123991325"  title="Add us on Google Plus">
		<svg class="ninetofive-icon googleplus " aria-hidden="true">
									<use
				xlink:href="https://9to5google.com/wp-content/themes/9to5-2015/images/svg-sprite-1.svg#ninetofive-icon-googleplus"/>
		</svg>
		</a>
<a href="https://9to5google.com/push/" title="Signup for Safari Notifications">
		<svg class="ninetofive-icon pushup " aria-hidden="true">
									<use
				xlink:href="https://9to5google.com/wp-content/themes/9to5-2015/images/svg-sprite-1.svg#ninetofive-icon-pushup"/>
		</svg>
		</a>
<a href="https://eepurl.com/bdw6AH" title="Signup for our email list">
		<svg class="ninetofive-icon email " aria-hidden="true">
									<use
				xlink:href="https://9to5google.com/wp-content/themes/9to5-2015/images/svg-sprite-1.svg#ninetofive-icon-email"/>
		</svg>
		</a>
</div>							<button aria-expanded="false" aria-controls="js-header-social-more" id="js-button-social" class="js-button button-social-toggle">
										<svg class="ninetofive-icon dots-expand " aria-hidden="true">
									<use
				xlink:href="https://9to5google.com/wp-content/themes/9to5-2015/images/svg-sprite-1.svg#ninetofive-icon-dots-expand"/>
		</svg>
										<span class="screen-reader-text">More social networks</span>
							</button>
						</div>
						<!-- .header-social -->

						<div class="header-icon-links">
							
<a href='https://9to5google.com/contact/' class='has-tooltip'>		<svg class="ninetofive-icon feedback " aria-hidden="true">
									<use
				xlink:href="https://9to5google.com/wp-content/themes/9to5-2015/images/svg-sprite-1.svg#ninetofive-icon-feedback"/>
		</svg>
		<span class='header-tooltip'>Submit a Tip / Contact Us</span></a>
</li>
						</div>
						<!-- .header-icon-links -->

						<div class="header-search">
							
<form role="search" class="search-form" method="get" action="https://9to5google.com/" id="js-search-form">
	<label class="search-label">
		<span class="screen-reader-text">Search</span>
		<input type="search" placeholder="search" name="s" class="searchInput" value="">
	</label>
	<button type="submit" class="search-submit">
				<svg class="ninetofive-icon search " aria-hidden="true">
									<use
				xlink:href="https://9to5google.com/wp-content/themes/9to5-2015/images/svg-sprite-1.svg#ninetofive-icon-search"/>
		</svg>
				<span class="screen-reader-text">Search</span>
	</button>
</form>
							<button aria-expanded="false" aria-controls="js-search-form" id="js-button-search" class="js-button button-search-toggle">
										<svg class="ninetofive-icon search js-regular-icon" aria-hidden="true">
									<use
				xlink:href="https://9to5google.com/wp-content/themes/9to5-2015/images/svg-sprite-1.svg#ninetofive-icon-search"/>
		</svg>
												<svg class="ninetofive-icon cross js-expanded-icon" aria-hidden="true">
									<use
				xlink:href="https://9to5google.com/wp-content/themes/9to5-2015/images/svg-sprite-1.svg#ninetofive-icon-cross"/>
		</svg>
										<span class="screen-reader-text">Toggle search</span>
							</button>
						</div>
						<!-- .header-search -->

					</div>
					<!-- .header-right-area -->

				</div>
				<!-- .site-header-inner -->

				<div class="site-switcher" id="js-site-switcher" aria-hidden="true">
					<ul class="site-switcher-list">
<li><a href='https://9to5mac.com'>		<svg class="ninetofive-icon ninetofive-mac " aria-hidden="true">
									<use
				xlink:href="https://9to5google.com/wp-content/themes/9to5-2015/images/svg-sprite-1.svg#ninetofive-icon-ninetofive-mac"/>
		</svg>
		<span class='screen-reader-text'>9to5Mac</span></a></li>
</li>

<li><a href='https://9to5toys.com'>		<svg class="ninetofive-icon ninetofive-toys " aria-hidden="true">
									<use
				xlink:href="https://9to5google.com/wp-content/themes/9to5-2015/images/svg-sprite-1.svg#ninetofive-icon-ninetofive-toys"/>
		</svg>
		<span class='screen-reader-text'>9to5Toys</span></a></li>
</li>

<li><a href='https://electrek.co'><div class="ninetofive-icon ninetofive-electrek"></div><span class='screen-reader-text'>Electrek</span></a></li>
</li>

<li class='menu-item-dronedj'><a href='https://www.dronedj.com'><div class="ninetofive-icon ninetofive-dronedj"></div><span class='screen-reader-text'>DroneDJ</span></a></li>
</li>

<li class='site-switcher-text-only'><a href='https://9to5mac.com/about/'>About</a></li>
</li>

<li class='site-switcher-text-only'><a href='https://9to5mac.com/community/'>Community</a></li>
</li>
</ul>				</div>
				<!-- .site-switcher -->

			</header>
			<!-- .site-header -->

			<div class="site-header-placeholder"></div>
			
			<div class="order-control">
				
				
				<div class="th91673b49 ad-container ad-container--leaderboard order-control__mobile-top">
					<div id="div-gpt-ad-1436850350386-0" class="inlinead"></div>
<script type='text/javascript'>
	// Make sure that nineto5ads exists, it will load ad once google tag exists
	window.nineto5ads = window.nineto5ads|| [];

	var apstagSlots = [];
	var adUnits = [];
	if ( 'undefined' !== typeof ninetofiveGetHeaderBidderAdUnits ) {
		adUnits = ninetofiveGetHeaderBidderAdUnits( "\/1049447\/9to5google-728x90-TopMain-R", [[728,90]], true );
	}
	apstagSlots.push( {
		slotID: "div-gpt-ad-1436850350386-0",
		slotName: "\/1049447\/9to5google-728x90-TopMain-R",
		sizes: [[728,90]]
	} );

	var slotID = "\/1049447\/9to5google-728x90-TopMain-R";</script><div class="th5ab4b74c thbda1bf79"><div class="thfdf0ab77"><img src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" class="th1deda670"/></div></div><div class="th77c0731a thd0c9ccc2"><div class="thfdf0ab77"><img src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" class="th1deda670"/></div></div><div class="thae8b23c1 th65d2083d"><div class="thfdf0ab77"><img src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" class="th1deda670"/></div></div><div class="the973188f thfd0f1947"><div class="thfdf0ab77"><img src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" class="th1deda670"/></div></div><div class="th1c03414d th5700f671"><div class="thfdf0ab77"><img src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" class="th1deda670"/></div></div><div class="th5aac46ba thc1354f15"><div class="thfdf0ab77"><img src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" class="th1deda670"/></div></div><div class="thcb711e89 thc84cf502"><div class="thfdf0ab77"><img src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" class="th1deda670"/></div></div><div class="th8a0c9dbd th76643bdd"><div class="thfdf0ab77"><img src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" class="th1deda670"/></div></div><div class="th779cfd3e th82762bd3"><div class="thfdf0ab77"><img src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" class="th1deda670"/></div></div><div class="th99e0ddc1 thfa900f8b"><div class="thfdf0ab77"><img src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" class="th1deda670"/></div></div><div class="th21616264 th9b62ad4a"><div class="thfdf0ab77"><img src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" class="th1deda670"/></div></div><div class="th8b7fad06 thd48c2477"><div class="thfdf0ab77"><img src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" class="th1deda670"/></div></div><div class="th91ecec9f thbee4fc96"><div class="thfdf0ab77"><div class="th6b50ef6c th1c2fc94f"><div class="thfdf0ab77" data-thb5acf372="http://amzn.to/2ptg1ma"><img src="https://9to5google.com/wp-content/uploads/sites/4/2017/05/best-usb-c_amz.jpg?quality=82&strip=all"/></div></div></div></div><div class="th25b24c7c th50a553fe"><div class="thfdf0ab77"><img src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" class="th1deda670"/></div></div><div class="th8e3578cb th1d6c7233"><div class="thfdf0ab77"><img src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" class="th1deda670"/></div></div><div class="th0605b035 theaa770c0"><div class="thfdf0ab77"><img src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" class="th1deda670"/></div></div><div class="th7c753f1e th57d091f4"><div class="thfdf0ab77"><img src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" class="th1deda670"/></div></div><div class="thb6877ce8 th5730b85b"><div class="thfdf0ab77"><img src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" class="th1deda670"/></div></div><div class="th16d84b72 th7d342ba5"><div class="thfdf0ab77"><img src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" class="th1deda670"/></div></div><div class="thbe45b0b2 th3195ab6c"><div class="thfdf0ab77"><img src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" class="th1deda670"/></div></div><div class="th42582e49 th40615691"><div class="thfdf0ab77"><img src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" class="th1deda670"/></div></div><div class="th066e5271 the4723c99"><div class="thfdf0ab77"><img src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" class="th1deda670"/></div></div><div class="theae4dce5 thaef6765f"><div class="thfdf0ab77"><img src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" class="th1deda670"/></div></div><div class="th520a7559 th10a81aaf"><div class="thfdf0ab77"><img src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" class="th1deda670"/></div></div>				</div>

			</div><!-- .order-control -->
			
		<div id="content">
					<div class="news-feed-header">
				<div class="elastic-container">
					<div class="currently-reading">
						<p>Today</p>
					</div><!-- .currently-reading -->


				</div><!-- .elastic-container -->
			</div><!-- .news-feed-header -->
			<div id="news-placeholder"></div>

		<article class="post-content" itemscope itemtype="http://schema.org/NewsArticle">
				<div class="elastic-container">
					<h1 class="post-title" itemprop="headline"><a href="https://9to5google.com/2018/12/07/google-messaging-allo-hangouts-future/" itemprop="mainEntityOfPage">Say goodbye? I say Allo: A brief look at the past, present, and future of Google messaging</a></h1>
					<div class="post-meta">
						<p class="byline" itemprop="author" itemscope itemtype="https://schema.org/Person">
							<a href="https://9to5google.com/author/technacity/">
								<span itemprop="name">Abner Li</span>
							</a>
						</p>
						<p class="time-twitter">
							- Dec. 7th 2018 12:33 pm PT
								<div class="icon-twitter"></div>
								<p><a href="https://twitter.com/technacity" target="_blank" class="twitter-handle">@technacity</a></p>
						</p>


							<div class="tags">
								<div class="post-cats">
										<a href="https://9to5google.com/feature/feature/" title="View all posts in Feature" class="featured_tag">Feature</a>
								</div><!-- .post-cats -->
							</div><!-- .tags -->

						<meta itemprop="keywords" content="Google Duo,Android Messages,RCS,Hangouts Meet,Hangouts Chat,"/>
						<meta itemprop="datePublished" content="2018-12-07 12:33:16"/>
						<meta itemprop="dateModified" content="2018-12-07 12:55:27"/>
					</div><!-- .post-meta -->
				</div><!-- .elastic-container -->
				<div class="feat-image-wrapper">
						<div itemprop="image" itemscope itemtype="https://schema.org/ImageObject">
							<meta itemprop="url" content="https://9to5google.com/wp-content/uploads/sites/4/2018/12/google_messaging_apps_1.jpg?quality=82&#038;strip=all&#038;w=1600">
							<meta itemprop="height" content="800">
							<meta itemprop="width" content="1600">
						</div>
						<div class="feat-image wide">
							<img src="https://9to5google.com/wp-content/uploads/sites/4/2018/12/google_messaging_apps_1.jpg?quality=82&#038;strip=all&#038;w=1600" srcset="https://i2.wp.com/9to5google.com/wp-content/uploads/sites/4/2018/12/google_messaging_apps_1.jpg?resize=320%2C0&amp;quality=82&amp;strip=all&amp;ssl=1 320w, https://i2.wp.com/9to5google.com/wp-content/uploads/sites/4/2018/12/google_messaging_apps_1.jpg?resize=640%2C0&amp;quality=82&amp;strip=all&amp;ssl=1 640w, https://i2.wp.com/9to5google.com/wp-content/uploads/sites/4/2018/12/google_messaging_apps_1.jpg?resize=1024%2C0&amp;quality=82&amp;strip=all&amp;ssl=1 1024w, https://i2.wp.com/9to5google.com/wp-content/uploads/sites/4/2018/12/google_messaging_apps_1.jpg?resize=1500%2C0&amp;quality=82&amp;strip=all&amp;ssl=1 1500w, https://i2.wp.com/9to5google.com/wp-content/uploads/sites/4/2018/12/google_messaging_apps_1.jpg?resize=2000%2C0&amp;quality=82&amp;strip=all&amp;ssl=1 2000w, https://i2.wp.com/9to5google.com/wp-content/uploads/sites/4/2018/12/google_messaging_apps_1.jpg?resize=2500%2C0&amp;quality=82&amp;strip=all&amp;ssl=1 2500w">
						</div><!-- .feat-image -->
					<div class="post-social-mobile">
						<a href="https://9to5google.com/2018/12/07/google-messaging-allo-hangouts-future/#comments" class="comments" itemprop="discussionUrl"><span class="dsq-postid" data-dsqidentifier="260619 https://9to5google.com/?p=260619">0</span></a>
						<div class="sharedaddy sd-sharing-enabled"><div class="robots-nocontent sd-block sd-social sd-social-text sd-sharing"><div class="sd-content"><ul><li class="share-facebook"><a rel="nofollow noopener noreferrer" data-shared="sharing-facebook-260619" class="share-facebook sd-button no-icon" href="https://9to5google.com/2018/12/07/google-messaging-allo-hangouts-future/?share=facebook" target="_blank" title="Click to share on Facebook"><span>Facebook</span></a></li><li class="share-twitter"><a rel="nofollow noopener noreferrer" data-shared="sharing-twitter-260619" class="share-twitter sd-button no-icon" href="https://9to5google.com/2018/12/07/google-messaging-allo-hangouts-future/?share=twitter" target="_blank" title="Click to share on Twitter"><span>Twitter</span></a></li><li class="share-google-plus-1"><a rel="nofollow noopener noreferrer" data-shared="sharing-google-260619" class="share-google-plus-1 sd-button no-icon" href="https://9to5google.com/2018/12/07/google-messaging-allo-hangouts-future/?share=google-plus-1" target="_blank" title="Click to share on Google+"><span>Google</span></a></li><li class="share-pinterest"><a rel="nofollow noopener noreferrer" data-shared="sharing-pinterest-260619" class="share-pinterest sd-button no-icon" href="https://9to5google.com/2018/12/07/google-messaging-allo-hangouts-future/?share=pinterest" target="_blank" title="Click to share on Pinterest"><span>Pinterest</span></a></li><li class="share-linkedin"><a rel="nofollow noopener noreferrer" data-shared="sharing-linkedin-260619" class="share-linkedin sd-button no-icon" href="https://9to5google.com/2018/12/07/google-messaging-allo-hangouts-future/?share=linkedin" target="_blank" title="Click to share on LinkedIn"><span>LinkedIn</span></a></li><li class="share-reddit"><a rel="nofollow noopener noreferrer" data-shared="" class="share-reddit sd-button no-icon" href="https://9to5google.com/2018/12/07/google-messaging-allo-hangouts-future/?share=reddit" target="_blank" title="Click to share on Reddit"><span>Reddit</span></a></li><li class="share-end"></li></ul></div></div></div>
					</div><!-- .post-social-mobile -->
				</div><!-- .feat-image-wrapper -->
				<div class="elastic-container">
					<div class="post-body" itemprop="articleBody">
						<p>Over the past week, the narrative around Google&#8217;s messaging and communication services has been defined by a spate of planned deprecations — both of which <a href="https://9to5google.com/2018/12/02/google-hangouts-shutting-down/"><em>9to5Google</em> first reported about</a>. While older services will be &#8220;sunset,&#8221; the <a href="https://9to5google.com/2018/12/05/google-confirms-allo-classic-hangouts-shutdown/">company&#8217;s vision</a> for consumers hasn&#8217;t changed much <a href="https://9to5google.com/2018/07/06/google-android-messages-rcs-chat-explained/">since earlier this year</a>, revolving around RCS &#8220;Chat&#8221; and Google Duo video calling.</p>
<p>However, complicating this dual-service future now is the newly-revealed fact that the enterprise-focused Hangouts Chat and Meet <a href="https://9to5google.com/2018/12/01/hangouts-chat-meet-consumers/">will also be available to consumers</a>, and that Google Voice is still an active service. This is just the latest in Google&#8217;s tangled and sometimes incoherent strategy for simply saying &#8220;Hello.&#8221;</p>
<p><span id="more-260619"></span>
	<ins class="adsbygoogle author_ad" style="display:block;" data-ad-client="ca-pub-7114551592991368" data-ad-slot="4679583531"></ins>
<script type="text/javascript">(adsbygoogle = window.adsbygoogle || []).push({});</script>
		
</p>
<h3>Recent Past: Hangouts, Google Allo</h3>
<p>At I/O 2013, Google <a href="https://www.theverge.com/2013/5/15/4318830/inside-hangouts-googles-big-fix-for-its-messaging-mess">introduced Hangouts</a> to serve as the company&#8217;s future messaging solution that predominantly replaced the beloved Google Talk — or &#8220;Gchat.&#8221; Confusingly, it was named after the video calling portion of Google+, but nevertheless it was an okay brand that communicated the primary purpose of the app.</p>
<p>With Hangouts, Google could point users to one app — especially on phones — for SMS/MMS and instant messaging, as well as video calling. Instead of disparate services, the company would just rally around one and build new features there.</p>
<p>However, three years later, this one app strategy broke down when Google <a href="http://9to5google.com/2016/05/18/allo-is-googles-new-messaging-app-with-assistant-built-right-in-expressive-features-and-more/">introduced Allo</a> and <a href="http://9to5google.com/2016/05/18/google-launches-duo-video-app/">Duo</a> at I/O 2016. While tied to a phone number, these apps only use your digits as an identifier to reach users. Messages and video calls are handled by a cloud-based service.</p>
<p><img title="Say goodbye? I say Allo: A brief look at the past, present, and future of Google messaging" class="aligncenter wp-image-115449 size-full" src="https://9to5google.com/wp-content/uploads/sites/4/2015/08/hangouts-logo1.png" alt="" width="1215" height="497" /></p>
<p>Allo is a smart messaging app that was many users&#8217; first experience with the Google Assistant. The smart bot allowed users to ask questions textually in a somewhat conversational manner, while it could be usefully invoked within a conversation to provide answers to a group chat.</p>
<p>Another feature that debuted with Allo was Smart Reply. Google&#8217;s machine learning prowess was leveraged to analyze past messages and even images to come up with fast contextual replies. The other big area of focus was expressive features, like stickers, emoji, and a whisper/shout functionality where users could adjust the size of text.</p>
<p>While Allo was seemingly a grab bag of features, Google Duo was a much more focused offering. Its primary function was video (and later <a href="https://9to5google.com/2017/04/10/google-duo-audio-calling-worldwide/">audio</a>) calling, with Google optimizing quality for low-bandwidth networks. Knock Knock showed a live preview of you to the recipient, with the service eventually adding the ability to send video/audio voicemail.</p>
<p><div class="tiled-gallery type-rectangular tiled-gallery-unresized" data-original-width="1000" data-carousel-extra='null' itemscope itemtype="http://schema.org/ImageGallery" > <div class="gallery-row" style="width: 1000px; height: 442px;" data-original-width="1000" data-original-height="442" > <div class="gallery-group images-1" style="width: 250px; height: 442px;" data-original-width="250" data-original-height="442" > <div class="tiled-gallery-item tiled-gallery-item-small" itemprop="associatedMedia" itemscope itemtype="http://schema.org/ImageObject"> <a href="https://9to5google.com/2018/12/07/google-messaging-allo-hangouts-future/google-allo-old-1/" border="0" itemprop="url"> <meta itemprop="width" content="246"> <meta itemprop="height" content="438"> <img data-attachment-id="260620" data-orig-file="https://9to5google.com/wp-content/uploads/sites/4/2018/12/google-allo-old-1.png" data-orig-size="750,1334" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="google-allo-old-1" data-image-description="" data-medium-file="https://9to5google.com/wp-content/uploads/sites/4/2018/12/google-allo-old-1.png?w=394" data-large-file="https://9to5google.com/wp-content/uploads/sites/4/2018/12/google-allo-old-1.png?w=576" src="https://i1.wp.com/9to5google.com/wp-content/uploads/sites/4/2018/12/google-allo-old-1.png?w=246&#038;h=438&#038;quality=82&#038;strip=all&#038;ssl=1" width="246" height="438" data-original-width="246" data-original-height="438" itemprop="http://schema.org/image" title="google-allo-old-1" alt="google-allo-old-1" style="width: 246px; height: 438px;" /> </a> </div> </div> <!-- close group --> <div class="gallery-group images-1" style="width: 250px; height: 442px;" data-original-width="250" data-original-height="442" > <div class="tiled-gallery-item tiled-gallery-item-small" itemprop="associatedMedia" itemscope itemtype="http://schema.org/ImageObject"> <a href="https://9to5google.com/2018/12/07/google-messaging-allo-hangouts-future/google-allo-old-2/" border="0" itemprop="url"> <meta itemprop="width" content="246"> <meta itemprop="height" content="438"> <img data-attachment-id="260621" data-orig-file="https://9to5google.com/wp-content/uploads/sites/4/2018/12/google-allo-old-2.png" data-orig-size="695,1236" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="google-allo-old-2" data-image-description="" data-medium-file="https://9to5google.com/wp-content/uploads/sites/4/2018/12/google-allo-old-2.png?w=394" data-large-file="https://9to5google.com/wp-content/uploads/sites/4/2018/12/google-allo-old-2.png?w=576" src="https://i0.wp.com/9to5google.com/wp-content/uploads/sites/4/2018/12/google-allo-old-2.png?w=246&#038;h=438&#038;quality=82&#038;strip=all&#038;ssl=1" width="246" height="438" data-original-width="246" data-original-height="438" itemprop="http://schema.org/image" title="google-allo-old-2" alt="google-allo-old-2" style="width: 246px; height: 438px;" /> </a> </div> </div> <!-- close group --> <div class="gallery-group images-1" style="width: 250px; height: 442px;" data-original-width="250" data-original-height="442" > <div class="tiled-gallery-item tiled-gallery-item-small" itemprop="associatedMedia" itemscope itemtype="http://schema.org/ImageObject"> <a href="https://9to5google.com/2018/12/07/google-messaging-allo-hangouts-future/google-allo-old-3/" border="0" itemprop="url"> <meta itemprop="width" content="246"> <meta itemprop="height" content="438"> <img data-attachment-id="260622" data-orig-file="https://9to5google.com/wp-content/uploads/sites/4/2018/12/google-allo-old-3.png" data-orig-size="695,1236" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="google-allo-old-3" data-image-description="" data-medium-file="https://9to5google.com/wp-content/uploads/sites/4/2018/12/google-allo-old-3.png?w=394" data-large-file="https://9to5google.com/wp-content/uploads/sites/4/2018/12/google-allo-old-3.png?w=576" src="https://i1.wp.com/9to5google.com/wp-content/uploads/sites/4/2018/12/google-allo-old-3.png?w=246&#038;h=438&#038;quality=82&#038;strip=all&#038;ssl=1" width="246" height="438" data-original-width="246" data-original-height="438" itemprop="http://schema.org/image" title="google-allo-old-3" alt="google-allo-old-3" style="width: 246px; height: 438px;" /> </a> </div> </div> <!-- close group --> <div class="gallery-group images-1" style="width: 250px; height: 442px;" data-original-width="250" data-original-height="442" > <div class="tiled-gallery-item tiled-gallery-item-small" itemprop="associatedMedia" itemscope itemtype="http://schema.org/ImageObject"> <a href="https://9to5google.com/2018/12/07/google-messaging-allo-hangouts-future/google-allo-old-4/" border="0" itemprop="url"> <meta itemprop="width" content="246"> <meta itemprop="height" content="438"> <img data-attachment-id="260623" data-orig-file="https://9to5google.com/wp-content/uploads/sites/4/2018/12/google-allo-old-4.png" data-orig-size="695,1236" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="google-allo-old-4" data-image-description="" data-medium-file="https://9to5google.com/wp-content/uploads/sites/4/2018/12/google-allo-old-4.png?w=394" data-large-file="https://9to5google.com/wp-content/uploads/sites/4/2018/12/google-allo-old-4.png?w=576" src="https://i1.wp.com/9to5google.com/wp-content/uploads/sites/4/2018/12/google-allo-old-4.png?w=246&#038;h=438&#038;quality=82&#038;strip=all&#038;ssl=1" width="246" height="438" data-original-width="246" data-original-height="438" itemprop="http://schema.org/image" title="google-allo-old-4" alt="google-allo-old-4" style="width: 246px; height: 438px;" /> </a> </div> </div> <!-- close group --> </div> <!-- close row --> </div></p>
<p>Back then, Google said that Hangouts would remain and <a href="https://9to5google.com/2016/08/16/hangouts-fate-allo-duo/">shift its focus to the enterprise</a>, while consumers were advised to use Allo and Duo. Over time, it emerged that the new enterprise focus would manifest itself as Hangouts Chat and Hangouts Meet.</p>
<h3>Present: Messages, Allo&#8217;s death, Google Duo, Google Voice</h3>
<p>However, two years later, Google announced that it was <a href="https://9to5google.com/2018/04/19/google-rcs-chat/">&#8220;pausing investment&#8221; in Allo</a> in <a href="https://9to5google.com/2018/07/06/google-android-messages-rcs-chat-explained/">favor of its Messages app and Rich Communication Services.</a> RCS is the next-generation SMS/MMS replacement with modern features like sending high-resolution pictures and videos thanks to a cloud backend, read/sent receipts, and typing indicators.</p>
<p>Other features include larger group chats and the ability to send messages over Wi-Fi and mobile data. Aside from the standard, the Messages app already has other functionality like location and contact sharing, as well as Google Pay and a <a href="https://9to5google.com/2018/06/18/google-launch-android-messages-web/">web app</a>.</p>
<p><div class="tiled-gallery type-rectangular tiled-gallery-unresized" data-original-width="1000" data-carousel-extra='null' itemscope itemtype="http://schema.org/ImageGallery" > <div class="gallery-row" style="width: 1000px; height: 802px;" data-original-width="1000" data-original-height="802" > <div class="gallery-group images-1" style="width: 602px; height: 802px;" data-original-width="602" data-original-height="802" > <div class="tiled-gallery-item tiled-gallery-item-large" itemprop="associatedMedia" itemscope itemtype="http://schema.org/ImageObject"> <a href="https://9to5google.com/2018/07/06/google-android-messages-rcs-chat-explained/rcs-2/" border="0" itemprop="url"> <meta itemprop="width" content="598"> <meta itemprop="height" content="798"> <img data-attachment-id="234632" data-orig-file="https://9to5google.com/wp-content/uploads/sites/4/2018/07/rcs-2.png" data-orig-size="750,1000" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="rcs-2" data-image-description="" data-medium-file="https://9to5google.com/wp-content/uploads/sites/4/2018/07/rcs-2.png?w=525" data-large-file="https://9to5google.com/wp-content/uploads/sites/4/2018/07/rcs-2.png?w=750" src="https://i2.wp.com/9to5google.com/wp-content/uploads/sites/4/2018/07/rcs-2.png?w=598&#038;h=798&#038;quality=82&#038;strip=all&#038;ssl=1" width="598" height="798" data-original-width="598" data-original-height="798" itemprop="http://schema.org/image" title="rcs-2" alt="rcs-2" style="width: 598px; height: 798px;" /> </a> </div> </div> <!-- close group --> <div class="gallery-group images-1" style="width: 398px; height: 802px;" data-original-width="398" data-original-height="802" > <div class="tiled-gallery-item tiled-gallery-item-large" itemprop="associatedMedia" itemscope itemtype="http://schema.org/ImageObject"> <a href="https://9to5google.com/2018/07/06/google-android-messages-rcs-chat-explained/rcs-1/" border="0" itemprop="url"> <meta itemprop="width" content="394"> <meta itemprop="height" content="798"> <img data-attachment-id="234633" data-orig-file="https://9to5google.com/wp-content/uploads/sites/4/2018/07/rcs-1.gif" data-orig-size="296,600" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="rcs-1" data-image-description="" data-medium-file="https://9to5google.com/wp-content/uploads/sites/4/2018/07/rcs-1.gif?w=296" data-large-file="https://9to5google.com/wp-content/uploads/sites/4/2018/07/rcs-1.gif?w=296" src="https://i1.wp.com/9to5google.com/wp-content/uploads/sites/4/2018/07/rcs-1.gif?w=394&#038;h=798&#038;quality=82&#038;strip=all&#038;ssl=1" width="394" height="798" data-original-width="394" data-original-height="798" itemprop="http://schema.org/image" title="rcs-1" alt="rcs-1" style="width: 394px; height: 798px;" /> </a> </div> </div> <!-- close group --> </div> <!-- close row --> </div></p>
<p>This functionality is par for the course in a modern messaging service, but the fact that it&#8217;s carrier-centered is problematic in a variety of ways. First and foremost, it is a remarkably Western-centered, if not US-centric, approach to messaging, with most users around the world adopting cloud-based instant messaging. Secondly, it lacks meaningful end-to-end encryption.</p>
<p>The specific implementation that Google and carriers are now beginning to adopt is called the Universal Profile. This allows interoperability and the ability for subscribers to leverage these features across different carriers.</p>
<p>Carriers around the world, including the big four of AT&amp;T, Verizon, T-Mobile, and Sprint, plan to support RCS, while various OEMs have agreed to <a href="https://9to5google.com/2017/02/23/android-messages-rebrand-official-rcs-client/">preload Google&#8217;s Messages app</a> as the default RCS client for Android.</p>
<p><img title="Say goodbye? I say Allo: A brief look at the past, present, and future of Google messaging" class="aligncenter wp-image-232042 size-full" src="https://9to5google.com/wp-content/uploads/sites/4/2018/06/android-messages-web-convo-5.jpg?quality=82&amp;strip=all" alt="" width="2560" height="1600" /></p>
<p>Beyond messaging, Google Duo continues to be a success as a lightweight and super focused video calling service, now available on <a href="https://9to5google.com/2018/11/19/lenovo-smart-display-google-home-hub/">Assistant Smart Displays</a> and continually adding <a href="https://9to5google.com/2018/12/05/google-duo-faster-video-messaging/">useful features</a>.</p>
<p>Google&#8217;s other consumer messaging solution is Google Voice, which <a href="https://9to5google.com/2017/01/23/new-google-voice-redesign-android-ios-web-app/">relaunched in 2017</a> and has continually received new features in a sign that the company is fully committed to it. The VOIP service dates back to 2009 and assigns users a portable number that is cloud-based and not tied to just one phone. Users can send SMS/MMS from any devices that has the app installed or via the website.</p>
<p>Over the past two years, Voice benefited from a redesign, new mobile and web apps, as well as features like <a href="https://9to5google.com/2018/04/04/google-voice-voip-android-web-beta/">proper VOIP on Android</a>. Meanwhile, its longevity is ensured since it&#8217;s now <a href="https://9to5google.com/2018/12/02/google-voice-for-g-suite-stable/">part of G Suite</a> as an enterprise service that large business customers can use.</p>
<h3>Future: Messages, Google Duo, Hangouts Chat &amp; Meet</h3>
<p>Google plans to better integrate RCS &#8216;Chat&#8217; and Messages with existing services like Google Photos — consumer messaging is now led by the head of Google Photos — and Assistant. We&#8217;ve seen signs of the <a href="https://9to5google.com/2018/10/15/messages-3-7-apk-insight-teardown/">latter in development</a>, with the implementation likely similar to the Allo smart bot. Its adoption will increase as more carriers bring it online, with Verizon <a href="https://9to5google.com/2018/12/06/pixel-3-verizon-rcs-launch/">launching support</a> for the Pixel 3 and Pixel 3 XL on December 6th, 2018.</p>
<p>Meanwhile, the RCS future will also involve Business Messaging, so that companies can have interactive conversations with customers. For example, airlines could send a boarding pass that includes flight updates and terminal maps.</p>
<p><div class="tiled-gallery type-rectangular tiled-gallery-unresized" data-original-width="1000" data-carousel-extra='null' itemscope itemtype="http://schema.org/ImageGallery" > <div class="gallery-row" style="width: 1000px; height: 504px;" data-original-width="1000" data-original-height="504" > <div class="gallery-group images-1" style="width: 250px; height: 504px;" data-original-width="250" data-original-height="504" > <div class="tiled-gallery-item tiled-gallery-item-small" itemprop="associatedMedia" itemscope itemtype="http://schema.org/ImageObject"> <a href="https://9to5google.com/2018/02/22/rcs-business-messaging-us-launch/rcs-business-2/" border="0" itemprop="url"> <meta itemprop="width" content="246"> <meta itemprop="height" content="500"> <img data-attachment-id="213970" data-orig-file="https://9to5google.com/wp-content/uploads/sites/4/2018/02/rcs-business-2.png" data-orig-size="1378,2800" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="rcs-business-2" data-image-description="" data-medium-file="https://9to5google.com/wp-content/uploads/sites/4/2018/02/rcs-business-2.png?w=345" data-large-file="https://9to5google.com/wp-content/uploads/sites/4/2018/02/rcs-business-2.png?w=504" src="https://i0.wp.com/9to5google.com/wp-content/uploads/sites/4/2018/02/rcs-business-2.png?w=246&#038;h=500&#038;quality=82&#038;strip=all&#038;ssl=1" width="246" height="500" data-original-width="246" data-original-height="500" itemprop="http://schema.org/image" title="rcs-business-2" alt="rcs-business-2" style="width: 246px; height: 500px;" /> </a> </div> </div> <!-- close group --> <div class="gallery-group images-1" style="width: 250px; height: 504px;" data-original-width="250" data-original-height="504" > <div class="tiled-gallery-item tiled-gallery-item-small" itemprop="associatedMedia" itemscope itemtype="http://schema.org/ImageObject"> <a href="https://9to5google.com/2018/02/22/rcs-business-messaging-us-launch/rcs-business-3/" border="0" itemprop="url"> <meta itemprop="width" content="246"> <meta itemprop="height" content="500"> <img data-attachment-id="213969" data-orig-file="https://9to5google.com/wp-content/uploads/sites/4/2018/02/rcs-business-3.png" data-orig-size="1378,2800" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="rcs-business-3" data-image-description="" data-medium-file="https://9to5google.com/wp-content/uploads/sites/4/2018/02/rcs-business-3.png?w=345" data-large-file="https://9to5google.com/wp-content/uploads/sites/4/2018/02/rcs-business-3.png?w=504" src="https://i0.wp.com/9to5google.com/wp-content/uploads/sites/4/2018/02/rcs-business-3.png?w=246&#038;h=500&#038;quality=82&#038;strip=all&#038;ssl=1" width="246" height="500" data-original-width="246" data-original-height="500" itemprop="http://schema.org/image" title="rcs-business-3" alt="rcs-business-3" style="width: 246px; height: 500px;" /> </a> </div> </div> <!-- close group --> <div class="gallery-group images-1" style="width: 250px; height: 504px;" data-original-width="250" data-original-height="504" > <div class="tiled-gallery-item tiled-gallery-item-small" itemprop="associatedMedia" itemscope itemtype="http://schema.org/ImageObject"> <a href="https://9to5google.com/2018/02/22/rcs-business-messaging-us-launch/rcs-business-4/" border="0" itemprop="url"> <meta itemprop="width" content="246"> <meta itemprop="height" content="500"> <img data-attachment-id="213968" data-orig-file="https://9to5google.com/wp-content/uploads/sites/4/2018/02/rcs-business-4.png" data-orig-size="1378,2800" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="rcs-business-4" data-image-description="" data-medium-file="https://9to5google.com/wp-content/uploads/sites/4/2018/02/rcs-business-4.png?w=345" data-large-file="https://9to5google.com/wp-content/uploads/sites/4/2018/02/rcs-business-4.png?w=504" src="https://i2.wp.com/9to5google.com/wp-content/uploads/sites/4/2018/02/rcs-business-4.png?w=246&#038;h=500&#038;quality=82&#038;strip=all&#038;ssl=1" width="246" height="500" data-original-width="246" data-original-height="500" itemprop="http://schema.org/image" title="rcs-business-4" alt="rcs-business-4" style="width: 246px; height: 500px;" /> </a> </div> </div> <!-- close group --> <div class="gallery-group images-1" style="width: 250px; height: 504px;" data-original-width="250" data-original-height="504" > <div class="tiled-gallery-item tiled-gallery-item-small" itemprop="associatedMedia" itemscope itemtype="http://schema.org/ImageObject"> <a href="https://9to5google.com/2018/02/22/rcs-business-messaging-us-launch/rcs-business-1/" border="0" itemprop="url"> <meta itemprop="width" content="246"> <meta itemprop="height" content="500"> <img data-attachment-id="213971" data-orig-file="https://9to5google.com/wp-content/uploads/sites/4/2018/02/rcs-business-1.png" data-orig-size="1378,2800" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="rcs-business-1" data-image-description="" data-medium-file="https://9to5google.com/wp-content/uploads/sites/4/2018/02/rcs-business-1.png?w=345" data-large-file="https://9to5google.com/wp-content/uploads/sites/4/2018/02/rcs-business-1.png?w=504" src="https://i2.wp.com/9to5google.com/wp-content/uploads/sites/4/2018/02/rcs-business-1.png?w=246&#038;h=500&#038;quality=82&#038;strip=all&#038;ssl=1" width="246" height="500" data-original-width="246" data-original-height="500" itemprop="http://schema.org/image" title="rcs-business-1" alt="rcs-business-1" style="width: 246px; height: 500px;" /> </a> </div> </div> <!-- close group --> </div> <!-- close row --> </div></p>
<p>Meanwhile, Google plans to <a href="https://9to5google.com/2018/12/05/google-allo-shutting-down/">sunset Allo</a> in March 2019, while &#8220;<a href="https://9to5google.com/2018/12/02/google-hangouts-shutting-down/">classic&#8221; Hangouts will eventually be deprecated</a> (we reported that timeline to be sometime in 2020) in favor of Hangouts Chat and Hangouts Meet. Announced in 2017 at a Google Cloud conference, the former was presented as a Slack competitor, with the latter focused on video conferencing.</p>
<p>Hangouts Chat is focused on team communication, but does include one-to-one direct messaging. As Google offers a suite of productivity applications, having a messaging service is vital, especially as Slack takes a bigger and bigger slice of the enterprise comms market.</p>
<p>It includes bots to allow for third-party integrations, while integrating with other Google products as well. With G Suite especially, Google likes to tout how AI and machine learning will help increase productivity. Features like Smart Reply help provide contextual replies and just <a href="https://9to5google.com/2018/12/06/hangouts-chat-smart-reply/">launched this week</a>.</p>
<p><div class="tiled-gallery type-rectangular tiled-gallery-unresized" data-original-width="1000" data-carousel-extra='null' itemscope itemtype="http://schema.org/ImageGallery" > <div class="gallery-row" style="width: 1000px; height: 282px;" data-original-width="1000" data-original-height="282" > <div class="gallery-group images-1" style="width: 561px; height: 282px;" data-original-width="561" data-original-height="282" > <div class="tiled-gallery-item tiled-gallery-item-large" itemprop="associatedMedia" itemscope itemtype="http://schema.org/ImageObject"> <a href="https://9to5google.com/2017/03/09/google-hangouts-meet-chat-enterprise/screen-shot-2017-03-09-at-10-44-37-am/" border="0" itemprop="url"> <meta itemprop="width" content="557"> <meta itemprop="height" content="278"> <img data-attachment-id="170463" data-orig-file="https://9to5google.com/wp-content/uploads/sites/4/2017/03/screen-shot-2017-03-09-at-10-44-37-am-e1489085146602.png" data-orig-size="1873,936" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="hangouts-chat" data-image-description="" data-medium-file="https://9to5google.com/wp-content/uploads/sites/4/2017/03/screen-shot-2017-03-09-at-10-44-37-am-e1489085146602.png?w=700" data-large-file="https://9to5google.com/wp-content/uploads/sites/4/2017/03/screen-shot-2017-03-09-at-10-44-37-am-e1489085146602.png?w=1000" src="https://i1.wp.com/9to5google.com/wp-content/uploads/sites/4/2017/03/screen-shot-2017-03-09-at-10-44-37-am-e1489085146602.png?w=557&#038;h=278&#038;quality=82&#038;strip=all&#038;ssl=1" width="557" height="278" data-original-width="557" data-original-height="278" itemprop="http://schema.org/image" title="hangouts-chat" alt="hangouts-chat" style="width: 557px; height: 278px;" /> </a> </div> </div> <!-- close group --> <div class="gallery-group images-1" style="width: 439px; height: 282px;" data-original-width="439" data-original-height="282" > <div class="tiled-gallery-item tiled-gallery-item-large" itemprop="associatedMedia" itemscope itemtype="http://schema.org/ImageObject"> <a href="https://9to5google.com/2018/11/30/google-hangouts-meet-100-participants/hangouts_meet_100/" border="0" itemprop="url"> <meta itemprop="width" content="435"> <meta itemprop="height" content="278"> <img data-attachment-id="259487" data-orig-file="https://9to5google.com/wp-content/uploads/sites/4/2018/11/hangouts_meet_100.png" data-orig-size="640,410" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="hangouts_meet_100" data-image-description="" data-medium-file="https://9to5google.com/wp-content/uploads/sites/4/2018/11/hangouts_meet_100.png?w=640" data-large-file="https://9to5google.com/wp-content/uploads/sites/4/2018/11/hangouts_meet_100.png?w=640" src="https://i1.wp.com/9to5google.com/wp-content/uploads/sites/4/2018/11/hangouts_meet_100.png?w=435&#038;h=278&#038;quality=82&#038;strip=all&#038;ssl=1" width="435" height="278" data-original-width="435" data-original-height="278" itemprop="http://schema.org/image" title="hangouts_meet_100" alt="hangouts_meet_100" style="width: 435px; height: 278px;" /> </a> </div> </div> <!-- close group --> </div> <!-- close row --> </div></p>
<p>Meanwhile, like Duo, Hangouts Meet is focused on team video calling and not much else. Telecommunication is an important market, with solutions in hot demand for conference rooms. For example, Google has released <a href="https://9to5google.com/2018/02/06/google-hangouts-meet-jamboard-expansion/">Hangouts Meet hardware</a> that includes a camera, microphone, and Chromebox, as well as touchscreen to quickly schedule and start calls. For the enterprise, it includes features like phone dial-in, screen sharing, and more.</p>
<p>Before the classic version of Hangouts is shut down, Google confirmed that <a href="https://9to5google.com/2018/12/01/hangouts-chat-meet-consumers/">all users would have their data transitioned</a> to Chat and Meet. This would give consumers another way to communicate through a Google service and replace Hangouts chat in Gmail, but in all likelihood, this support is mostly meant to appease existing classic Hangouts users.</p>
<p><img title="Say goodbye? I say Allo: A brief look at the past, present, and future of Google messaging" class="aligncenter wp-image-260999 size-large" src="https://9to5google.com/wp-content/uploads/sites/4/2018/12/Messaging_apps2.max-1000x1000.png?w=1000" alt="" width="1000" height="158" /></p>
<p>So in the near future, all of this comes down to Google&#8217;s messaging and video efforts separated into four apps in two categories: Messages with RCS &amp; Duo for &#8220;friends,&#8221; or consumer use cases, and Hangouts Chat and Hangouts Meet for &#8220;teams&#8221; as part of G Suite, or primarily enterprise use cases.</p>
<p><em>Confused? Let us know in the comments below.</em></p>
<hr />
<p class="p1" style="text-align: center"><span class="s1"><a href="https://www.youtube.com/c/9to5google?sub_confirmation=1"><i>Check out 9to5Google on YouTube for more news:</i></a></span></p>
<p><span class="embed-youtube" style="text-align:center; display: block;"><iframe class='youtube-player' type='text/html' width='1000' height='563' src='https://www.youtube.com/embed/rblYSKz_VnI?version=3&#038;rel=1&#038;fs=1&#038;autohide=2&#038;showsearch=0&#038;showinfo=1&#038;iv_load_policy=1&#038;wmode=transparent' allowfullscreen='true' style='border:0;'></iframe></span></p>

					</div><!-- .post-body -->

				</div><!-- .elastic-container -->

				<div itemprop="publisher" itemscope itemtype="https://schema.org/Organization">
					<div itemprop="logo" itemscope itemtype="https://schema.org/ImageObject">
						<meta itemprop="url" content="https://9to5google.com/wp-content/uploads/sites/4/2018/10/cropped-new-9to5-google-logo.png">
						<meta itemprop="width" content="366">
						<meta itemprop="height" content="60">
					</div>
					<meta itemprop="name" content="9to5Google">
				</div>

				<div class="elastic-container">
					<div class="related-guides-container">
						<h1>Guides</h1>
						<div class="related-guides-list">
							<div class="related-guides-item">
								<a href="https://9to5google.com/guides/hangouts/">
								<div class="related-guides-item-image">
									<img src="https://9to5google.com/wp-content/uploads/sites/4/2016/10/google_hangouts.jpg?quality=82&#038;strip=all&#038;w=290&#038;h=145&#038;crop=1" title="Google Hangouts" alt="Google Hangouts" />
								</div>
								<h3>Google Hangouts</h3>
								<p></p>
								</a>
							</div>
							<div class="related-guides-item">
								<a href="https://9to5google.com/guides/google-allo/">
								<div class="related-guides-item-image">
									<img src="https://9to5google.com/wp-content/uploads/sites/4/2016/09/allo_logo_2-e1508806209666.jpg?quality=82&#038;strip=all&#038;w=290&#038;h=145&#038;crop=1" title="Google Allo" alt="Google Allo" />
								</div>
								<h3>Google Allo</h3>
								<p></p>
								</a>
							</div>
						</div>
							<div class="post-cats"> <a href="https://9to5google.com/guides/google-duo/" title="View all posts in Google Duo">Google Duo</a>
							 <a href="https://9to5google.com/guides/android-messages/" title="View all posts in Android Messages">Android Messages</a>
							 <a href="https://9to5google.com/guides/rcs/" title="View all posts in RCS">RCS</a>
							 <a href="https://9to5google.com/guides/hangouts-meet/" title="View all posts in Hangouts Meet">Hangouts Meet</a>
							 <a href="https://9to5google.com/guides/hangouts-chat/" title="View all posts in Hangouts Chat">Hangouts Chat</a>
							</div>
							<!-- .post-cats -->
					</div>
				</div>

			<div class="elastic-container">
				<div class="author-bio-container">
					<h2 class="bio-title">About the Author</h2>
					<div class="author-bio" itemprop="author" itemscope itemtype="https://schema.org/Person">
							<div class="author-bio-details">
								<a href="https://9to5google.com/author/technacity/">
									<img src="https://secure.gravatar.com/avatar/ba5acd965e31e2bfe2fbd4e37d8f68b9?s=512&#038;d=mm&#038;r=r" class="author-gravatar">
								</a>
								<h3>
									<a href="https://9to5google.com/author/technacity/">
										<span itemprop="name">Abner Li</span>
									</a>
								</h3>

									<p class="twitter">
										<a href="https://twitter.com/technacity" target="_blank" class="twitter-handle"><span class="icon-twitter"></span>@technacity</a>
									</p>

								<div class="author-excerpt">
									<p>Editor. Interested in the minutiae of Google and Alphabet. Tips/talk: abner@9to5g.com</p>

								</div>
						</div>
					</div>
				</div>
			</div>




				<div id="div-gpt-ad-1437016474156-0-260619" class="inlinead"></div><div class="th5ab4b74c thbda1bf79"><div class="thfdf0ab77"><img src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" class="th1deda670"/></div></div><div class="th77c0731a thd0c9ccc2"><div class="thfdf0ab77"><img src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" class="th1deda670"/></div></div><div class="thae8b23c1 th65d2083d"><div class="thfdf0ab77"><img src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" class="th1deda670"/></div></div><div class="the973188f thfd0f1947"><div class="thfdf0ab77"><img src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" class="th1deda670"/></div></div><div class="th1c03414d th5700f671"><div class="thfdf0ab77"><img src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" class="th1deda670"/></div></div><div class="th5aac46ba thc1354f15"><div class="thfdf0ab77"><img src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" class="th1deda670"/></div></div><div class="thcb711e89 thc84cf502"><div class="thfdf0ab77"><img src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" class="th1deda670"/></div></div><div class="th8a0c9dbd th76643bdd"><div class="thfdf0ab77"><img src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" class="th1deda670"/></div></div><div class="th779cfd3e th82762bd3"><div class="thfdf0ab77"><img src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" class="th1deda670"/></div></div><div class="th99e0ddc1 thfa900f8b"><div class="thfdf0ab77"><img src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" class="th1deda670"/></div></div><div class="th21616264 th9b62ad4a"><div class="thfdf0ab77"><img src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" class="th1deda670"/></div></div><div class="th8b7fad06 thd48c2477"><div class="thfdf0ab77"><img src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" class="th1deda670"/></div></div><div class="th91ecec9f thbee4fc96"><div class="thfdf0ab77"><div class="th6b50ef6c thf287934f"><div class="thfdf0ab77" data-thb5acf372="http://amzn.to/2ptg1ma"><img src="https://9to5google.com/wp-content/uploads/sites/4/2017/05/best-usb-c_amz.jpg?quality=82&strip=all"/></div></div></div></div><div class="th25b24c7c th50a553fe"><div class="thfdf0ab77"><img src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" class="th1deda670"/></div></div><div class="th8e3578cb th1d6c7233"><div class="thfdf0ab77"><img src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" class="th1deda670"/></div></div><div class="th0605b035 theaa770c0"><div class="thfdf0ab77"><img src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" class="th1deda670"/></div></div><div class="th7c753f1e th57d091f4"><div class="thfdf0ab77"><img src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" class="th1deda670"/></div></div><div class="thb6877ce8 th5730b85b"><div class="thfdf0ab77"><img src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" class="th1deda670"/></div></div><div class="th16d84b72 th7d342ba5"><div class="thfdf0ab77"><img src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" class="th1deda670"/></div></div><div class="thbe45b0b2 th3195ab6c"><div class="thfdf0ab77"><img src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" class="th1deda670"/></div></div><div class="th42582e49 th40615691"><div class="thfdf0ab77"><img src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" class="th1deda670"/></div></div><div class="th066e5271 the4723c99"><div class="thfdf0ab77"><img src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" class="th1deda670"/></div></div><div class="theae4dce5 thaef6765f"><div class="thfdf0ab77"><img src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" class="th1deda670"/></div></div><div class="th520a7559 th10a81aaf"><div class="thfdf0ab77"><img src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" class="th1deda670"/></div></div>

		</article><!-- .post-content -->

	<aside class="trending-wrapper"><div class="trending-items trending-items--single">
				<a href="https://9to5google.com/2018/12/07/google-messaging-allo-hangouts-future/" rel="bookmark">
					<div class="trending-grid-item">
						<div class="img-wrap" style="background-image: url(https://9to5google.com/wp-content/uploads/sites/4/2018/12/google_messaging_apps_1.jpg?quality=82&#038;strip=all&#038;w=1600);"></div>
						<p class="trending-excerpt">Google&#039;s messaging apps: Past, present, and future</p>
					</div>
				</a>
			
				<a href="https://9to5google.com/2018/12/07/iphone-xr-vs-pixel-3-xl-camera-comparison/" rel="bookmark">
					<div class="trending-grid-item">
						<div class="img-wrap" style="background-image: url(https://9to5google.com/wp-content/uploads/sites/4/2018/12/cam-compare-pixel-3-vs-iphone-xr.jpg?quality=82&#038;strip=all&#038;w=1600);"></div>
						<p class="trending-excerpt">Cam Compare: Pixel 3 XL vs iPhone XR</p>
					</div>
				</a>
			
				<a href="https://9to5google.com/2018/12/06/google-pixel-3-accessories-starter-kit/" rel="bookmark">
					<div class="trending-grid-item">
						<div class="img-wrap" style="background-image: url(https://9to5google.com/wp-content/uploads/sites/4/2018/12/pixel_3_starter_kit_1.jpg?quality=82&#038;strip=all&#038;w=1600);"></div>
						<p class="trending-excerpt">Google Pixel 3 Starter Kit: A few great accessories</p>
					</div>
				</a>
			
				<a href="https://9to5google.com/2018/12/06/huawei-watch-gt-review/" rel="bookmark">
					<div class="trending-grid-item">
						<div class="img-wrap" style="background-image: url(https://9to5google.com/wp-content/uploads/sites/4/2018/12/Huawei-Watch-GT-review.jpg?quality=82&#038;strip=all&#038;w=1600);"></div>
						<p class="trending-excerpt">Huawei Watch GT review</p>
					</div>
				</a>
			</div></aside>
					<div id="comments" class="comments-area post-body">
				<div class="elastic-container">
					
<div id="disqus_thread"></div>
				</div><!-- .elastic-container -->
			</div><!-- #comments.comments-area -->
			</div><!-- #content -->


	<div style="text-align:center">
		<a href="https://vip.wordpress.com/?utm_source=vip_powered_wpcom&#038;utm_medium=web&#038;utm_campaign=VIP%20Footer%20Credit&#038;utm_term=9to5google.com" rel="generator nofollow" class="powered-by-wpcom"><img src="https://9to5google.com/wp-content/mu-plugins/vip-helpers/images/vip-powered-light-small.png" width="187" height="26" alt="Powered by WordPress.com VIP" /></a>	</div>

		<script type="text/javascript">
		//<![CDATA[
		var ninetofiveInfiniteScroll = {"settings":{"id":"content","ajaxurl":"https:\/\/9to5google.com\/?infinity=scrolling","currentday":"07.12.18","order":"DESC","offset":0,"history":{"host":"9to5google.com","path":"\/2018\/12\/07\/google-messaging-allo-hangouts-future\/page\/%d\/","use_trailing_slashes":true,"parameters":""},"query_args":{"page":0,"year":2018,"monthnum":12,"day":7,"name":"google-messaging-allo-hangouts-future","error":"","m":"","p":0,"post_parent":"","subpost":"","subpost_id":"","attachment":"","attachment_id":0,"static":"","pagename":"","page_id":0,"second":"","minute":"","hour":"","w":0,"category_name":"","tag":"","cat":"","tag_id":"","author":"","author_name":"","feed":"","tb":"","paged":0,"meta_key":"","meta_value":"","preview":"","s":"","sentence":"","title":"","fields":"","menu_order":"","embed":"","category__in":[],"category__not_in":[],"category__and":[],"post__in":[],"post__not_in":[],"post_name__in":[],"tag__in":[],"tag__not_in":[],"tag__and":[],"tag_slug__in":[],"tag_slug__and":[],"post_parent__in":[],"post_parent__not_in":[],"author__in":[],"author__not_in":[],"ignore_sticky_posts":false,"suppress_filters":false,"cache_results":false,"update_post_term_cache":true,"lazy_load_term_meta":true,"update_post_meta_cache":true,"post_type":"","posts_per_page":6,"nopaging":false,"comments_per_page":"75","no_found_rows":false,"order":"DESC"},"last_post_date":"2018-12-07 12:33:16","dfp_id":"1049447","post_id":260619,"stats":"blog=146091833&host=9to5google.com&v=ext&j=1:6.8.1&x_pagetype=infinite-jetpack","google_analytics":false}};
		//]]>
	</script>
	<div style="display:none">
	</div>
<script id='loop-template' type='x-tmpl-mustache'>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</script><script id='content-template' type='x-tmpl-mustache'><div class="extended">
	{{{ post_content }}}

	{{# product_link }}
		{{# product_price }}
			<div class="product_cta_lower">
				<a href="{{ product_link }}" class="product-button{{# savings_amount }} has-savings{{/ savings_amount }}" target="_blank">
					{{# savings_amount }}
						<span class="product-savings-amount">Get this deal<br/>{{ savings_amount }}</span>
					{{/ savings_amount }}
					<span class="product-price">{{ product_price }}</span>
				</a>
			</div>
		{{/ product_price }}
	{{/ product_link }}
	
	<div class="extended-comment-cta">
	  <a href="{{ permalink }}#comments" class="comments">{{{ comment_count }}}</a>
	</div>

</div><!-- .extended -->
</script><script id='aside-template' type='x-tmpl-mustache'><div class="post-body">

	{{# featured_image }}
		{{# product_link }}
			{{# product_price }}
				<div class="product_cta_image">
					<a href="{{ product_link }}" class="product-button{{# savings_amount }} has-savings{{/ savings_amount }}" target="_blank">
						{{# savings_amount }}
							<span class="product-savings-amount">Get this deal<br/>{{ savings_amount }}</span>
						{{/ savings_amount }}
						<span class="product-price">{{ product_price }}</span>
					</a>
				</div>
			{{/ product_price }}
		{{/ product_link }}

		<div class="feat-image-wrapper">
			{{# featured_image }}
				<div class="feat-image{{ image_class }}"><img src="{{featured_image}}" srcset="{{ srcset }}"></div>
			{{/ featured_image }}
		</div><!-- .feat-image-wrapper -->
		<div class="post-social-mobile">
			<a href="{{permalink}}#comments" class="comments">{{{comment_count}}}</a>
			{{{share_buttons}}}
		</div><!-- .post-social-mobile -->

	{{/ featured_image }}
	{{{post_content}}}
	{{# meta.display_author_ad }}
		{{{ meta.author_ad }}}
	{{/ meta.display_author_ad }}

	{{# product_link }}
		{{# product_price }}
			<div class="product_cta_lower">
				<a href="{{ product_link }}" class="product-button{{# savings_amount }} has-savings{{/ savings_amount }}" target="_blank">
					{{# savings_amount }}
						<span class="product-savings-amount">Get this deal<br/>{{ savings_amount }}</span>
					{{/ savings_amount }}
					<span class="product-price">{{ product_price }}</span>
				</a>
			</div>
		{{/ product_price }}
	{{/ product_link }}

	<div class="post-cats">
		{{# featured_tags }}
    	<a href="{{tag_link}}" title="View all posts in {{tag_name}}" class="featured_tag">{{tag_name}}</a>
    {{/ featured_tags }}
		{{# categories }}
			<a href="{{cat_link}}" title="View all posts in {{cat_name}}">{{cat_name}}</a>
		{{/ categories }}
	</div><!-- .post-cats -->

	<div class="extended-comment-cta">
	  <a href="{{ permalink }}#comments" class="comments">{{{ comment_count }}}</a>
	</div>

</div><!-- .post-body -->
</script>		<script type='text/javascript'>
/* <![CDATA[ */
var globalJSVars = {"ajaxurl":"https:\/\/9to5google.com\/wp-admin\/admin-ajax.php"};
/* ]]> */
</script>
<script type='text/javascript' src='https://9to5google.com/_static/??-eJyVzNENgkAMANCFLBWkCX4YZ1EooReuvVyLJEzvjwPIAO/hXmA0DdbAWDiz4z2MoLu2hC93DsfkmG3iqnJUsC3KFk3yC/5HVZTDZvlwk0VPQNFZVILBx2rrCqXyW6Zf8syPlvrbMBD1XfoCiTRFkQ=='></script>
<script type='text/javascript' src='https://s0.wp.com/wp-content/js/devicepx-jetpack.js?ver=201849'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var countVars = {"disqusShortname":"9to5googleprod"};
/* ]]> */
</script>
<script type='text/javascript'>
/* <![CDATA[ */
var embedVars = {"disqusConfig":{"integration":"wordpress 3.0.16"},"disqusIdentifier":"260619 https:\/\/9to5google.com\/?p=260619","disqusShortname":"9to5googleprod","disqusTitle":"Say goodbye? I say Allo: A brief look at the past, present, and future of Google messaging","disqusUrl":"https:\/\/9to5google.com\/2018\/12\/07\/google-messaging-allo-hangouts-future\/","postId":"260619"};
/* ]]> */
</script>
<script type='text/javascript'>
/* <![CDATA[ */
var PushUpNotificationSettings = {"domain":"https:\/\/9to5google.com","userID":"1","websitePushID":"web.com.9to5google","webServiceURL":"https:\/\/push.10up.com","prompt":"1"};
/* ]]> */
</script>
<script type='text/javascript'>
/* <![CDATA[ */
var stylesheetDirectory = "https:\/\/9to5google.com\/wp-content\/themes\/9to5-2015";
/* ]]> */
</script>
<script type='text/javascript' src='https://9to5google.com/_static/??-eJyVjssKwjAURH/I9PZhFRfip5Q0udiUvOzkIv69bxDBhbtZnDMzdM7KpFg4Fspeji6CrMNJQFlG7wzNIJNCuAGDSRJLNWNF/1gcRra/rCyYJN/xZ6qCi99smTgwaFdSr9q66UkDXPDY0EsSsFfa4q25aLxYxscHtXD2l1f3Ieybvuva9bbe1PMVHb1elA=='></script>
<script type='text/javascript' src='//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js?ver=1.0.41'></script>
<script type='text/javascript' src='https://9to5google.com/_static/??/wp-includes/js/mediaelement/wp-mediaelement.min.js,/wp-includes/js/wp-embed.min.js?m=1533247060j'></script>

	<script>
		(function($){
			$(document.body).on('post-load', function(){
				var nodes = document.querySelectorAll('span.dsq-postid');
				for (var i = 0, url; i < nodes.length; i++) {
					var shorturl = nodes[i].getAttribute('rel');
					var new_rel = shorturl ? shorturl.replace( 'https:', 'http:' ) : '';
					nodes[i].parentNode.setAttribute('data-disqus-identifier', new_rel );
					url = nodes[i].parentNode.href.split('#', 1);
					if (url.length == 1) url = url[0];
					else url = url[1];
					nodes[i].parentNode.href = url + '#disqus_thread';
				}

				var DISQUSWIDGETS = window.DISQUSWIDGETS || {};

				if ( Object.keys(DISQUSWIDGETS).length !== 0 && DISQUSWIDGETS.constructor === Object ) {
					DISQUSWIDGETS.getCount({reset: true});
				}
			});
		})(jQuery);
	</script>

	<script type='text/javascript'>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</script>
	<script>

		// Check if our canRunAds variable is set
		if ( typeof canRunAds === 'undefined' || canRunAds === null ){
			document.body.classList.add( 'enable-fallbacks' );
		}

		(function($){
			$( '.thfdf0ab77' ).click( function () {
				window.open( $( this ).data( 'thb5acf372' ) );
				return false;
			});

			$(document.body).on('post-load', function(){
				$( '.thfdf0ab77' ).click( function () {
					window.open( $( this ).data( 'thb5acf372' ) );
					return false;
				});
			});
		})(jQuery);
	</script>
<script type='text/javascript' src='https://stats.wp.com/e-201849.js' async='async' defer='defer'></script>
<script type='text/javascript'>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:6.8.1',blog:'146091833',post:'260619',tz:'-8',srv:'9to5google.com'} ]);
	_stq.push([ 'clickTrackerInit', '146091833', '260619' ]);
</script>
<!-- Tracking Codes -->          <script type="text/javascript" src="//s.skimresources.com/js/3947X1518523.skimlinks.js"></script>
		<!-- End Tracking Codes -->
	</body>
</html>